IC2 1.97 Over Compatability! (Awesome Bug That They Should Never Fix!)

  • Does over compatability work for you? Do some addons not work with IC2 1.97? 25

    1. Yeah, over compatability works great for me! (16) 64%
    2. I've gotta mod that doesn't work. (Please post it!) (5) 20%

    Industrial Craft 2 1.97 has over compatability! (thats a phrase I'm using that is the reason that my upcoming modpack is going to be awesome, it is in developement and is unofficially called U-XPLORE) But, to shorten things up ;), ALMOST every addon mod that is desinged for MC 1.1 or later or IC2 1.90 are compatable with MC 1.2.5 and IC2 1.97! I first figured that out when I really wanted the BC-IC2 Crossover Mod, but it is designed for IC2 1.95b, but i tried installing it anyway and it worked!


    About the poll: I've removed the "no" anwser because the whole purpose was that whatever addon didn't work would be posted and then I would put it in a spoiler.


    WARNING! USE OUTDATED ADDONS WITH INDUSTRIAL CRAFT 2 1.97 AT YOUR OWN RISK! THESE ADDONS ARE NOT DESIGNED FOR AND MAY NOT WORK WITH INDUSTRIAL CRAFT 2 1.97!

    MinecraftNotch + :Quantum-Helmet: = :thumbsup:


    MinecraftChicken + :Quantum-Helmet: = ... :?:


    MinecraftCreeper + lightning + :Quantum-Helmet: = :Mining Laser: + :Nuke TNT: covered withsurrounded by :Tesla Coil:


    Our motto here at Eli's, Inc. Trade-O-Mat: "Magic to Science, Science to Magic? We've got you covered."

    The post was edited 4 times, last by EliasErik ().

  • Welcom to noob town. That only works when there's minor IC2 changes and not a major Minecraft version change. Happened once before and even then not all mods automatically work with the new version. Most do yes, but some don't.

  • Only works with MC 1.4+ (or 1.5+), when we have a Mod-API, which makes obfuscation not an issue. (And only if the Mod-API works like a Mod-API should do)

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • What, did you think incompatibility was a feature? Who are you, FlowerChild? Wait, FlowerChild is actually sane.

    1. OMG CREEPER RUN AWAY!
    2. Go away, you creeper wierdo!
    3. What ever, I'll just go around.
    4. Hup, over their heads I go!
    5. Okay Mister living grenade, I'm going to knock you into those skeletons, and I'll follow through with a nano saber. Understood? FOR THE ALMIGHTLY DRAGON LORD!