You are not logged in.

IC2 Experimental builds (jenkins):
v2.0/2.1/2.2 / 2.3 / 2.5 / 2.6 (For Minecraft 1.6.4/1.7.2/1.7.10 / 1.8.9 / 1.9.4 / 1.10)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

Dear visitor, welcome to IC² Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, April 12th 2015, 10:00pm

Issues with miner.....

Hello, my first post here so please excuse me if it is in the wrong place.


I am using Industrialcraft2 experimental v 2.2.706

this is a multiplayer 1.7.10 environment on survival.


i just built a miner and plopped it down like i always do. using a generator and battbox to power it. Insert regular mining drill and an OD scanner with mining pipes..... and nothing.

The generator is functioning and the battbox is full of EU.... yet the miner does not do anything.

has something changed in the operation of the miner? there are no beehives or water anywhere near it.

any help would be appreciated.

thanks
Eddie

Chocohead

Drowning in mods.

  • "Chocohead" is male
  • Korea, Democratic People's Republic of United Kingdom

Posts: 5,981

Location: Badly generated chunks.

  • Send private message

2

Sunday, April 12th 2015, 10:14pm

Redstone signal?
145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

I see this too much.

3

Sunday, April 12th 2015, 10:28pm

Redstone signal?
I tried adding a switch on, around and even a piece of redstone in fron with the switch powering it..... still miner does nothing.

Speiger

TMT & IC2 Classic Dev

  • "Speiger" is male

Posts: 997

Location: Germany

  • Send private message

4

Monday, April 13th 2015, 12:00am

I checkt the Source.
There are a couple questions:
Is the Generator constantly running? (The generator which is applied to the Miner)?
How long did the Miner stay?

From what i readed in the source the Miner has now a progress time. He needs about 10 seconds to mine a block... At least from what i saw...

5

Monday, April 13th 2015, 12:43pm

Have you a space/inventory for the miner to place the collected material?

Speiger

TMT & IC2 Classic Dev

  • "Speiger" is male

Posts: 997

Location: Germany

  • Send private message

6

Monday, April 13th 2015, 4:49pm

Have you a space/inventory for the miner to place the collected material?
Not Required. If he can not put the Items in a Inventory he just drops them into the world.

7

Monday, April 13th 2015, 7:14pm

miner sat for an extended period of time... like hours.... did absolutely nothing.


I had a battbox connected to the generator and then the battbox was connected to the miner. The generator ran until the battbox was full and then did nothing. To test electrical flow i temporarily stuck a macerator to the piece of cable between the battbox and the miner. The macerator worked fine. So i know the electricity is not the issue.

Speiger

TMT & IC2 Classic Dev

  • "Speiger" is male

Posts: 997

Location: Germany

  • Send private message

8

Monday, April 13th 2015, 8:06pm

Thats only an idea. Place the Miner on Top of Stone instead of Grass / Dirt.
Then look whats happen. If that does not help. Try to use a Diamond drill. (Both cases. on Dirt/Grass Staying miner and on Stone Staying Miner)

If that do not work i do have no idea what could cause that.

If the Stone Trick works then the reason is that the IC2 Drill is not able to mine Dirt/Gravel/Sand and co blocks.. At least from Materials.
Because the Drill is only a Shovel and Pickaxe. (In ic2 its a little bit differend)
Shovel can only mine Snow kind Materials in IC2 thinkin.
Pickaxe can only mine Iron/Anvil/Rock materials in IC2 thinking..
Maybe that is the problem...

Chocohead

Drowning in mods.

  • "Chocohead" is male
  • Korea, Democratic People's Republic of United Kingdom

Posts: 5,981

Location: Badly generated chunks.

  • Send private message

9

Monday, April 20th 2015, 6:36pm

Going back to this, I've not been able to replicate this, no matter which drill type or scanner was used.

All I can think is that it's a multiplayer only bug, or you were doing something wrong.
145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

I see this too much.

10

Tuesday, May 12th 2015, 11:11pm

is

Well I am still having this issue. No matter what source of power, drill or scanner used.......

My server admin and i built this pack. We threw it all together and it worked. i guess at this point is anyone aware of a config entry or a possible conflicting mod that would cause this?







( I apologize if the images are too large)


As you can see it is a simple setup. Whether it be by solar or the generator the battbox is full of energy, the miner itself registers as full of energy. It simply does not do anything regardless of standard or diamond drill. Even tried swapping out the scanners.

If anyone has any ideas please let us know we are lost in the sauce.....

PS this is in single player as well as multiplayer.

Speiger

TMT & IC2 Classic Dev

  • "Speiger" is male

Posts: 997

Location: Germany

  • Send private message

11

Wednesday, May 13th 2015, 8:00am

Heh bugreport on two things i guess.
First miner does not work.
Second: Gui has a bug xD

Chocohead

Drowning in mods.

  • "Chocohead" is male
  • Korea, Democratic People's Republic of United Kingdom

Posts: 5,981

Location: Badly generated chunks.

  • Send private message

12

Wednesday, May 13th 2015, 8:58am

First miner does not work.
It still does for me though, I don't see what the difference is between our setups.
Second: Gui has a bug xD
That's just the texture pack :P
145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

I see this too much.

13

Saturday, August 22nd 2015, 5:48am

A Solution

Hello,
I had the same problem and I'm not sure if the OP has found a solution yet. For me the texture pack had a bug in the gui. The spots it was showing for the drill, pipes, and scanner card were actually part of the internal inventory. I had to place them on the far left in what looks like empty space. If you remove the IC texture pack and load the game and put those items in the miner then add the textures back in it should show you where to place them. I tried to attach a picture but I'm not sure if it worked.
Thrakna has attached the following file:

Counter:

Hits today: 30,854 | Hits yesterday: 29,849 | Hits record: 152,331 | Hits total: 65,294,218