You are not logged in.

IC2 Experimental builds: v2.0/2.1/2.2 (For Minecraft 1.6.4/1.7.2/1.7.10 → jenkins)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

Dear visitor, welcome to IC² Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, April 16th 2012, 10:49am

[Addon 1.115]Transformers BETA-1 v2.0 - Convert IC2 & BC3 energy back & forth!

Transformers BETA-1 v2.0 - IC2 v1.115 & BC 3.4.3 & MC 1.4.7

Introduction:

Spoiler Spoiler

This mod adds 4 electric engines and 4 pneumatic generators.
Electric engines are buildcraft engines which run off IndustrialCraft power.
Pneumatic generators are generators which run off the buildcraft powergrid.


I made this mod because I wasn't satisfied with the existing mods.
PowerConverters is only compatible with BC 2.2.x, and has a 20% energy loss.
IC2-BC crossover takes too much power, the conversion rate isnt right imo.
I tried to fix that in this mod, converting 2048 EU/t back & forth in the shortest setup makes you lose about 2-3%.
Electric Engines shouldnt have to be cooled IMO, so they don't have to in this release, but I may add it as an option in a future release.
Also, I found it very annoying to have different versions for different BC versions. So Transformers is compatible with both.

Ratio & Numbers:

Spoiler Spoiler


A steam engine produces 1600 MJ from one coal.
A generator produces 4000 EU from one coal.
Default conversion rate is based off this, so that's MJ : EU as 2 : 5, however you can edit that in the config.
This does mess up geothermals vs lava in combustion engines, as 1 bucket in a geothermal creates 20000 EU, and 1 bucket in a combustion creates 20000 MJ.
Therefore this mod does nerf lava in combustion engines.

Recipes:

Spoiler Spoiler

Engines:

Spoiler Spoiler

Slow Electric Engine:
(uses a Steam Engine)

Produces 1 MJ/t, defaultly uses 2.5 EU/t - equivalent to a Steam Engine.Accepts up to 32 EU/t before exploding.

Regular Electric Engine:
(uses a Combustion Engine)

Produces 5 MJ/t, defaultly uses 12.5 EU/t - equivalent to a Combustion Engine burning fuel. Accepts up to 128 EU/t before exploding.

Fast Electric Engine:
(uses 2 combustion engines)

Produces 10 MJ/t, defaultly uses 25 EU/t - equivalent to 2 combustion engines burning fuel, the exact amount a refinery/quarry/pump needs to run at max speed.
Accepts up to 512 EU/t before exploding.


Adjustable Electric Engine:
(uses 3 combustion engines)

This engine is adjustable, you can adjust the amount of MJ/t it will produce and thus the EU/t it will use. Accepts up to 2048 EU/t before exploding.
To set the amount it will produce, it has a nifty GUI:


Note that it's not able to produce more BC energy than the equivalent of 2048 EU/t in BC energy rounded down, with a maximum of 1000. (2048 * 2 / 5 = 819,2)

However, the Adjustable Electric Engine produces way more energy a regular wooden conductive pipe can handle. That's why there's a new pipe: the HV Wooden Conductive Pipe.


Pneumatic Generators:

Spoiler Spoiler

LV Pneumatic Generator:


Takes the equivalent of 32 EU/t in Buildcraft energy at maximum. Defaultly thats 12,8 MJ/t.

MV Pneumatic Generator:

Takes the equivalent of 128 EU/t in Buildcraft energy at maximum. Defaultly thats 51,2 MJ/t.

HV Pneumatic Generator:


Takes the equivalent of 512 EU/t in Buildcraft energy at maximum. Defaultly thats 204,8 MJ/t.


EV Pneumatic Generator:
(uses 2 geothermal generators)

Takes the equivalent of 2048 EU/t in Buildcraft energy at maximum. Defaultly thats 819,2 MJ/t.


Tips:
- Always use pipes. Pipes make sure machines get energy every tick, if wired directly you'll lose most of your energy.

Common errors:

- NoSuchMethodError: ic2.api.Direction.toForgeDirection()

Spoiler Spoiler

Check all your mods zip and jar files for containing ic2 folders. If you find one of those, delete them (except the one in IC2.jar itself).
This error is caused by an outdated IC2 api. Forestry usually causes it.

Changelog:

Spoiler Spoiler


v1.7b -> BETA-1 v2.0
- Fixed the dirt issue :P
- Fixed Adjustable Engines not working at low rates.
- Fixed Adjustable Engine recipe not working
- Other engine recipes now also work with charged batteries
- Changed the config abit, to cope with the new options while still featuring the old options
And the new things:
- Added the Pneumatic Convertor! This will replace the Pneumatic Generator in future versions, but still needs testing and tweaking.
Use is quite straightforward I think. It converts MJ to EU (BC to IC2 power) - but only directly. As in, no pipes, you attach your engine directly to the Convertor.
Currently only vanilla BC engines are accepted, but I plan to add support for a lot more mod engines. Using this direct conversion the conversion is always the way it should be, there is no standard 2:5 ratio or anything, the ratio is different for every engine. Try it out, play with it, report bugs. Recipe is Advanced Machine in the middle, corners empty, rest filled with golden conductive pipes.
v1.7a -> v1.7b
- No longer using deprecated ENet methods
- Should? no longer get the API ERRORS in the log. Not sure though, as I wasn't able to reproduce them.
v1.7 -> v1.7a
- Ported to 1.4.6
- No longer using deprecated registerBlock function
- Fixed default ID's to outside the worldgen area. Now defaults to 695 and 696
v1.6 -> v1.7
- Straight port to 1.4.5.
v1.5 -> v1.6
- Straight port to 1.4.2. Enjoy :)
v1.4a -> v1.5
- Cleaned up the code alot
- Now has OreDictionary support :) (better recipe handling)
- Fixed lazy implementation of canRecieveEnergyFrom
v1.4 -> v1.4a
- Fixed engine recipes not showing up in NEI.
v1.3 -> v1.4
- Updated to 1.3.2
- Less use of Reflection because of one version of buildcraft :)
- Made the main classes more readable
v1.2 -> v1.3
- Fixed engines showing explosion animation but not disappearing
- Slow, regular & fast electric engines now have a slot for transformer upgrades
- Made some changes to the config
- Made the config generate before any errors could occur
- Added an option to the config to disable version checking
- Changed the engine sprites - thanks Shadowrock!
v1.1 -> v1.2
- Fixed Pneumatic Generators transforming more than they should be able to
- Fixed transforming algorithm for BC to IC (more efficiency! Yay!)
- Transformers will now violently spit errors at your face if you dont have IC2 or BuildCraft
- Fixed NPE while fixing lava energy values.
v1.0 -> v1.1
- Fixed engines not dropping contents
- Made errors when IC2 or BC were missing more user friendly
- Now using FML

Old versions:

Spoiler Spoiler

Transformers v1.3:
- Client
- Server


And a nice picture which shows the Adjustable Electric Engine at full throttle:

Spoiler Spoiler

ULTIMATE POWAAAHH

New engine textures thanks to Shadowrock:

Spoiler Spoiler


Snyke has attached the following files:

This post has been edited 20 times, last edit by "Snyke" (Apr 2nd 2013, 12:22am)


2

Tuesday, April 17th 2012, 11:24pm

nice mod

3

Wednesday, April 18th 2012, 2:13am

Really cool looking mod. I gave it a try and I see myself using it over any of the other crossover mods. Well done :)

4

Wednesday, April 18th 2012, 3:05pm

Thanks, also, if anybody ever comes up with better sprites, feel free to post them - I really suck at spriting :P.

jppk1

Automation Engineer

  • "jppk1" is male
  • Finland

Posts: 298

Location: Underground, mining uranium for my reactors

  • Send private message

5

Wednesday, April 18th 2012, 3:53pm

DL link doesn't work

Edit: Seems like mediafire had messed something up. Works fine now.
Check out this awesome mod !

DZCreeper

Unregistered

6

Wednesday, April 18th 2012, 9:49pm

Mediafire links are down.

I really want to use this mod, please fix the links or use a new host. Or if someone could email me the mod file. shreddinmachine@gmail.com

7

Wednesday, April 18th 2012, 10:25pm

Mediafire links work fine here? Hmm. I have attached the downloads to the OP now.

DZCreeper

Unregistered

8

Friday, April 20th 2012, 3:06am

The problem is free media fire accounts only allow so much traffic per hour. Obviously your mod is popular, lots of people download it, then your account hits it's limits till the next hour.

ultimate_omega

Copper Miner

  • "ultimate_omega" is male

Posts: 1,124

Location: Ontario, Canada

  • Send private message

9

Friday, April 20th 2012, 3:24am

Gave it a shot on my old 1.2.4 world and holy crap, I can see myself using this over the IC2-BC Crossover mod (no offense to silentdeth) in my upcoming LP.

Good work.

*sees the adjustable engine* O__O Holy...

10

Friday, April 20th 2012, 11:41am

Found the energy-loss bug in buildcraft! If anyone noticed, in BuildCraft 2.2.x there is a bug which makes you lose 10-20% of the energy you put in.
As soon as energy enters a conductive pipe, energy is switched from an integer value (1,2,3,4,5,...) to a floating point value, so a number with a decimal (i.e: 3,562)
Next loss is applied. Conductive pipes defaultly lose 0,1% of energy, and golden conductive pipes 0,01%. This means your energy decreases by a small amount. For example: 4 MJ will become 3,996 MJ.
However, buildcraft machines only take integers, and when the energy is added to the machines, buildcraft casts the floating point value(3,996) to an integer value, which in this case becomes 3 MJ.
That's a big loss, so I made it round off -> 3,996 MJ will be 4 MJ, while 3,499 will be 3 MJ. This is IMO the fairest solution.

To install the fix, extract the EnergyLossFix.zip, and put its contents inside your buildcraft-transport.zip. Works for server & client.

Gima

Unregistered

11

Friday, April 20th 2012, 6:13pm

Im getting this when starting MC:

Spoiler Spoiler

Mods loaded: 52
ModLoader 1.2.3
mod_ModLoaderMp 1.2.3v3
mod_MinecraftForge 1.4.0.56
mod_GuiApiTWLExamples 1.0
mod_GuiApiBasicExample 1.1
mod_GuiApiIntermediateExample 1.0
mod_GuiApiItemTickExample 1.0
mod_Stackables 1.2.3
mod_NotEnoughItems 1.1.3
mod_TF2Teleporter 1.2.3 by pitman-87
mod_AdditionalBuildcraftObjects 0.9.1-84 (MC 1.2.3, BC 3.1.4pre)
mod_zAdditionalPipes 3.0.1 (Minecraft 1.2.3, Buildcraft 3.1.4, Forge 1.4.1.59)
mod_BuildCraftBuilders 3.1.4
mod_BuildCraftCore 3.1.4
mod_BuildCraftEnergy 3.1.4
mod_BuildCraftFactory 3.1.4
mod_BuildCraftSilicon 3.1.4
mod_BuildCraftTransport 3.1.4
mod_SneakyPipes 0.1.0 (Minecraft 1.2.3, Buildcraft 3.1.4, Forge 1.4.0.52)
mod_LogisticsPipes 0.2.2 (built with Minecraft 1.2.3, Buildcraft 3.1.4, Forge 1.4.0.52)
Compact Solar (2.0) rev 0 build 0 2.0
mod_CCTurtle 1.31
mod_ComputerCraft 1.31
mod_Elevator 1.3.1
mod_EE 1.4.0.3
mod_Forestry 1.4.0.3
mod_BuildCraftZFP (Forestry Package)
mod_IC2 v1.81
mod_PGEU 1.0.2
mod_Transformers v1.0
mod_BCIC2Crossover IBv0.07 for MC 1.2.3, BC 3.1.4, IC2 1.81
mod_IC2AdvancedMachines v3.8
mod_InvTweaks 1.40 (1.2.3)
mod_IronChest 3.0
mod_PigbearLaser 1.4
mod_RedPowerArray 2.0pr4e
mod_RedPowerCore 2.0pr4e
mod_RedPowerLighting 2.0pr4e
mod_RedPowerLogic 2.0pr4e
mod_RedPowerMachine 2.0pr4e
mod_RedPowerWiring 2.0pr4e
mod_RedPowerWorld 2.0pr4e
mod_ReiMinimap v3.0_03 [1.2.3]
mod_Somnia v21 [1.2.3]
mod_Timber 1.2.3
mod_WirelessRedstone 1.5
mod_PowerConfigurator 0.6
mod_WirelessRemote 0.5
mod_WirelessSniffer 0.6
mod_WirelessTriangulator 0.5
mod_zAdvancedSolarPanel v2.1.0
mod_ModularForceFieldSystem 1.2 Beta 6pre3_2

Minecraft has crashed!
----------------------

Minecraft has stopped running because it encountered a problem.




--- BEGIN ERROR REPORT a5381cac --------
Generated 20.04.12 19:11

Minecraft: Minecraft 1.2.3
OS: Mac OS X (i386) version 10.7.3
Java: 1.6.0_31, Apple Inc.
VM: Java HotSpot(TM) Client VM (mixed mode), Apple Inc.
LWJGL: 2.4.2
OpenGL: ATI Radeon HD 5750 OpenGL Engine version 2.1 ATI-7.18.11, ATI Technologies Inc.

java.lang.NoSuchMethodError: forge.Configuration.getOrCreateIntProperty(Ljava/lang/String;Ljava/lang/String;I)Lforge/Property;
at Transformers.TransformersCore.modsLoaded(TransformersCore.java:107)
at mod_Transformers.modsLoaded(mod_Transformers.java:44)
at ModLoader.init(ModLoader.java:898)
at ModLoader.addAllRenderers(ModLoader.java:186)
at aho.<init>(aho.java:79)
at aho.<clinit>(aho.java:9)
at net.minecraft.client.Minecraft.a(Minecraft.java:395)
at net.minecraft.client.Minecraft.run(Minecraft.java:732)
at java.lang.Thread.run(Thread.java:680)
--- END ERROR REPORT a147715b ----------


12

Friday, April 20th 2012, 7:08pm

Outdated forge version, I'm running forge 1.4.1.64

13

Saturday, April 21st 2012, 6:47pm

are u going to update it? :)

14

Saturday, April 21st 2012, 7:37pm

Can't update yet - IC2 was released for 1.2.3 & 1.2.4, BuildCraft for 1.2.3 & 1.2.5.
Will have to wait for an official IC2 for 1.2.5.

15

Monday, April 23rd 2012, 8:35pm

Would love to use this, but I have to wait on the update to 1.2.5. Right
now I have no conversion addons because none of them are up to date but
i'll be waiting on this one.

I was using the Crossover mod and I
liked it pretty okay, but I completely agree the coolant was
unnecessary and created a lot of problems for SMP which is all I play on
with a few friends. And power converters was okay except for the Energy
Link, which most of the time drew WAY too much power for something that
really didn't need that much.

In the meantime I suppose all of
my Fuel will be sitting around not generating EU. Guess I'd better get
to work on bulding a lot of fermenters and stills to compensate for my
lack of EU at the moment Lol.
╯( °□° ) ╯ ┻━┻

16

Monday, April 23rd 2012, 8:45pm

Will update tomorrow, got exams & stuff. Don't worry :)

17

Tuesday, April 24th 2012, 9:03pm

Updated! :)

Stephenseiber123

Unregistered

18

Tuesday, April 24th 2012, 9:17pm

error

Mods loaded: 18

ModLoader 1.2.5

mod_MinecraftForge 3.1.2.90

mod_Somnia v24 [1.2.5]

mod_ReiMinimap v3.0_06 [1.2.5]

mod_CraftGuide 1.4.3 for Minecraft 1.2.3

mod_ElementalCreepers 1.2.4

mod_Timber 1.2.4

mod_Shelf 1.2.5

mod_Transformers v1.1

DrZhark's Mo'Creatures v3.5.0 (MC 1.2.5)

Balkon's WeaponMod 1.2.5 v8.6.0

mod_BuildCraftCore 2.2.14

mod_BuildCraftBuilders 2.2.14

mod_BuildCraftEnergy 2.2.14

mod_BuildCraftFactory 2.2.14

mod_BuildCraftFactory 2.2.14

mod_BuildCraftTransport 2.2.14

mod_IC2 v1.95




Minecraft has crashed!

----------------------




Minecraft has stopped running because it encountered a problem.













--- BEGIN ERROR REPORT a38680c1 --------

Generated 4/24/12 2:14 PM




Minecraft: Minecraft 1.2.5

OS: Mac OS X (x86_64) version 10.7.3

Java: 1.6.0_31, Apple Inc.

VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.

LWJGL: 2.4.2

OpenGL: ATI Radeon HD 6770M OpenGL Engine version 2.1 ATI-7.18.11, ATI Technologies Inc.




java.lang.RuntimeException: java.lang.NullPointerException

at Transformers.TransformersCore.handleException(TransformersCore.java:288)

at Transformers.TransformersCore.fixIronEngineFuel(TransformersCore.java:310)

at Transformers.TransformersCore.modsLoaded(TransformersCore.java:119)

at mod_Transformers.modsLoaded(mod_Transformers.java:26)

at ModLoader.init(ModLoader.java:899)

at ModLoader.addAllRenderers(ModLoader.java:189)

at ahu.(ahu.java:77)

at ahu.(ahu.java:8)

at net.minecraft.client.Minecraft.a(Minecraft.java:394)

at net.minecraft.client.Minecraft.run(Minecraft.java:732)

at java.lang.Thread.run(Thread.java:680)

Caused by: java.lang.NullPointerException

at Transformers.TransformersCore.fixIronEngineFuel(TransformersCore.java:305)

... 9 more

--- END ERROR REPORT 6fb118d0 ----------</init>

19

Tuesday, April 24th 2012, 10:12pm

Unable to reproduce that, however i forgot to turn debug mode off so I reuploaded & try again?
Oh and you also might want to delete one version of BCFactory, seeing you have two.

20

Tuesday, April 24th 2012, 10:34pm

Yeah the debug mode must have been it because I had the EXACT same error, but I have no errors now. Just about a minute ago the server and client both load properly. Gonna try it out now. THANKS! =D
╯( °□° ) ╯ ┻━┻

Counter:

Hits today: 12,354 | Hits yesterday: 0 | Hits record: 111,506 | Hits total: 34,690,613