You are not logged in.

IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)
Experimental builds: v2.0/2.1 (For Minecraft 1.6.4/1.7.2/1.7.10 → jenkins)
IndustrialCraft recent version: v8.55_02! (For Minecraft 1.7.3 Beta)
Please pay attention on where you put your topics! (IC² doesn't belong into IC)

wcf.user.register.welcome

1

Monday, January 28th 2013, 4:25pm

[MC 1.4.7] Open Beta v1.115

I've been busy working on MiscPeripherals, so this beta was mostly made by Player. No new content, but both of us have lots of stuff in mind for when 1.5 hits.

Download: http://ic2api.player.to:8080/job/IC2_lf/….115.231-lf.jar
API: https://dl.dropbox.com/u/861751/IC2/1.11….113.205-lf.zip
Requires at least Forge 486!

Changelog:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
1.113:
- Added ore density config option
- API: Added a custom electric item interface
- API: Added documentation for the energy API
- Fixed the ancient bug with "Has Amplifier" gate triggers
- Fixed potential crash while using steam reactors
- Fixed crafting gray and light gray painters
- Fixed quantum chestplate not extinguishing fire
- Fixed memory leaks
- Fixed error display for singleplayer server-side crashes
- Increased Geothermal Generator buffer-clearing output to 32 EU/t (still generates 20 EU/t)
- Improved right-click charging for batteries
- Improved performance in storage block redstone emitting
- Iron Furnaces and Generators now accept any lava container (but not as efficient as Geothermal)
- Discharged armor does not shows up in the armor bar
- Explosions can destroy existing items

Source code

1
2
1.114:
- Fix single tick callback CME

Source code

1
2
1.115:
- Fix BC Capacitor Trigger

This post has been edited 9 times, last edit by "RichardG" (Mar 17th 2013, 1:13am)


Mister_Omega

Copper Miner

  • "Mister_Omega" is male

Posts: 1,131

Location: Ontario, Canada

  • Send private message

2

Monday, January 28th 2013, 5:28pm

Yay!

EDIT: Will add-ons break with this update?

This post has been edited 2 times, last edit by "Mister_Omega" (Jan 28th 2013, 6:29pm)


Kane Hart

Godcraft.Com Administrator

    Canada

Posts: 2,294

Location: Barrie, Ontario, Canada

  • Send private message

3

Monday, January 28th 2013, 7:46pm

Forge 509 here. Seems like version 201 if I recalled started to break IC for me (Server) and forge 509 or should be ;)

http://pastebin.com/ums4HdTi


Let me know if I derped up :P
Check out my GregTech Server .:Here:.
Check out my Brand New 1.6.4 Let's Play Series .:Here:.

4

Monday, January 28th 2013, 9:11pm

should be fixed in 1.114

Kane Hart

Godcraft.Com Administrator

    Canada

Posts: 2,294

Location: Barrie, Ontario, Canada

  • Send private message

5

Monday, January 28th 2013, 9:38pm

should be fixed in 1.114
Thanks, Confirmed the fix in 206 (Build)!

keep up the good work player!
Check out my GregTech Server .:Here:.
Check out my Brand New 1.6.4 Let's Play Series .:Here:.

6

Tuesday, January 29th 2013, 3:38am

I'll post this properly on the bug tracking site as soon as I get a free minute or two, but for now, I think the sound fix regressed and is now spamming up the client console again. These were being generated by the 64 recyclers I have, of which only about 12-15 were in use at any one time at the moment.

Spoiler Spoiler

2013-01-28 19:36:11 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:11 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:11 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:20 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:20 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:20 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:20 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:29 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:29 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:30 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:30 [INFO] [STDOUT] Channel null in method 'stop'

Forecaster

Tree Miner

  • "Forecaster" is male

Posts: 207

Location: Sweden

  • Send private message

7

Tuesday, January 29th 2013, 12:26pm

Well, there's no crash when connecting an RP2 pipe to a nuclear reactor now.

But it doesn't output any steam. Not even if you try to pump it out.
Railcraft Boiler Calculator(Now updated to 8.3!)

Minecraft Online ID Resolver BETA! Come discuss/report bugs in #towerofawesome @ esper.net

8

Tuesday, January 29th 2013, 5:02pm

I'll post this properly on the bug tracking site as soon as I get a free minute or two, but for now, I think the sound fix regressed and is now spamming up the client console again. These were being generated by the 64 recyclers I have, of which only about 12-15 were in use at any one time at the moment.

Spoiler Spoiler

2013-01-28 19:36:11 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:11 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:11 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:20 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:20 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:20 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:20 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:29 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:29 [INFO] [STDOUT] Channel null in method 'stop'
2013-01-28 19:36:30 [INFO] [STDOUT] Error in class 'SourceLWJGL OpenAL'
2013-01-28 19:36:30 [INFO] [STDOUT] Channel null in method 'stop'
Isn't this a vanilla Minecraft error? Been seeing that for years before I even heard of IC2.

9

Tuesday, January 29th 2013, 6:07pm

Kids these days...

wish I had the banhammer

PS: For some weird reason, my posts have URLs, smileys and BBcode disabled by default.

This post has been edited 1 times, last edit by "RichardG" (Nov 25th 2013, 4:22pm)


Wliu

The Silent Engineer

  • "Wliu" is male

Posts: 254

Location: 50DKP

  • Send private message

10

Tuesday, January 29th 2013, 10:48pm

OptiFine C1 and Forge .516+ (I've tested 516 and 518) work fine.
I think sp614x fixed all the Forge stuff in Cxxx.
EDIT: C2 works fine too.
hi~ :P

This post has been edited 1 times, last edit by "Wliu" (Jan 29th 2013, 11:07pm)


pazzoeo

Tree Cutter

  • "pazzoeo" is male
  • Italy

Posts: 3

Location: Viterbo, Italia

  • Send private message

11

Wednesday, January 30th 2013, 7:27pm

I can't download it...
I'm Italian. Italian is a Latin language, English is a Germanic language. It's like speaking Japanese, with only one difference: English is everywhere so it's easy to learn. SO if I write something that breaks all the grammatical rules, READ THIS. Or I will put a Nuclear Reactor full of Quadra-Uranium Cell WITHOUT WATER, ICE, COOLANT CELL ECC. ON YOUR REAL HOUSE.
:Reactor:

Wliu

The Silent Engineer

  • "Wliu" is male

Posts: 254

Location: 50DKP

  • Send private message

12

Wednesday, January 30th 2013, 9:56pm

Working fine for me...try again?
hi~ :P

pazzoeo

Tree Cutter

  • "pazzoeo" is male
  • Italy

Posts: 3

Location: Viterbo, Italia

  • Send private message

13

Wednesday, January 30th 2013, 10:39pm

Now works :D
I'm Italian. Italian is a Latin language, English is a Germanic language. It's like speaking Japanese, with only one difference: English is everywhere so it's easy to learn. SO if I write something that breaks all the grammatical rules, READ THIS. Or I will put a Nuclear Reactor full of Quadra-Uranium Cell WITHOUT WATER, ICE, COOLANT CELL ECC. ON YOUR REAL HOUSE.
:Reactor:

14

Thursday, January 31st 2013, 3:12am

Isn't this a vanilla Minecraft error? Been seeing that for years before I even heard of IC2.


No, this is directly related to IC2 sound effects. It's the only mod that causes these errors in the client console log and it only happens with sound enabled. It does not happen with other mods sound effects (TC3, Mystcraft, Portalgun, Gravity Gun, etc) and it's been a problem in the past that seemed fixed for awhile, but seems to be back again. I've been extremely busy IRL so I haven't had a chance to put a proper bug report up, I'm sorry about that.

15

Friday, February 1st 2013, 5:22am

I know this has been asked already...

...But it wasn't answered. Is this update an addon-breaker, or can someone just update IC2 & still use addons for 1.112?
(If so,:Wrench:time, things could use updating. Let's see, :Glass Fibre: goes here... Take :Tesla Coil:, plug it into :MFS-Unit:, and apply a full 10,000,000 EU. Why is it not working...?)
:Nuke TNT: = Answer to all problems. Including that creeper camping right outside the door of your glass house.

Galaxy_2Alex

No individual title at all please

  • "Galaxy_2Alex" is male
  • Austria

Posts: 12

Location: Salzburg, Austria

  • Send private message

16

Friday, February 1st 2013, 8:31am

...But it wasn't answered. Is this update an addon-breaker, or can someone just update IC2 & still use addons for 1.112?
(If so,:Wrench:time, things could use updating. Let's see, :Glass Fibre: goes here... Take :Tesla Coil:, plug it into :MFS-Unit:, and apply a full 10,000,000 EU. Why is it not working...?)
Try to use words next time, please...
Anyway, Most/all Add-ons should work with 1.115.
For your problem: you need to put the Fibre Cable onto the Dot ( :MFS-Unit: ), the Output of the MFSU.
The person who finds any spelling errors can keep them by himself. Sorry for the bad knowledge at all, look at my age and my country. Sorry for any inconvinience.

Greets!

17

Saturday, February 2nd 2013, 7:58pm

...But it wasn't answered. Is this update an addon-breaker, or can someone just update IC2 & still use addons for 1.112?
(If so,:Wrench:time, things could use updating. Let's see, :Glass Fibre: goes here... Take :Tesla Coil:, plug it into :MFS-Unit:, and apply a full 10,000,000 EU. Why is it not working...?)
Try to use words next time, please...
Anyway, Most/all Add-ons should work with 1.115.
For your problem: you need to put the Fibre Cable onto the Dot (:MFS-Unit:), the Output of the MFSU.
I know, I was trying to be slightly humorous. And Tesla Coils actually can do serious damage to the Ender Dragon... If it gets in range. And the crystals are destroyed. And it doesn't destroy the setup first. (I used SPC & the 'Freeze' command last time I tried this, & going back to that old world I found the setup. And it still worked perfectly. It was sweet to zap anything that moved.)
:Nuke TNT: = Answer to all problems. Including that creeper camping right outside the door of your glass house.

18

Sunday, February 3rd 2013, 8:20am

Crash

I get this error report when I try to start up the game:
https://docs.google.com/document/d/1LrBK…dit?usp=sharing


Mods installed:
Buildcraft 3.4.2
Traincraft 3.1.13_030
Forestry 2.0.0.5(Also doesn't work, but that isn't your problem to fix)
Redpower 2.0pr6
Railcraft 6.15.1.0
Minecraft Forge 6.6.0.518

Minecraft works when IndustrialCraft2 and Forestry have been removed from the Mods directory. I have tried running without Forestry and it still doesn't work and the only difference in the error report is that it said that Traincraft successfully initialized.

This post has been edited 3 times, last edit by "(2142)Gen.Reaper" (Feb 3rd 2013, 8:35am)


mak326428

Iron Miner

  • "mak326428" is male

Posts: 627

Location: Totally not Honduras.

  • Send private message

19

Sunday, February 3rd 2013, 9:13am

I get this error report when I try to start up the game:
https://docs.google.com/document/d/1LrBK…dit?usp=sharing


Mods installed:
Buildcraft 3.4.2
Traincraft 3.1.13_030
Forestry 2.0.0.5(Also doesn't work, but that isn't your problem to fix)
Redpower 2.0pr6
Railcraft 6.15.1.0
Minecraft Forge 6.6.0.518

Minecraft works when IndustrialCraft2 and Forestry have been removed from the Mods directory. I have tried running without Forestry and it still doesn't work and the only difference in the error report is that it said that Traincraft successfully initialized.

java.lang.RuntimeException: RedPowerCore: BlockID 244 occupied by ic2.core.block.machine.BlockMiningTip, autoAssign is disabled.
Another blockID conflict.
Go to /config/redpower/redpower.cfg and find 244 blockID and change it to another.

Wliu

The Silent Engineer

  • "Wliu" is male

Posts: 254

Location: 50DKP

  • Send private message

20

Sunday, February 3rd 2013, 12:35pm

you could also try enabling autoAssign. It tries to shuffle around RP2's IDs so that they don't conflict. (Might corrupt your world though)
hi~ :P

Similar threads

Counter:

Hits today: 18,798 | Hits yesterday: 30,247 | Hits record: 111,506 | Hits total: 33,003,407