[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • Sorry to bother but I'm having an issue with 1.8-debug4.

  • TechieJunk please generate a new crash report with the attached version, It'll add more detailed information about the issue.

    I think there's somewhere caused a bug to the texture loading,I got some mod items and blocks' texture completely transparent with forge 1213

    GregTech SHALL rule the world !

  • TechieJunk please generate a new crash report with the attached version, It'll add more detailed information about the issue.

    Here you go. Looks like a different texture this time, Huh.

  • So far I've investigated that hee uses a bad name for TextureBiomeCompass which conflicts with the vanilla compass, causing some corruption. I'm not fully aware yet why fastcraft trips over it though. I can at least reproduce it nicely, so the search continues ;)

    Thank you very much :)

  • I was going to leave a crash report on my modpack (note: I'm not going to include the mod on the public release, don't worry), but I noticed these debug releases, maybe it fixes it. Anyway, here it is in case it doesn't work, this is with 1.8 "stable" (from the first post): http://paste.ee/p/vEQIf

    EDIT: I've tried the debug, loaded the world perfectly, but gave this crash when hitting F5. Seems to be related with the "Selfie" mod, I'm sending you both devs this report, odn't know which one is causing it: http://paste.ee/p/Fylln (With both mods enabled this happens when pressing F5, if I leave Selfie mod alone doesn't happen, if I leave fastcraft alone, it works flawlessly)

    Although, these blocks/items aren't rendering on 1.8-debug6:

    • Red Sand (Vanilla)
    • Note Block (Vanilla)
    • Measurement Gauges (Archimedes Ships)
    • Name Tag (Vanilla)
    • Wheat Grass (Biomes O Plenty)
    • Red Large Flower Pot (Garden Containers)
    • Ghostwood Leaves (Natura)
    • Darkwood Trapdoor (Natura)
    • Slime Pickaxe Head (Tinkers Construct)
    • ME Level Emitter (AE2)
    • Azulejo (Botania)
    • Marble Pillar - All variables (Chisel)
    • Glowstone - "Neon Glowstone" Variant (Chisel)
    • Dark Oak Wood - "Smooth Dark Oak Wood Planks" Variant (Chisel)
    • Carpet - "Magenta Carpet Block" Variant (Chisel)
    • Floor Carpet - "Magenta Carpet Block" Variant (Chisel)
    • Stained Glass - "Light Blue Borderless Glass" Variant (Chisel)
    • Cannon - Balkon's Weapons Mod [Item Texture]

    Hope this helps :)

  • Yeah, As far as I've seen is when I hit F5, which is a client way of making selfies (without the mod on the server). I'd really like to change the hotkey to something different, first to check if that's what triggers the crash, but also because it works awful being overlapped with the default f5 use...

    About the build, I'm opening, I'll keep you informed if It worked :)

    EDIT: Works like a charm :D

  • this mod is amazing. my FPS went from 20 to 60+

    chunks load so quick.

    i cannot express my amazement and thanks enough.


    wonderful job, thank you. :thumbup:

  • I've released fastcraft-1.9, it's exactly the same as fastcraft-1.8-debug7 without all the debug checks. If you encounter any issues run fastcraft-1.8-debug7 to see if it generates anything useful.

    did you say the problems with cauldron were on your end? if so could you try fixing them in the next update if you have nothing to do? if so that would be great! its a nice mod and i looooove it so far ;)

  • Just made an account here after browsing for a very long time to say thanks for this mod. My custom 1.7.10 server was giving people issues but they all seem to be fixed because of this.

  • it wont take me to anywhere when i click on the download link, i get a gateway timout error... would you consider putting a download on something like the minecraft forums itself? I would really like to try to use this mod because i went from 90 fps 1.6.4 to 10 fps on 1,7,10

  • Wow, practically seamless chunk loading, amazing.

    I'm scatterbrained, i work well alone and i don't, i always have some grandiose, huge project to build in minecraft that i NEVER finish (to this date i have NEVER finished an entire project on a world)
    I constantly bite off more than i can chew with a new project, change my mind, change the idea ... tear it all down and start again! (the core of the project remains the same) or the pack stops updating!
    Captain Tyriael_Soban - XO, Sanctuary Project.

  • Hi i have Minecraft 1.7.10 and ive downloaded you mod like 2 weeks ago but didnt improve my lag problem. Anyway, im not here because of that. Im having some minor issues inside-gaming after installing-removing fastctaft from my Mods folder. Im not getting experience when melting and my enchant table changed to 28 max lvl instead of 30 by enchantments (also mi Metheors mod its having some minor issues when detecting metheors last crash site). Can u help me to solve this minor issues pls ?

  • i am using BTP and Fastcraft works like a charm for me, every time it updates (BTP i mean) i get massive FPS "chewgum" effects when i have the inventory open and nei up, with fastcraft it works perfectly.

    awesome job!