[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • Got an error with fastcraft 1.16 on my server. Player logs on and then:

  • Got an error with fastcraft 1.16 on my server. Player logs on and then:

    This looks like an issue with Mekanism that was actually just fixed and released about an hour ago. Check their github for mlre info...


  • Sorry, you are right. I looked in the changelog of Mekanism with the following content : ""

    OK. That wasn't only "" , that was "*BULLSHIT*" :)

    Sorry again.

  • Using Fastcraft 1.16 and Mekanism
    Someone placed a Mekanism generator in flowing lava on our server which produced the following error:

    Crash-report: http://paste2.org/4msJKcEX

    Not sure if it's a Fastcraft or Mekanism issue so posting it here just in case it might be useful. Also posted an issue on Mekanism Github here: https://github.com/aidancbrady/Mekanism/issues/2095

    Should be fixed in Mekanism

  • Shinisuryu: This sounds like sporadic lag spikes, take a closer look at /sampler tps, it'll report a max tick time as well, which is the worst recorded for the past ~2 minutes. One cause for this may be when MC writes modified chunks to disk. Sampler's spiketrigger should be able to catch this kind of spikes, run /sampler sampleinterval 3000 and then /sampler spiketrigger 500.

    I tried this for my server, since i have been having the same problem with lag spikes on and off a few times.. never really understanding what was causing it...
    the spike trigger worked wonders, but i'm at a bit of a loss as to what i should look for in the files.

    using VisualVM to look at them atm, but a bit lost in what the different things mean.. What should i look for?


  • Fastcraft 1.6 has an issue with the mods used in RR3 - mainline + a few other mods. It crashes after RR3 has been loaded the second time, independently wether Fastcraft was installed or not when RR3 was started initally. Removing Fastcraft afterwards allows to start RR3. Reinstalling (including full removal of RR3 shows reproducibility of the issue. Former versions (assumingly RR3, cannot remeber exactly) worked quite well. I am not sure if its version or mod depending since the upgrade from 3.2.2.x to 3.2.2. included a change of mod choices which i cannot recall.
    Another player reports that on his machine the crash solely appears when Opis + Mobiuscore is installed. Removing Fastcraft or Opis solves the issue without the need of reinstalling, however this doesnt work for me (as described above).

    1st attachment contains crashlog for Fastcraft 1.6.
    2nd attachment contains crashlog for Fastcraft 1.11-debug2

  • Analyzing them properly is quite tricky, it requires a good amount of knowledge.

    Upload a few of the nastier ones (1st number = spike length in ms) and I'll have a quick look.

    Here you go, two of the really bad ones:


    If it is very clear what the problem is, could you give me some hints as to what i should look for in the future, if this happens again?
    I am a professional software engineer, so i'm not completely lost looking at stuff like this, just a bit unsure what numbers i should be looking for and where.

    Cheers for the help!

  • It's mekanism doing some sort of network maintenance in both cases. The call stack is really quite deep, initially triggered by a te accumulator loading adjacent chunks.


    That is what i had found myself. At least i know i was looking at the right stuff.. just didn't see any reference to a TE accumulator.. and not in your screenshot either? (so i had no clue what to look for in my world)

  • Hey Player! I've got a weird bug for you to tackle: Me and a few others are getting CME (ConcurrentModificationException) errors when teleporting to a certain mekanism teleporter. The only thing showing up in the logs is fastcraft and vanilla function calls.

    Crash Report via Pastebin:

    EDIT: apparently it's not just the teleporting... i was flying back to my place and crashed with the same error.

  • Yes, it'll set a system property which fastcraft will check and then enable concurrent modification catching. There is however a good chance that it won't conflict nearly as much afterwards since the catching involves some extra synchronization affecting the multi thread interaction timing.

    Okay... yeah i can't seem to reproduce with that property set. What could that mean?

    EDIT: never mind.... it just crashed :(

    2nd EDIT: it's being very weird.... sometimes it crashes other times not.... and the crashreport is the same.