[GregTech-5][1.7.10-FORGE-1355+][Unofficial but approved Port][Stable] Even GT5 Experimental is slowly getting stable.


  • Which page in the thaumonomicon are they on though? I'm having trouble finding them..


    I believe it's hidden at the bottom of Artifice; you need a bit of research to unlock them though.


  • I believe it's hidden at the bottom of Artifice; you need a bit of research to unlock them though.

    Thanks, found it now


    Having some trouble with the Magic Energy Absorber though. It doesn't accept input of items from any sides, only solution seems to be putting in the items manually. Not sure if this is intended or not.....

  • Yep. Tier of input/output hatches/buses defines only size of it's inventory/tank.

    Ideal Industrial Assembly (IIA) - my pretty hard industrial modpack based on GT5.09

    Идеальная Индустриальная Сборка (ИИС) - довольно сложный сугубо индустриальный модпак, базирующийся на GT5.09

    http://sapientmail.wixsite.com/minecraft

  • Energy Hatches do matter; their voltages are added together (so LV+MV = 160EU/t > 128EU/t = machine thinks it's HV tier = most recipes won't work because you can't give it enough power from those 2 hatches)


    However, for everything except Energy or Dynamo hatches, the level of casing used to make them only determines the number of item slots or fluid capacity, and mixing different ones doesn't matter.

  • Hey, I have an issue with world loading that seems to only occur when I have this mod installed, as in it freezes on converting world when creating a new one. I am using FTB Resurrection with most mods disabled (My PC is broken and my laptop is slow when using all the mods). The only additions I have are fastcraft and optifine. Everything used to run fine on both my client and server but when I updated the forge version along with removing GT5 to install GT5U and updating forestry to stop incompatibilities (plus updating WAILA to fix a memory leak, but that shouldn't affect much), my client can't load or create new worlds as long as GT5U is installed. I tried regenerating the configs and such but it didn't help. I didn't try it on my server yet but I assume that if the client doesn't work then neither does the server. Other people having this problem had to delete some thaumcraft files in their save's folder but I don't have that installed and as far as I'm aware, I don't have those files anyway. Here's my log: http://pastebin.com/5b6UL0D3


    Many mods which I don't have installed are throwing up errors, such as Thaumcraft and Thermal Expansion (IIRC). Is this normal?
    This might be something obvious but I can't for the life of me get it to work. Does anyone know what could be causing this, and possibly how to fix it?

  • Quote

    OS: Windows 8.1 (amd64) version 6.3

    Well There's Your Problem [/s]


    The errors about Thermal Expansion and Thaumcraft are just other mods looking for the Thaumcraft API and finding the mod not present. Those can probably be ignored.


    As for why the world hangs... How much RAM are you giving Minecraft? I never got Resurrection to load on less than 3GB... and I don't think Resurrection ever really worked right anyway.


    Another idea: Do you still have Railcraft installed? If so, try this: Open the Railcraft .jar file, and delete the thaumcraft folder from it. Because that might be doing something it's not supposed to, particularly because you don't have Thaumcraft actually installed.

  • Thanks for the quick reply!


    I allocated 2.5 GB which worked well before updating (although GT5U is 4 or so MB more than normal GT5, so maybe it makes enough of a difference?). According to the F3 info, Used Memory was ~30-50% and Allocated Memory was 50-80% IIRC.
    UPDATE: I tried setting it to 3.5 GB, still same thing :(


    As for Railcraft, I have it disabled but I didn't mess around with the files. I'll try that and see if it helps.
    UPDATE: This didn't seem to change anything unfortunately.


    I also want to add that I'm running the newest version of forge 1.7.10 (1614), if that makes a difference.


    I'll try to launch with only IC2 and gregtech installed now.
    UPDATE: Success! I did get some scary errors about missing GT textures though. I'll try running it with all the mods I usually have minus CustomOreGen, as I didn't need that to launch and create a world. I hope it won't cause problems.
    UPDATE: Nope, same problem as before. Do you know which mod could be causing this freeze?


    (Sorry for taking so long to reply, it takes a while for FTB to load up)

  • Hello people.
    i don't usually use Gregtech, but I was working on a (private) quick modpack port for someone else) and while using the X-ray mod to admire my hopelessly cluttered oregen, I noticed all these blocks that rendered as if they were smooth stone.


    On closer inspection, those turned out to be Gregtech ores, that only started to render their coloured content, like black for coal, yellow for gold, etc. after I actually uncovered them.
    Is this a cheat-prevention option of Gregtech?
    Is there any estimation of how much all these ores hiding their true nature slow down the game?


    All in all, I think it's pretty impressive if this is intentional.

  • Is this a cheat-prevention option of Gregtech?
    Is there any estimation of how much all these ores hiding their true nature slow down the game?


    It's not actually a cheat-prevention system by design, nor does it slow down the game at all. It was actually designed as a bandwidth-saving system, because all GregTech ore blocks are actually non-ticking TileEntities, and so to save on packets, while the server knows what ore blocks are, clients don't find out what a GT ore block is until it becomes visible to the world.

  • It's not actually a cheat-prevention system by design, nor does it slow down the game at all. It was actually designed as a bandwidth-saving system, because all GregTech ore blocks are actually non-ticking TileEntities, and so to save on packets, while the server knows what ore blocks are, clients don't find out what a GT ore block is until it becomes visible to the world.

    Hmm, interesting.
    And why does it need to be a Tile Entity other than the changing rendered texture?

  • Because GT has too many different ores. Without TEs, a block can only contain 16 different types of ores. There are about 400 materials GT generates ores of, and that then for many different types of materials result in ~3000 different oreblocks.

    And since I have once seen someone who tried to combine Metallurgy, Ex Nihilo and AOBD with an otherwise already pretty hefty modpack*, I get why 3000 blocks would be a problem.


    *AOBD gives every block and item a new ID and doesn't even use different MetaData, Which meant that it used up hundreds of block IDs for just the Metallugic Ex Nihilo Gravels, Sands and Dusts, which caused them to go over ID 4095.


    I am going to investigate whether or not this aspect of Gregtech can be exploited to find them 'ores when using Extra Utilities' Unstable blocks.
    EDIT: Apparently not.

  • Whereas we have NBT-defined items of 50 different shapes, and a total of, what, 5 block IDs?


    Something something efficiency and planning...