IC2 and Minecraft 1.8

  • Hello,


    So I am clearly a noob at this because I cannot get this to work for the life of me.


    I first install and run a Minecraft server. Then I grab the Minecraft Forge Installer and install the server. I then go grab the server version of the experimental 1.8 IC2 and place it in the mod folder. I do the same thing for the client side. The server starts fine and seems to grab the mod. "ML has found a non-mod file industrialcraft-2-client_1.337b.jar in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible." The server does state that, however, the server starts up without error. I get on Minecraft and join the server and all goes well except for the fact that it appears IC2 didn't actually load.


    What am I doing wrong in this? I just want a personal server with IC2 running on it!

  • IndustrialCraft 2 does NOT support 1.8. Use 1.7.10.

    Help the Official FTB Wiki reach a billion pages! [I had to keep changing it so there ^^]

    Someone should fix the gravel texture in the background. It's been years now, come on people.

  • I think the OP might have been confused by the thread title of [MC 1.8.1] IC² v1.337 SSP/SMP
    IC2 1.337b was released December 4, 2011, and it's for Minecraft Beta 1.8.1 that released September 19, 2011 (also it's not IC2 "experimental"). If you're trying to install it for the full Minecraft 1.8 that released September 2, 2014, then I'm not surprised that it won't work.


    You should be looking at this thread instead: [LATEST RELEASE] [MC 1.6][MC 1.7] IC2 Experimental

  • Fixed the Titles to be more descriptive about the Beta State of MC back then.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • I think the OP might have been confused by the thread title of [MC 1.8.1] IC² v1.337 SSP/SMP
    IC2 1.337b was released December 4, 2011, and it's for Minecraft Beta 1.8.1 that released September 19, 2011 (also it's not IC2 "experimental"). If you're trying to install it for the full Minecraft 1.8 that released September 2, 2014, then I'm not surprised that it won't work.


    You should be looking at this thread instead: [LATEST RELEASE] [MC 1.6][MC 1.7] IC2 Experimental

    Ahh, that explains it! I ended up starting a 1.7.10 server instead since it wasn't working. Now it all makes sense. Thanks!