[IC2 Exp][1.7.10] CompactSolars 4.4

  • I use this mod in multiplayer with IC2 1.97 and did not experience any problems with arrays.

    Ah! I was using the 1.2.5 + IC2 1.95 download, I tried the Forge 1.18+ download and it works now! If you hadn't posted, I would have never tried again and found my mistake. Thanks!

  • Ah! I was using the 1.2.5 + IC2 1.95 download, I tried the Forge 1.18+ download and it works now! If you hadn't posted, I would have never tried again and found my mistake. Thanks!


    You welcome

  • Last night I finished making an HV Solar Array. Manually in SMP and without cheats. It was an arduous task, I tell you, but well worth the effort. I now have enough power to run my huge force field, around my base, indefinitely.


    This config is vulnerable. It requires regular visiting of the base or additional power source. Otherwise someone can cover your base by dirt (or just a solar array block if it's visible) and wait until field disappears.
    Workaround - use forcefield up to 256 height, so block can't be placed above force field.


  • This config is vulnerable. It requires regular visiting of the base or additional power source. Otherwise someone can cover your base by dirt (or just a solar array block if it's visible) and wait until field disappears.
    Workaround - use forcefield up to 256 height, so block can't be placed above force field.


    Ok building a emergency nuclear reactor + power detector pipe :thumbsup: more fun


  • This config is vulnerable. It requires regular visiting of the base or additional power source. Otherwise someone can cover your base by dirt (or just a solar array block if it's visible) and wait until field disappears.
    Workaround - use forcefield up to 256 height, so block can't be placed above force field.


    Hmmm, I never thought of that. Though, I do have a nuclear reactor which switches on automatically in case I run low on power. It is still limited energy though. A force field of that magnitude would be way too power consuming. Do you have any other suggestion? How about making my nuclear reactor self-replenishing so it could run for days on end?


    EDIT: My base is only run by this solar panel atm, charging up 5 MFSU's. It takes less than 2 million EU during the night and recharges those 2 million EU back up before half a Minecraft day has passed. It would take some time for all those MFSU's to run out, not to mention that I am in my base pretty much all the time. I rarely leave it.

  • Hey,


    I was wondering if anyone could help me. I'm trying to change the recipe for the solar power. I feel it's too cheap right now.


    I was wondering if anyone could replace the LV, MV and HV parts to batbox, MFE and MFSU. Or atleast show me how its done. I've tried looking around but can't seem get any mod helpers working.


    Thanks!

  • damn those solar arrays are overpowered i have 5 hv powering all my base with a nuclear reactor that activate only when they can't work (night or storms).
    but i can't use then in my server i always get an error message.

  • damn those solar arrays are overpowered i have 5 hv powering all my base with a nuclear reactor that activate only when they can't work (night or storms).
    but i can't use then in my server i always get an error message.


    And the error message is?

    Disappointed with the bugs and nerfedness of AtomicStryker Corp's Advanced Machines, and the unupdatedness of Snyke's Enterprises?
    Need low-lag renewable power?
    Come to ImmTech Intragalactical this thread for free UUM!

    Note: UUM may stand for Unnerfed Unbuggy Updated Machines and may not be actual UUM. The extra U was lost due to a bit error.
    Battery snot included.

  • i get this message



    [FINER] Initializing mod_CompactSolars
    2012-08-06 01:56:08 [SEVERE] A fatal error has occured initializing CompactSolars
    2012-08-06 01:56:08 [SEVERE] Unexpected exception
    java.lang.RuntimeException: java.lang.ClassNotFoundException: cpw.mods.compactsolars.client.ClientProxy
    at cpw.mods.compactsolars.ServerClientProxy.buildProxy(ServerClientProxy.java:20)
    at cpw.mods.compactsolars.ServerClientProxy.getProxy(ServerClientProxy.java:32)
    at mod_CompactSolars.load(mod_CompactSolars.java:30)
    at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:351)
    at cpw.mods.fml.common.Loader.modInit(Loader.java:263)
    at cpw.mods.fml.common.Loader.initializeMods(Loader.java:604)
    at cpw.mods.fml.server.FMLServerHandler.onLoadComplete(FMLServerHandler.java:147)
    at net.minecraft.server.MinecraftServer.s(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:412)
    at dn.run(SourceFile:492)
    Caused by: java.lang.ClassNotFoundException: cpw.mods.compactsolars.client.ClientProxy
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at cpw.mods.compactsolars.ServerClientProxy.buildProxy(ServerClientProxy.java:16)
    ... 9 more

  • I'm also getting the same error as Hellgate when I try to start my SMP server. I don't think this supports server for IC1.97 yet.

  • I'm also getting the same error as Hellgate when I try to start my SMP server. I don't think this supports server for IC1.97 yet.


    That's the server I use, so it does work. I get no errors related to the solar arrays. (I get an error for additional pipes for BC, but that's an entirely different story).

  • In that case, perhaps the issue lies with the particular version of Forge, since I WAS having issues with additional pipes but after upgrading Forge I'm not. I didn't have this add-on before upgrading forge though.

  • can someone help im trying to install this on my server and i i get this error



  • Don't quote me on this, but you might have installed a client version to the server, I THINK the server asks for clint forge hooks there... but idk. Might also be that you need to update forge. I run a server with like all the mods and forge 171 with the FMLServerHandler fix. and it does work indeed. but yeah, that client thingy can be outdated forge too ^^