Conflicts while starting the server on certain blocks.

  • I am not sure if this was happening from the beginning but yesterday for first time my eye caught some conflicts happening while starting the server. I am on the MCPC Bukkit 1.2.3 with forge The mods I have on are
    Buildcraft, Industrialcraft, Equivalent Exchange, Redpower, Balkon's Weaponmod, Hot Air Baloons, Dynamic Elevators, Rei's Minimap, Rugs, Simple Ores and some extra addons for Buildcraft and Industrialcraft (teleport pipes, advanced machines, compact solars, super wrench, charging table).

    and also I tried to change the block ids of these blocks to other free ones and again they appeared again with the different block id and a different conflict number. The blocks that conflict are:


    I never had a problem up to now but I never crafted any of these items to know what will happen. No matter in what free block ids i switch them to they still conflict.


    Scratch that, my gf that plays with me just told me she made a nuke and when she tried to use it the server kicked her out and there was no explosion.

  • I installed NEI and checked both if the ids I changed them first time were taken and also looked for free ones. I changed the ids to the free ones according to nei and still i got this

    As for using the default client ids, industrialcraft is one of the mods I did not touch the default ids. To be 100% sure I deleted the config file and let the server create a new default one and still go the same conflicts.

  • Ok I started a new clean server wit hthe only thing being the industrialcraft mod and still got the same exact conflicts. I am guessing its an MCPC bukkit port problem :/

    And yes my client works fine.

  • Sadly no, I did run it by itself and it gave me the save error. When I say by itself I grabbed just the server jar and industrial craft and ran it and it gave me the same error. Also the client config is the server's config. Also I have an excel listing what mod takes what block id to keep a track in case I want to add/remove a mod.

  • client have additional mods adding blocks and shifting index.

    I am not really sure what you mean but would it not affect other blocks and not always the 4 dynamite and 2 luminator blocks? I changed a couple of ids and even replaced spots with other blocks and the other loaded right while these 6 still had a problem. Also I deleted both ic.cfg and placed the client one on the server but still the same.

  • 1: this is a problem for minecraftports, we don't support bukkit
    2: almost certain you don't see that with the vanilla server: again, not our problem.

    so in short: we don't support bukkit here.

  • Yes thats true, its probably a port problem rather than the actual mod. Thank you both very much for the support and suggestions. I hope you will both have a good day :)