Questions: EnergyNet *.* is not added to the enet

  • What does this mean and may I ask why it does not display coordinates?


    Code
    1. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    2. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    3. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    4. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    5. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityElectricMFSU@7b71183b is not added to the enet
    6. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityElectricMFSU@3dee08cd is not added to the enet
    7. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    8. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    9. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    10. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • What does this mean and may I ask why it does not display coordinates?


    Code
    1. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    2. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    3. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    4. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@63c0a09e is not added to the enet
    5. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityElectricMFSU@7b71183b is not added to the enet
    6. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityElectricMFSU@3dee08cd is not added to the enet
    7. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    8. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    9. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet
    10. 22:50:48 [INFO] [IC2] EnergyNet.emitEnergyFrom: ic2.common.TileEntityTransformerMV@5683ea7e is not added to the enet

    You know that E-net-Bug which causes Energy not to flow? Well, now instead of fixing it completely, they just added that messages to the Log.


    @Devs
    And if its possible to see that its not connected to it, then Y U NO code an E-net-Update into that Logfunction?

  • There are no ways to update the network I know of, and even if there were, doing so would cause Kane's much disliked lagspikes.

    So your philosophy is:
    Hey there is a Problem, lets tell that to the host of the Server, so that he can fix that by removing and placing a Wire which causes the SAME LAGSPIKE as an E-net-Update, which we could do at the same time as outputting the Log.


    IF YOU KNOW WHICH BLOCKS ARE AFFECTED, THAN YOU COULD JUST RE-ADD THEM TO THE E-NET. I would even show you the location, where you could add it into the Code, but the E-net does not decompile!!!

  • The E-net needs a rewrite

    The Truth! (!!!WARNING!!! DO NOT READ THIS IF YOU'RE RELIGIOUS IN ANY WAY!!!)


  • The E-net needs a rewrite

    This is the real truth... I'm pretty sure this is what E-Net does to my server:


    1.95b:



    1.97:

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • I could live with lag spikes if it meant functioning machinery.


    Im glad i found this thread. good to know that the problem was being discussed.

  • pardon my ignorance, but isn't this part and parcel of the SMP sideways texture bug?


    In which case, by all accounts, an update to Forge 3.4.9 (aka Forge 171) would resolve this, yes?


    (it's a bug I haven't encountered in SMP with 1.95b/Forge 108... )

    "Why is that unhappy green pe*is running towards you?" - Minecraft first impressions live long.

  • It is not part of that bug. People can live with their machines being faced the wrong way. What people can't live with is their machines not receiving ANY power at all. I would like to clarify that i have updated my Forge to the latest #171 build and YES, cables are connected from the batbox to the machine and yes, the batbox is getting power (from a lv solar panel) and my machines still no more power.No options of power generation are working either (except for compact solars).

  • It is not part of that bug. People can live with their machines being faced the wrong way. What people can't live with is their machines not receiving ANY power at all.

    The machine orientation is more than just a texture issue, tho. I could live with machines pointing the wrong way too - IF they actually worked without requiring manually applied battery power.


    And given that the sideways machines and the e-net bug are both related to world update technicalities, I had assumed they were separate symptoms of the same update mishandling.

    "Why is that unhappy green pe*is running towards you?" - Minecraft first impressions live long.

  • 171 with the FMLServerHandler patch?


    Doing some searches I found where you linked this FMLServerHandler patch, but the file has been removed from the download site. Will this patch fix this EnergyNet issue? I can't use IC2 in my new world because none of the IC2 machines will send or receive power from the energy net.