Teleporter 'stuck' on teleporting

  • Hi.

    I have a simple teleporter configuration: one teleporter linked to another on a different location.
    Setting placing them and linking them works without issues.
    Even teleporting the first time works.

    However on teleporting once or twice it does not work aain.
    Activating the button on place a will not do anything, just the bue dust shows up but for a bit but I am not teleported.

    Walking back manually to b I find out that the button on the teleporter there remains pressed and a constant blue haze is displazed above it.
    Sometimes re-starting the client helps. But sometimes I have to dismantle the teleporters, place them and link them again to work again (when that happens my character is stuck 'somewhere' for a moment and reappears above the original transporter then even though I might have stood beside it when pressing its button).

    I have minecraft 1.2.5, ic2 1.97 with minecraft forge 3.4.9 (with the machine facing bugfix applied).
    I originally had minecraft forge 3.3.7 installed on client and server (then updated to 3.4.9 on both). Updating did not reslove the issue.

    I searched the forum and could not find another having the same issue.
    (Btw.: running the server off a ramdisk really improves block-loading speed observable when travelling larger distances fast!)

    I also tried while removing any other mods other than ic2 - it did not help.
    Can you help me with this issue?
    Having to run 550m through difficult territory between my two locations is really annoying, so I'd like to get this fixed.

  • Were both of the chunks containing the teleporters loaded?

    I don't think that matters as I don't use chunkloaders and have never had problems with teleporters, to the op, download the excel file found here, apply the formula, and check the power in the mfsu connected to the teleporter, the behavior of the teleporter you described sounds similar to what happens when a teleporter is powered without enough energy to teleport the player

    Alternatively if that doesn't work, I believe it is a problem with the button getting stuck, try placing a button somewhere other than the on teleporter and use repeaters to trigger the teleporter

    Is the answer to this question no?


    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

  • Yes. I had 6 million EU in one MFSU and the other is full.

    I also observed that after it does not work anymore there were other glitches:
    - The MFSU and other devices do not count up in the displayed window nicely anymore, i have to close its interface and re-open it to watch the update of the contained energy. A client restart fixes this.
    - The button on the Transporter (and it's stone) cannot be dismantled/mined. They reappar instantly. A client restart also fixes this.

    Btw, I noticed that after some time (maybe a 5 minute timeout?) the blue haze on the stuck transporter mentioned (where the blue haze keeps on being displayed and the button keeps being in pressed status) goes away again. However trying to transport afterwards is still not possible.

    I calculated how much a transport takes and the spreadsheet calculated 789382

    I also observed that after such issues I could not open a door that opens with a button (restarting the clinet also fixed this).
    I also observed that it happens in such issues that i cannot just log out and in again. Loggin in won't work and I have to completely close and restart minecraft again.

  • To stop this I end up using a lever and an rp2 pulse former to apply the current. A button can get stuck when you immediately leave the chunk, but a pulse former only sends a single pulse.

  • My usual trick (if RedPower is also loaded) is to set up the button like this: Button -> NOT Gate -> Pulse Former -> Teleporter. The teleporter triggers after the button deactivates, thus there's no risk of the button being trapped in an 'on' state when the chuck gets unloaded.

  • I have a simpler approach. If the teleport doesn't lead to the chunk being unloaded, just use a button.

    If it does lead to the chunk being unloaded, just set the MFSU that powers the thing to "Emit when full". The teleporter turns off immediately you jump, and stays off until you get back.

  • Thanxs Talonius (nice avatar by the way, I'm a dragon too and got an dragon avatar picture, just did not apply it here) and dronf.
    I installed redpower 2 and created a setup like you described (took me a while since redstone stuff was rather new to me).
    I also tried setting the MFSU to "Emit when full".

    Both changes did not help.
    After a transport and back it does not work anymore and I have to log out and In again so it works again. After it does not work it has the state as already described that the power level is not counted up fluid and I have to close and open the mfsu display again to see the current level (at the time of opening the display).

    Any more ideas?