[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • Hello Player! I would like to use your mod in a modpack called Destination Automation that will be released on the FTB Launcher soon. All requirements will be met! :D

  • Hey anyone else having entity render issues with "fastcraft-1.22-ctest17" ? I am having players claim that things go invisible and I did notice that it appears to fix itself after a player disconnects and reconnects. Anyone having a similar issue?


    Here is my mod-list if anyone knows definitively what could be causing it let me know.



    Using forge release 10.13.4.1517 for 1.7.10

  • Hey anyone else having entity render issues with "fastcraft-1.22-ctest17" ? I am having players claim that things go invisible and I did notice that it appears to fix itself after a player disconnects and reconnects. Anyone having a similar issue?

    I am definitely experiencing this as well, although I haven't noticed it being fixed on relog.

  • For me it's specific entities such as Ghasts disappearing at a certain distance and then reappearing 1 second later, I think I've seen it happen with other mobs too though. I will try and catch it in a screenshot but will seeing a picture of something that is fully invisible help? I could try to record it in a gif or something as well to show them transitioning from visible to invisible if that would help, with F3 on of course. :)

  • Yes, it seems to be angle dependent, I had to get it just right to capture this
    Edit: Actually no on further testing it is not angle dependent but distance dependent, any angle will cause the mob to disappear at a certain distance from the mob. I can't reproduce it with a ghast that is stuck in blocks, or any non-flying mob. Haven't tested squids yet though.

    The post was edited 1 time, last by Fargo ().

  • That frame rate though :P

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • Squid rendering seems to be messed up in >= ctest15.
    Squids spawned in water either render nothing at all or render just their shadow, while squids spawned on land (via spawn egg) render fine.
    ctest14 and older doesn't exhibit this problem.

    Since others are posting about invisible entities..
    Reposting this as I suspect it got buried in all the modpack permission spam.

  • Hi! I would like to include your mod into a private modpack. I'm including a notification about using your mod in my pack and a link to this thread.


    Thank you for working on this, your mod really helps to keep my gaming experience enjoyable!

  • I've found the problem causing the squid glitch after a lot of debugging. It may be related to other disappearing entity issues.


    A new build will follow soon.



    cindylo: This is unlikely to be related to Fastcraft, the mention at the bottom of the stack trace is fairly transparent and does nothing even remotely related to the error. It looks like one of the inner classes in ChatComponentStyle is missing, probably from a corrupted jar or a broken coremod.

  • Interesting, it seems one of the world gen mods I was using caused a conflict with fastcraft serverside on join. It was either wildcaves 3 or streams. I was just assuming it was Fastcraft since it has had serverside connection problems in the past, my bad.

  • I've found the problem causing the squid glitch after a lot of debugging. It may be related to other disappearing entity issues.


    A new build will follow soon.


    cindylo: This is unlikely to be related to Fastcraft, the mention at the bottom of the stack trace is fairly transparent and does nothing even remotely related to the error. It looks like one of the inner classes in ChatComponentStyle is missing, probably from a corrupted jar or a broken coremod.


    Oh thank god! You and Fewizz are truly modding gods :D

  • man i got a bug that SEEMS to be relative to your fastcraft. i have put the crashreport in the attachment. i'm not the one who meets this bug, so i can't give you any information except that crashreport. i'm asking the one who posted this bug for more detail howerver, if you need it.


    EDIT: if this actually has nothing to do with your mod, i'll apologize. i don't really understand either java or Minecraft.

  • man i got a bug that SEEMS to be relative to your fastcraft. i have put the crashreport in the attachment. i'm not the one who meets this bug, so i can't give you any information except that crashreport. i'm asking the one who posted this bug for more detail howerver, if you need it.


    EDIT: if this actually has nothing to do with your mod, i'll apologize. i don't really understand either java or Minecraft.

    Do you have CoFH Tweaks as well as Fastcraft? That's the normal crash that seems to happen if you do.

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.