[AddOn v1.43/v1.64] Advanced Machines V3.2 Beta 2

  • By the way, how much god damned power do these things USE?!? Still having the 'can only have one on a dedicated MFE glass line" issue....I built a rotary macerator in my new world, and it refuses to work on 32 EU/t.

  • Then I believe there is a very evil bug, because I cannot, EVER keep even 1 of your machines running on a dedicated 128 EU/t line from an MFE that is completely full from energy crystals....and I have the latest IC2 and 2.1 of your mod. The machines also refuse to allow anything past them on the power line to receive any power.....sorry if I sound annoyed, it's just after having so many damned worlds corrupted by Additional Buildcraft Pipes, *the mod creator seems to like using ID's used by IC/BTW and ID Resolver seems to LOVE to re-id the entire mod, thus killing all chunks his Chunk Loader pipes are in....* I am more than a little pissed that I can't seem to use on of the machines I love so much.

  • Then I believe there is a very evil bug, because I cannot, EVER keep even 1 of your machines running on a dedicated 128 EU/t line from an MFE that is completely full from energy crystals....and I have the latest IC2 and 2.1 of your mod. The machines also refuse to allow anything past them on the power line to receive any power.....sorry if I sound annoyed, it's just after having so many damned worlds corrupted by Additional Buildcraft Pipes, *the mod creator seems to like using ID's used by IC/BTW and ID Resolver seems to LOVE to re-id the entire mod, thus killing all chunks his Chunk Loader pipes are in....* I am more than a little pissed that I can't seem to use on of the machines I love so much.

    I do apologize, but I am unable to reproduce the bug. Please post a list of your mods, and I'll be happy to see if I can't fix this quickly.

  • Hmm, trying to figure out how to get a ModLoader list, but I am using EE, BC, IC2, RP2pr2b, your mod, adv solar panels, that wall forcefield thing from these forums, rei's minimap, id resolver, millenaire, wireless redstone, wireless remote, recipe book, TMI, treecapitator, multitools*removing this one*, koda's clay soldiers.\


    Also, both your machines and the induction furnace seem to drain power while building up speed/heat, and using them to smelt or whatnot drains the power completely, and it will only build back up is if I turn off the redstone powering them, my induction furnace worked fine until I installed this mod of awesome win, so I don't think it is anything to do with IC2

  • Hmm, trying to figure out how to get a ModLoader list, but I am using EE, BC, IC2, RP2pr2b, your mod, adv solar panels, that wall forcefield thing from these forums, rei's minimap, id resolver, millenaire, wireless redstone, wireless remote, recipe book, TMI, treecapitator, multitools*removing this one*, koda's clay soldiers.\


    Also, both your machines and the induction furnace seem to drain power while building up speed/heat, and using them to smelt or whatnot drains the power completely, and it will only build back up is if I turn off the redstone powering them, my induction furnace worked fine until I installed this mod of awesome win, so I don't think it is anything to do with IC2

    try puting yor macines 1block away from the mfe it worked for me

  • Done that, I have tried many 'solutions' to no avail. I can only seem to get them to update their power if they have a battery in the input slot while powered....THEN they draw from both sources......

  • For everyone who has the ic2.api.IWrenchableBlock error when starting there server.


    Just rename Advanced Machines 2.1 Server.zip to something else. Make sure the beginning letter in the new name is a letter that comes after I. Because Modloader loads up the mods alphabetically. If it starts with a letter that is before the letter I, then ModLoader will load up advanced machines first, and this is why you get this error.

  • I'm having some trouble useing BC with this addon, namely: the Rotary Macerator doesn't seem to work without Direct Power, with gives Indirect power to the wooden pipe.


    Since the pipe requires alternating current, i can't get it to pull items from the macerator, any suggestions?


    Edit: The Rotary is requiring direct Redstone power to charge up.

  • I'm having some trouble useing BC with this addon, namely: the Rotary Macerator doesn't seem to work without Direct Power, with gives Indirect power to the wooden pipe.


    Since the pipe requires alternating current, i can't get it to pull items from the macerator, any suggestions?


    Edit: The Rotary is requiring direct Redstone power to charge up.

    I am addressing the direct current and it will be in the next release. Assuming that you're using 2.2.X of Buildcraft however, you should just use redstone engines. If you are using BC 1.8.1.1, however, I would advise against the use of piping items in/out as the implementation does not work. It will attempt to pull from the input first, so it's not a good idea. Sorry for the trouble.

  • Works very good, ty :D :Energy Crystal: :Energy Crystal:

    youtube.com/corjaantje
    :MFS-Unit::Glass Fibre::Glass Fibre::Glass Fibre::Glass Fibre::Tesla Coil: MinecraftCow MinecraftCreeper MinecraftPig MinecraftZombieman MinecraftSkeleton MinecraftSpider
    :Geothermal Generator:

  • I am addressing the direct current and it will be in the next release. Assuming that you're using 2.2.X of Buildcraft however, you should just use redstone engines. If you are using BC 1.8.1.1, however, I would advise against the use of piping items in/out as the implementation does not work. It will attempt to pull from the input first, so it's not a good idea. Sorry for the trouble.



    -looks- Hmm, I'm using 1.8.1.1... Let me fix that xD

  • I do apologize, but I am unable to reproduce the bug. Please post a list of your mods, and I'll be happy to see if I can't fix this quickly.


    I was able to reproduce this.


    If you have a machine (Induction furnace included) with a lever on top, it is getting redstone power. If that machine is TOUCHING a MFE (or MFSU) it sends that redstone signal to the MFE/SU -- thereby causing the MFE/MFSU to stop sending power out. The only power it'll send is 'Extra' power.


    Make sure your MFE/MFSU isn't getting a redstone signal from anywhere, including the Rotary Macerator right next to it.


    This is not a bug with the addon, as it happens with Induction furnaces as well.

  • Thank you for clearing that up. Might have been the reason for the "Direct Redstone Only" feature in IC2 v1.0.

  • Thanks Direwolf, loved your let's play, it may also have been an odd bug with BTW, I seem to be having much fewer problems now that I do not have that mod installed. Seriously, why the hell does a top mod need to be IN YOUR JAR! ...rant over...

  • Thanks Direwolf, loved your let's play, it may also have been an odd bug with BTW, I seem to be having much fewer problems now that I do not have that mod installed. Seriously, why the hell does a top mod need to be IN YOUR JAR! ...rant over...


    I would ditch Id resolver and manually edit the conflicting ID's, not that hard with the included config files, just takes some time but well worth it.


    Great Mod, keep up the good work!

  • I would ditch Id resolver and manually edit the conflicting ID's, not that hard with the included config files, just takes some time but well worth it.


    Great Mod, keep up the good work!


    Ditto (on both notes, but especially fixing ID's by hand). That way, when you add a new mod, you can ensure that its the new mod that gets a different ID. No world corruption possible that way ;).


    That said, I've never used ID resolver.

  • Only problem with manually editing ID's is things like RedPower 2 and IC2....upwards of a hundred ID's in EACH that conflict...and ID resolver DOES force the new mod to change ID's my problem with Zeldo's mod was he kept changing the damned name....that and using important IC2 ID's....that and I don't have the time to sit with about 6 config files open and checking back and forth to make sure one ID isn't used in the 4 conflicting mods. Millenaire is one of them....so many ID's...


    It all works now, I think BTW was seriously fucking up some of my IC2 stuff, since it DOES edit base classes...

  • Only problem with manually editing ID's is things like RedPower 2 and IC2....upwards of a hundred ID's in EACH that conflict...and ID resolver DOES force the new mod to change ID's my problem with Zeldo's mod was he kept changing the damned name....that and using important IC2 ID's....that and I don't have the time to sit with about 6 config files open and checking back and forth to make sure one ID isn't used in the 4 conflicting mods. Millenaire is one of them....so many ID's...


    It all works now, I think BTW was seriously fucking up some of my IC2 stuff, since it DOES edit base classes...


    glad to see you got it working. Yeah, MIllanaire is a pain to configure with the Forge base mods. I haven't had to manually configure ID;s with RP2v2b, IC2 or BC222. I read on Redpower forum or blog that mod automatically fixes ID conflicts.


    Someone on here or some other forum posted to use ID;s 170-204 with BTW and works like a charm but had to make some manual adjustments in the 200 range due to portal gun mod


    This mod is only a single ID to change and a piece of cake to get to work.


    Cheers!