[AddOn v1.43/v1.64] Advanced Machines V3.2 Beta 2

  • Found the problem HanFox. There are three arrays that look the same and one that doesn't.
    If you try to place the one that's the silver block, boom.
    If you use the three that look the same, works fine.
    I think that's just a behind-the-scenes block that we shouldn't be using :)

    What's with the 188:3 HV Solar Array?


    If you cheat it in and place it it crashes MC (yes, yes, cheating bad, but things need poking...).

    GENERATION 26: The first time you see this, copy it into your sig on any forum and add 1 to the generation. Social experiment or chain letter? This is left as an exercise for the reader.


    Efficiency 3, 50% duty cycle. SMP friendly. Alternate two of them slowly with an rp2 sequencer for a steady 120 EU/t.
    http://www.talonfiremage.pwp.b…=1j10101001501521s1r11r10

  • Thank you so much for this. I've been waiting for better panels and now I don't even need a new addon to get them. The recipe is fair enough also.


    Two things though.


    1) I did not get the config file to change my ID conflict at first either. Was easy enough for me to pull one from a backup and add the line. Still wanted to confirm the issues existence as those getting the mod for the first time might have problems.


    2) I'm also getting mismatching textures on the panel sides. The tops are fine but the sides use a plain texture instead of the normal solar one. I do use the soartex style HD textures so that could be the cause.

  • Found the problem HanFox. There are three arrays that look the same and one that doesn't.
    If you try to place the one that's the silver block, boom.
    If you use the three that look the same, works fine.
    I think that's just a behind-the-scenes block that we shouldn't be using :)


    I know. The actual arrays are in 189.


    I just want to know why that block is there at all. It almost looks like a test to put the new arrays in the same ID as the other advanced machines.


    Ultimately, I don't like the ability to crash my Minecraft even if it is by accident, because once a buggy block is placed you need to remove the mod or edit the world offline to fix it.


  • I know. The actual arrays are in 189.


    I just want to know why that block is there at all. It almost looks like a test to put the new arrays in the same ID as the other advanced machines.


    Ultimately, I don't like the ability to crash my Minecraft even if it is by accident, because once a buggy block is placed you need to remove the mod or edit the world offline to fix it.


    The other one looks like a bug- just ignore it- I think Zipp started by trying to add solar to the existing block ID, but advsolar is pretty different from AM block wise so he put in a new block and forgot to take out a bit of the code... (all speculation of course).

  • Ultimately, I don't like the ability to crash my Minecraft even if it is by accident, because once a buggy block is placed you need to remove the mod or edit the world offline to fix it.


    Perhaps now you begin to see that any inventory editor will have the risk of allowing you to add debug items that are not meant for gameplay.
    That's like complaining that using a debug cheat code crashes your game. Simple answer is: Don't use it, then.

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • Hi, I have a bukkit server with Railcraft installed, which isnt comnpatible with MCForge 1.2.4.


    Can you upload the latest Forge 1.2.3 compatible version of your AddOn for Client and bukkit server Please :)


    Best Regards
    Hung3r


  • Perhaps now you begin to see that any inventory editor will have the risk of allowing you to add debug items that are not meant for gameplay.
    That's like complaining that using a debug cheat code crashes your game. Simple answer is: Don't use it, then.


    Kinda beyond the point. There's nothing that should be left over that's accessible by any "simple" means that should crash MC, but I shan't argue with you. I was just bringing the crash to Zip's attention really.

  • I agree that Zip might want to clean up the test item that's still there, but more to the point I was illustrating the risks of using the "gimme" function in an inventory editor like TMI or NEI.
    Soetimes unexpected things can happen or the game can crash.

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • i

    I agree that Zip might want to clean up the test item that's still there, but more to the point I was illustrating the risks of using the "gimme" function in an inventory editor like TMI or NEI.
    Soetimes unexpected things can happen or the game can crash.


    Heh, And then we notice that we can cheat up batteries, energy crystals, and laptron crystals, and then complain to alblaka about how they wont work for crafting.


    Yep, Makes me think that the FAQ should have this warning, so I can just post "Read the FAQ"

  • Exactly. In fact, I think EVERY mod should have the following disclaimer:
    "Having problems with items you conjured through TMI/NEI? Take it up with them - it's not our problem, even if it's our items."
    But I don't think that would in any way reduce the number of complaints - typically those people don't read FAQs, original posts, or intuit that the problem isn't with the item they didn't bother to craft, but with how the inveditor messes it up.

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • Hi, I have a bukkit server with Railcraft installed, which isnt comnpatible with MCForge 1.2.4.


    Can you upload the latest Forge 1.2.3 compatible version of your AddOn for Client and bukkit server Please :)


    Best Regards
    Hung3r


    Really? Railcraft for bukkit works fine with 1.2.3 or 1.2.4. I know. I ported the MCL layer, and run MCF 1.2.4 on my server right now.

  • I can't for the life of me get the AVD machines to open up..


    Defualt GUI's ID's: the items don't do anything when right clicking (no not spawned items btw)


    Changed GUI: Crashes the client (Yes I made sure they are identical from server and client)

  • Incase you plan to add a chance of advanced solar panels breaking with a wrench..
    Please for the love of God.
    Dont.

    I do have plans for that, but the idea will be to drop the 8 panels/arrays that made it up, meaning you'd only need a new transformer.

  • With all do respect, I can not use this freaking mod until SOMEONE FREAKING TELLS ME WHY MY GUI'S ARE NOT WORKING.


    Forgive me for being impaitent, but I am in the processes of rebuilding a server, now the server is done, but the LAST THING I need is THIS bug to be fixed.


    Or someone could tell me what I am doing wrong with the config, I have set GUI's to so many differnt numbers just incase something might be using them or something..


    500 is not used...


    set macerator to 500 (client and server)


    start server, join, open macerator...CLIENT CRASH! WTF! WHY?


    Use defaults, ..nothing fucking works!


    I have PMed you both, but have not got a responce.


    For anyone else that has this working, please tell me and IRC to join or PM me and I will give you my TS3 info..


    Before I pull my hair out please.


    Thank you!

  • Can you please post the mods, including ALL addons, so I can attempt to see if i can replicate the error.

  • *sigh*


    I am sorry for my anger, or disrespect, but I seemed to fix it.


    You see I was actually using EACH TIME, a netGUI that was used.


    How I had the unfortunate luck in always choosing an ID that was used, I am not sure.


    Thank you for responding, I pretty much fixed it about 5 mins after I posted that but then couldn't snip my post because of the forums going down.


    Thank you also for the amazing addon/mod!


    If I have any other issues I will make sure to post a full list of mods.

  • what gui id's did you use? im having the same issue