[Addon 1.112] BuildCraft-IndustrialCraft Crossover Mod v2.0[SSP/SMP]

  • any idea on when/if this add on will be updated to work with 3.x version of buildcraft? i used this before and i loved it but i really like using the builders from 3.x and having a handy power converter would be awesome. if not does anyone have an alternative that does work with 3.x?

    look at the first side , and look for this :
    Experimental:
    IB v0.07 [SSP]
    for MC 1.2.3, BC 3.1.4, and IC2 1.81.




    this v. work whit bc 3.1.4 xD


    @kodemunkey post the error from the modlaoder.txt pls ^^

  • Is this the mod with the geothermal thing that allows lava to be pumped directly into it from a pipe? or is that something else?


    edit: sorry if this said before, can't figure out the search function for this site, it has also been a long time since i played minecraft, so whats in certain mods has become a haze to me

  • ok thanks. I didn't see it. now I feel like an idot.

  • Sorry if this has been reported(I can't get the search to do a search of just this thread), but this deserves a look. Everything works fine, it just looks strange:
    http://imgur.com/w8RmW
    edit: It appears to be forestry and the crossover not liking one another, as forestry also has problems, which go away when Bc-Ic crossover is removed.
    edit2: Everything is fine if one of "allElectricEngines" or "allowGenerator" is set to false. An issue with spaces for custom textures?

  • Sorry if this has been reported(I can't get the search to do a search of just this thread), but this deserves a look. Everything works fine, it just looks strange:
    http://imgur.com/w8RmW
    edit: It appears to be forestry and the crossover not liking one another, as forestry also has problems, which go away when Bc-Ic crossover is removed.
    edit2: Everything is fine if one of "allElectricEngines" or "allowGenerator" is set to false. An issue with spaces for custom textures?

    This uses some of BC's code to handle the rendering, forestry must change that or something, nothing I can do about it.

  • This uses some of BC's code to handle the rendering, forestry must change that or something, nothing I can do about it.


    We are having some quirks with Crossover after updating to minecraft 1.2.3... The electric engines seems to somehow conflict on some GUI ids... I resolved 3 of them by changing some GUI ids in Forestry (100, 101 and 102) but I cannot seem to find the last 3 (103-105) or where they conflict. When keeping the original GUI ids the Large Electric engine simply will not open any GUI at all... and no energy is output... By changing the GUI ids to 3xx instead of 1xx it works perfectly fine in SSP but on our server the game crashes with the following error:


  • I'm using a group of petrochemical generators to dump energy into an MFSU, on some of the generators there is a red bar next to the oil level, is that the ammount of power they are generating?

  • I'm using a group of petrochemical generators to dump energy into an MFSU, on some of the generators there is a red bar next to the oil level, is that the ammount of power they are generating?

    It is the amount of energy the have stored internally, the same as a IC2's generator horizontal bar or the little lightning icon on the machines.

  • We are having some quirks with Crossover after updating to minecraft 1.2.3... The electric engines seems to somehow conflict on some GUI ids... I resolved 3 of them by changing some GUI ids in Forestry (100, 101 and 102) but I cannot seem to find the last 3 (103-105) or where they conflict. When keeping the original GUI ids the Large Electric engine simply will not open any GUI at all... and no energy is output... By changing the GUI ids to 3xx instead of 1xx it works perfectly fine in SSP but on our server the game crashes with the following error:



    No one having any idea how to solve this? I cannot seem to find where the ID conflict is :(

  • I have IC2 1.81 and BC 2.2.13. I downloaded the last version of the mode there (1.27). Bukkit is "craftbukkit-1.2.3-R0.3-MCPC-SNAPSHOT-48.jar". Version of the game 1.23. I transfered "bcic2crossover-1.27-mcpc1.2.3-r1.zip" in "mods". When I run the server the error is appear.



    Help!


    I apologize for mistakes. I'm Russian.

  • hey there,
    it would be cool, when there would be a engine, that produces rubber out of oil. (with a lot usage of energy maybe)
    i use forestry, but it is quite a hassle to produce enough rubber for my needs y.y


    mfg

  • I am having a problem with at least the large electric engine not showing the interface of it when I right click it. It seems to work normally but I cant check how much water it has in it. In single player it seems to work just fine though so I do not know what I have done wrong. I checked the config of the server and the client and they are identical.



    I have not tried another engine to see if they do the same though.

  • I am having a problem with at least the large electric engine not showing the interface of it when I right click it. It seems to work normally but I cant check how much water it has in it. In single player it seems to work just fine though so I do not know what I have done wrong. I checked the config of the server and the client and they are identical.



    I have not tried another engine to see if they do the same though.


    I had this problem too when I used the Gult's Gorge modpack. I made a new minecraft.jar (only difference was forge version I think, went from 59 to 57) and then it worked again.

  • Thank you so very much Hulkie, I am going to try another forge version and see if that helps :) Thanks again for sharing this information!


    -Edit-


    Sadly it did not work for me but I messed around with the Gui ids and finally it works normally now. Seems one of the mods was conflicting with it.

  • Ok question about the experimental version for 3.x do the cross over pumps work with the gates/chips? I am wondering because I am building a power-plant (well the BC and vanilla parts while I wait for IC2 to update to 1.2.5) and I want to know if I can build in the control systems to monitor coolant and heat levels. If it is not already is that a plan to have them in there?


    Edit: also how well do these blocks work with builders? will the engines place properly in a building created from a blueprint?


    Thanks
    Love the Mod.

  • Ok question about the experimental version for 3.x do the cross over pumps work with the gates/chips? I am wondering because I am building a power-plant (well the BC and vanilla parts while I wait for IC2 to update to 1.2.5) and I want to know if I can build in the control systems to monitor coolant and heat levels. If it is not already is that a plan to have them in there?


    Edit: also how well do these blocks work with builders? will the engines place properly in a building created from a blueprint?


    Thanks
    Love the Mod.


    crossover pumps? If you mean engines, then yes they work with BC triggers.


    As for the BP I dunno, I've not yet created specific code for the blueprints so it may or may not work depending on how BC handles it.