[IC v1.8.1]NEI Integration bug[Miner bug]

  • NEI updated, and thus forth your integration with it needs to update, I am getting tired of responding to compliants of Ic2 related issues on the NEI thread, can you release 1.8.1b with fixed integration? for Nei 1.2.0 instead of nei 1.1.3)


    Thank you for all your efforts :D

    20kb for a signature? who has pictures that small??

  • ChickenBones gave me the source to his fixed IC2 submodule, will be in the 1.2.4 version

    Could you please link a patched class file for those of us who really don't want to have to wait for everything to update to 1.2.4 so we can have 6 more vanilla blocks and other minor tweaks? I for one would be grateful if it's not too much bother.

  • Could you please link a patched class file for those of us who really don't want to have to wait for everything to update to 1.2.4 so we can have 6 more vanilla blocks and other minor tweaks? I for one would be grateful if it's not too much bother.

    So this :)

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • Could you please link a patched class file for those of us who really don't want to have to wait for everything to update to 1.2.4 so we can have 6 more vanilla blocks and other minor tweaks? I for one would be grateful if it's not too much bother.


    If you need NEI so bad, just downgrade NEI to the version that worked with IC2.

  • Could you please link a patched class file for those of us who really don't want to have to wait for everything to update to 1.2.4 so we can have 6 more vanilla blocks and other minor tweaks? I for one would be grateful if it's not too much bother.


    The patch is for MC version 1.2.4 only.
    IC public version is for version 1.2.3 only (for now).


    You can't possible use the patched file without MC crashing.

  • The patch is for MC version 1.2.4 only.
    IC public version is for version 1.2.3 only (for now).


    You can't possible use the patched file without MC crashing.

    Just send the source I could help you there and I can't even program But I'm sure I could figure out how to set up a 1.2.3 environment and compile it for ya :)

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • Just send the source I could help you there and I can't even program But I'm sure I could figure out how to set up a 1.2.3 environment and compile it for ya :)

    Yea, it wouldnt hurt us having a 1.2.3 version of this, as most of us will be there for a while. Please.

    God blesses the child that can hold its own.

  • For the meantime until things are updated to 1.2.4 or a later version, you could try using CraftGuide and it's QuickGuide addon for recipes and such. Functionally the same in regards to crafting recipes and machine recipes.

  • Wait a minute... can't we just remove the NEI compatibility layer and get the recipes to work, just without the filter... (testing)


    Well I can't get it to work, but the IC2 1.81 jar works fine without the nei integration folder, but none of the recipes are picked up without it it seems. Maybe someone else could come up with a "hack job" solution. I can wait a few weeks but it would be nice to get my private server mod pack fully functional in the meantime.


    Edit:
    Yes I realize I *could* use NEI 1.1.3, but that didn't have a RedPower plugin, at least not one I could find by searching for the filename (adf.ly supported link)/Files/NEI/NEI_RedPowerPlugin%201.1.3.zip, 1.1.2 (for Minecraft 1.1) was there, and obviously 1.2.0 was there as well. Unfortunate overlap of incompatibility.

  • Wait a minute... can't we just remove the NEI compatibility layer and get the recipes to work, just without the filter... (testing)


    Well I can't get it to work, but the IC2 1.81 jar works fine without the nei integration folder, but none of the recipes are picked up without it it seems. Maybe someone else could come up with a "hack job" solution. I can wait a few weeks but it would be nice to get my private server mod pack fully functional in the meantime.


    Edit:
    Yes I realize I *could* use NEI 1.1.3, but that didn't have a RedPower plugin, at least not one I could find by searching for the filename (adf.ly supported link)/Files/NEI/NEI_RedPowerPlugin%201.1.3.zip, 1.1.2 (for Minecraft 1.1) was there, and obviously 1.2.0 was there as well. Unfortunate overlap of incompatibility.

    As far as I know it did not have Railcraft also and my servers in the same vote let alone my LP. Ticked a lot of people off but you kind of have to live with it. Most other mods (BESIDES RP) will do quick fix jobs. Kind of funny story the 2 guys working on BC now use to make quick jobs all the time for BC for the public. Without them who knows how bad things would have gone and now they are the main devs.


    You will get use to it in modding. For example IC will be 1.2.4 and say it's fixed but now 4-5 Mods will not be 1.2.4 because people are on holidays and some others are just tired of updating weekly even more that 1.2.5 is coming and THAT means even more delays because IC might be tired at 1.2.5 and it might come 2 weeks later and omfg it's sometimes better to go back to 1.1 :P

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • ... sometimes better to go back to 1.1 :P

    Sometimes I'm tempted to go back to 1.7.3 just for the world generation, since 1.8 if feels a bit "homogenized" if that makes any sense. I suppose it's just how large and mostly unvaried certain biomes can be. Hopefully Mojang will actually get moving on the modding API, and include everything Forge/ModLoader modders need to implement their mods. Then modders should mostly only have to recompile their mod against the new API each time the game updates.

  • Sometimes I'm tempted to go back to 1.7.3 just for the world generation, since 1.8 if feels a bit "homogenized" if that makes any sense. I suppose it's just how large and mostly unvaried certain biomes can be. Hopefully Mojang will actually get moving on the modding API, and include everything Forge/ModLoader modders need to implement their mods. Then modders should mostly only have to recompile their mod against the new API each time the game updates.

    Yeah don't worry I know the feeling. I remember how stable stuff was back in like 1.1-1.3 I think it was back in beta and lol... I know the feeling and sometimes its best to sit for a while on a version till things have stabilized. That way when you do upgrade it's a smack of new features.

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • For those wanting 1.2.3: Sadly the code was already ported to 1.2.4.


    I feel sort of guilty for making Sengir release a 1.2.4 version of BC (he didn't want to) just by telling him there will be an IC2 for 1.2.4.

  • For those wanting 1.2.3: Sadly the code was already ported to 1.2.4.


    I feel sort of guilty for making Sengir release a 1.2.4 version of BC (he didn't want to) just by telling him there will be an IC2 for 1.2.4.

    Am I not correct in assuming that is not even going to be a 1.2.4 version of NEI? I really wished there was a hot fix as ill end up being on 1.2.3 for at least another couple weeks waiting for all the mods and addons to update and I'm just going to skip 1.2.4

  • Am I not correct in assuming that is not even going to be a 1.2.4 version of NEI? I really wished there was a hot fix as ill end up being on 1.2.3 for at least another couple weeks waiting for all the mods and addons to update and I'm just going to skip 1.2.4

    You probably assume right. The chances of a 1.2.4 nei are very slim since chicken is on Holidays. Good for him hes done a great job and deserves it!

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • For those wanting 1.2.3: Sadly the code was already ported to 1.2.4.


    I feel sort of guilty for making Sengir release a 1.2.4 version of BC (he didn't want to) just by telling him there will be an IC2 for 1.2.4.

    I cannot find a link. I found 3.1.4 only. Can you point me? Or you mean Forestry 1.4.2.0 ?