New version of forge not compatible with IC2?

  • When i launch the game it gives me this message:



    Mods loaded: 4
    ModLoader 1.2.5
    mod_MinecraftForge 3.0.0.72
    mod_ModLoaderMp 1.2.5v1
    mod_IC2 v1.90


    Minecraft has crashed!
    ----------------------


    Minecraft has stopped running because it encountered a problem.





    --- BEGIN ERROR REPORT ac9caec1 --------
    Generated 4/8/12 4:51 PM


    Minecraft: Minecraft 1.2.5
    OS: Windows 7 (amd64) version 6.1
    Java: 1.7.0_01, Oracle Corporation
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    LWJGL: 2.4.2
    OpenGL: GeForce GTX 470/PCIe/SSE2 version 4.2.0, NVIDIA Corporation


    java.lang.RuntimeException: IndustrialCraft 2: MinecraftForge Major Version Mismatch, expecting 2.x.x
    at forge.MinecraftForge.killMinecraft(MinecraftForge.java:440)
    at forge.MinecraftForge.versionDetect(MinecraftForge.java:453)
    at mod_IC2.load(mod_IC2.java:92)
    at ModLoader.init(ModLoader.java:891)
    at ModLoader.addAllRenderers(ModLoader.java:189)
    at ahu.<init>(ahu.java:77)
    at ahu.<clinit>(ahu.java:8)
    at net.minecraft.client.Minecraft.a(Minecraft.java:394)
    at net.minecraft.client.Minecraft.run(Minecraft.java:732)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT c65a887 ----------


    Does it mean that the new forge doesnt work with IC2?

  • I just posted that the IC2 v1.90 will work in MC v1.2.5 but only if your using the 2.0.0.68 version of forge. Also included in that post is a whole slew of other mods that are running in MC v1.2.5 that up untill about 3 or 4 days ago were only out for MC v1.2.3 and a few had recently been updated to run in MC v1.2.4.

  • I just posted that the IC2 v1.90 will work in MC v1.2.5 but only if your using the 2.0.0.68 version of forge. Also included in that post is a whole slew of other mods that are running in MC v1.2.5 that up untill about 3 or 4 days ago were only out for MC v1.2.3 and a few had recently been updated to run in MC v1.2.4.

    1.2.4 mods only works on 1.2.4 MC. Learn that logic man.

  • mmaaxxii: if you just made an account to post that and troll us all, you need to kill yourself in a fire... seriously.
    Even Steve is mad at you now. MinecraftChar

  • when is the update for mc 1.2.5 coming out ?

    the highest noob crimes of the ic forums
    1. not reading all the stickies before your first post
    2. asking for a release date as a result of not following rule 1
    3. suggesting lightning rods be added as a result of not following rule 1
    4. suggesting most other previously denied suggsetions as a result of not following rule 1
    are you beginning to see the pattern here?

    true balance is impossible in video games the best one can hope for is to make it really hard to guess which of 2 choices are better.
    and remember kids "NEVER UNDERESTIMATE THE POWER OF JOKES!"

  • the highest noob crimes of the ic forums
    1. not reading all the stickies before your first post
    2. asking for a release date as a result of not following rule 1
    3. suggesting lightning rods be added as a result of not following rule 1
    4. suggesting most other previously denied suggsetions as a result of not following rule 1
    are you beginning to see the pattern here?

    You came here because i said that it happened or? :D


    Oh and now he is in the Void. (banned)

  • You came here because i said that it happened or? :D


    Oh and now he is in the Void. (banned)

    after you mentioned it you probably heard a distant voice shouting "to the support forum!" *car door slam* "SCREEAAACH!VROOOOOM!!!"

    true balance is impossible in video games the best one can hope for is to make it really hard to guess which of 2 choices are better.
    and remember kids "NEVER UNDERESTIMATE THE POWER OF JOKES!"