[Unofficial][SSP/SMP] Way to make IC2 v1.90 working on MC 1.2.5 with forge 3.x

  • download updated now SSP and SMP hotfix inside

    [SSP - How to]
    In attachment here is modified class(unofficial) to work with
    lastest forge build 3.x, no major errors found in SSP except NEI problems with
    recipes, extract and replace original mod_IC2.class in original IC2
    v1.90 from download site

    Modloader and modloaderMP for 1.2.5 are required

    [SSP problems]

    + NEI - recipe display issue - use craftguide will work fine

    [SMP - How to]

    Install lastest modloaderMP and lastest forge - no conflicts but in future it may appear
    than replace original class in industrialcraft-2-server_1.90.jar with mine from archive folder "MP"

    [SMP issues]

    + texture problem? - hmm what side should i connect things :D - some kind of graph bug, but works fine :)
    + looking for more, it will be updated in this post

  • The .zip contains 1 file. Downloaded it and scanned it with Norton and a bunch free virus scanners. The .zip is clean and the only file in the .zip is clean too.

    EDIT: I know I have got only 1 post but that's because I'm new to this forum. I am active on a ton of other forums including a security forum.

  • Uh, and no disrespect to new posters, I'm not here to give out sh**. What I'm saying is not what your file is for, but what it does to fix the problem. Like sure, it's a fix, but like... If you just made IC2 compatible, wouldn't you want Alblaka to know, as you've now helped him? Don't you.. you know... want to........ explain this at all? Even a little?

  • IC2 is 1.2.5 compatible (no major bugs found), but had problems with forge 3.x, that my fix do, allowing to launch IC2 with forge 3.x thats all

  • This is working and giving no errors what so ever, but I tried to make Crops or even use NEI to find a IC2 Machine, nothing to be crafted or found.

    So perhaps it's not working or is this intended? xD


  • everything works got crops (cute stickreed farm :D), and i mentioned NEI problems (last working compatiblity layer is for MC 1.1.0 didnt had enough time to make it working :D)- it wont show recipes, but they work, you will have to look at wiki :), or use craftguide mod (this compatiblity layer works nice), some screenshots below

  • Since Minecraft is using incremental obfuscation now (this means that any new classes/methods/fields will NOT change the old ones, and will just add on to it, making it MUCH, MUCH, *MUCH* easier for the MCP team), any 1.2.4 mod should work with 1.2.5.

    The only thing that is causing IC2 not to work in 1.2.5 is the removal of ModLoaderMP from Forge 3.x. This person probably just removed the import in the mod_ file.

  • Quote

    no major errors found in SSP

    No such luck, boss. I tried this with the 75, 81, and 84 builds of Forge 3.