[Addon 1.115]Transformers BETA-1 v2.0 - Convert IC2 & BC3 energy back & forth!

  • Well, there is a texture issue, the Wireless Redstone as well as the Pipes are not showing up. Thing is, it only breaks when i put the Loss Fix in, without it, its fine. Im pretty sure without Wireless Redstone the problem would be gone yes, but i want to keep that.

    Intel i7 990X @ 4,60 GHZ, Asus Rampage III Black Edition, 24GB Corsair Dominator GT DDR3,
    2x Zotac Nvidia Geforce 580AMP 1,5gb, OCZ Revodrive 3 X2 240GB 1GBps,
    1TB Western Digital Cavier Black, 2x Hitachi HDS723030BLE640 3TB, 3x BenQ XL2410T LCD-Monitors


    Hosting Minecraft Servers on an Octo Core 32GB Ram Server: http://two66.com/
    Free Space available! If you need a Server let me know!

  • hmm looks like some problem there while running

  • No all issues start when the Loss Fix is in place; without it, everything is fine.

    Intel i7 990X @ 4,60 GHZ, Asus Rampage III Black Edition, 24GB Corsair Dominator GT DDR3,
    2x Zotac Nvidia Geforce 580AMP 1,5gb, OCZ Revodrive 3 X2 240GB 1GBps,
    1TB Western Digital Cavier Black, 2x Hitachi HDS723030BLE640 3TB, 3x BenQ XL2410T LCD-Monitors


    Hosting Minecraft Servers on an Octo Core 32GB Ram Server: http://two66.com/
    Free Space available! If you need a Server let me know!

  • Something got a version mismatch. Could be forge.
    Try getting a less recent version of forge, I compiled against 3.1.2.94 - so that one will work in all cases.


    TampaPowers: I uploaded a new version, try that one.
    If that doesnt fix your problem, you can try getting forge 3.1.2.94, if that doesnt fix it, I really don't know what will :/.

  • Then either
    - your download got corrupt, so redownload
    - you're still on java 6 while I'm on 7 - upgrade to java 7.
    If that doesnt fix it, I have no idea how to solve it. Can you get me a proper error report, not ModLoader.txt?

  • desciption says eg for the LV-Generator it takes 32 and not more
    but placing a adjustable machine with 512 eu -> full power -> lv generator -> output is again ~512 eu . but shouldn´t this be 32 ?
    same is for all generators
    i can even burn the fibre cable when raising up to 800 MJ / 2048 EU with an LV-Trafo

  • desciption says eg for the LV-Generator it takes 32 and not more
    but placing a adjustable machine with 512 eu -> full power -> lv generator -> output is again ~512 eu . but shouldn´t this be 32 ?
    same is for all generators
    i can even burn the fibre cable when raising up to 800 MJ / 2048 EU with an LV-Trafo


    Thanks for spotting that one! Must have been late when I made that algorithm.
    It's now fixed and is a little bit more efficient aswell in transforming.
    Updated to v1.2 for all the bugfixes.

  • I was using forge 3.1.2.90 if im not wrong, maybe i need to update to .94 Will try that now.


    Edit: Newest Forge and LossFix are working, can't say if the Loss Fix functions, but no carshes no more :D


    Some server side error:

    Intel i7 990X @ 4,60 GHZ, Asus Rampage III Black Edition, 24GB Corsair Dominator GT DDR3,
    2x Zotac Nvidia Geforce 580AMP 1,5gb, OCZ Revodrive 3 X2 240GB 1GBps,
    1TB Western Digital Cavier Black, 2x Hitachi HDS723030BLE640 3TB, 3x BenQ XL2410T LCD-Monitors


    Hosting Minecraft Servers on an Octo Core 32GB Ram Server: http://two66.com/
    Free Space available! If you need a Server let me know!

  • Not sure if it's cause of your code or not, but when I fully use the variable electric engine I get a texture bug. It is where I get a weird flashing thing near the base of the engine. I have no error log or anything else, because it does not crash my game.


  • Ah, I think the problem is that the loss fix only works for client.
    PowerLossfix.zip now containst two folders, one for client and one for server, just copy the contents of the folder you need to your buildcraft transport.zip and it should be fine now :)


    Quote


    Not sure if it's cause of your code or not, but when I fully use the variable electric engine I get a texture bug. It is where I get a weird flashing thing near the base of the engine. I have no error log or anything else, because it does not crash my game.

    This is on SMP right? Yeah I can't fix that. It's just so fast that it fails to render properly :P


  • Thanks for spotting that one! Must have been late when I made that algorithm.
    It's now fixed and is a little bit more efficient aswell in transforming.
    Updated to v1.2 for all the bugfixes.

    thank you very much. Good to know that the mod is actively maintained.

  • All working now no errors, thanks a lot. I'll keep reporting if anything comes up.
    :thumbsup: :thumbsup: :thumbsup:

    Intel i7 990X @ 4,60 GHZ, Asus Rampage III Black Edition, 24GB Corsair Dominator GT DDR3,
    2x Zotac Nvidia Geforce 580AMP 1,5gb, OCZ Revodrive 3 X2 240GB 1GBps,
    1TB Western Digital Cavier Black, 2x Hitachi HDS723030BLE640 3TB, 3x BenQ XL2410T LCD-Monitors


    Hosting Minecraft Servers on an Octo Core 32GB Ram Server: http://two66.com/
    Free Space available! If you need a Server let me know!

  • there's a bug with the recipe for the adjustable engine. you got the metadata for the lapos wrong it can only be crafted with TMI'd lapos not legit ones (tried charged and uncharged)

  • there's a bug with the recipe for the adjustable engine. you got the metadata for the lapos wrong it can only be crafted with TMI'd lapos not legit ones (tried charged and uncharged)

    Fixed! Thanks for helping me spot all these little bugs guys :)


    Now for something completely different:
    What do you all think about a generator which runs off fuel?
    I don't like it alot as it would remove the need of buildcrafts engines entirely - it'd be just electric engine -> refinery -> fuel generator -> profit.
    Now it's electric engine -> refinery -> combustion engines (which have to be cooled) -> pneumatic generator -> profit, however this is harder to achieve, and it should be imo.
    However it does fit the mod, as another way to transform BC energy to IC energy - what's your opinion?

  • Fixed! Thanks for helping me spot all these little bugs guys :)


    Now for something completely different:
    What do you all think about a generator which runs off fuel?
    I don't like it alot as it would remove the need of buildcrafts engines entirely - it'd be just electric engine -> refinery -> fuel generator -> profit.
    Now it's electric engine -> refinery -> combustion engines (which have to be cooled) -> pneumatic generator -> profit, however this is harder to achieve, and it should be imo.
    However it does fit the mod, as another way to transform BC energy to IC energy - what's your opinion?


    I think fuel powered generators would be awesome. Like a backup gas powered generator in case the zombie horde destroy all my solar cells.

  • Fixed! Thanks for helping me spot all these little bugs guys :)


    Now for something completely different:
    What do you all think about a generator which runs off fuel?
    I don't like it alot as it would remove the need of buildcrafts engines entirely - it'd be just electric engine -> refinery -> fuel generator -> profit.
    Now it's electric engine -> refinery -> combustion engines (which have to be cooled) -> pneumatic generator -> profit, however this is harder to achieve, and it should be imo.
    However it does fit the mod, as another way to transform BC energy to IC energy - what's your opinion?

    powerConverters had a oil generator able to crate oil out of EU. This would be a great thing to have with the fuel generator

  • well i already have a 32 engine powerplant feeding a HV pneumatic gen. I don't see any need for a direct fuel>eu generator, i prefer the planning and expense of a water cooled setup considering the HUGE amount of eu that is in fuel (500000eu per bucket ~480000 if you count the cost to refine) so by my calculations i have around 40 BILLION eu in fuel storage and another 120 billion in the umpumped oil deposit