Rocket Science IC2-based Takeover IC2 [103]Needs Friendly Helpers

  • MIA means Missing In Action, which means he hasn't been seen in a while.


    Bug: if any block ID is set over 255, the mod will crash. (It seems like it tries to add the block twice, conflicting with itself.)

  • How can this even happen every time I adjust the id it Conflicts with the new id and so fort



    :!: PLEASE HELP :!:


    "Bug: if any block ID is set over 255, the mod will crash. (It seems like it tries to add the block twice, conflicting with itself.)"


    Doesn't matter it keeps crashing

    52 instances of minecraft are handable... not that you need to play all of them *ahem; ugh ugh* :S

  • MIA means Missing In Action, which means he hasn't been seen in a while.


    Bug: if any block ID is set over 255, the mod will crash. (It seems like it tries to add the block twice, conflicting with itself.)


    Scratch that, it's happening for me with any block ID. Perhaps it's an incompatibility with Forge 171?

  • Seems to be a block-container thing, I'll hopefully get a fix out by noon tomorrow. Nice job with the formatting, much easier to understand than " minecraft crashes on load this mod sucks" crap
    EDIT: the main class is double-initializing, that explains a lot, tested it by making an intended NPE on 2nd initilization.

  • Just so you know im mkaing an all out war server that(at the end) will have a ton of guns,bombs,and other weapons.It will be a extreme PVP server.
    PM me if you want to join(its a hamachi server)

  • Really looking forward to this being updated.


    I'd love to test the mod, but we currently run Tekkit, and it appears i can't add this in to it :(


    when i try it just crashes on boot :(


    do you have any plans to make this compatible with tekkit client?

  • i tested this whit ic 1.103, but this version of ic use fore whit fml, and minecraft crach.


    How i can instal RS whit ic 1.103??



    edit: i'm tested whit the forge 3.3.8.152 but minecraft crach again!!!

    The post was edited 1 time, last by Nibor62 ().

  • not your fault, just some buggy beta stuff

  • He hasn't totally been MIA. He posted in the thread that development for RS would be ending and posted the source code to it so the community could do something if they wanted to. This is just to update it and hopefully at some point add new features.

    Error 404: Signature not found!

  • ok!!


    You say beug, We can't use the beta for the moment?


    new features, humm, craft more expensive for the superconductor (more expensive than this :Glass Fibre: ), and a better nuclear explosion would be nice.


    But continue modding is already good

  • bah I just switched my server to bukkit..


    Time to figure out how to port it


    Thanks for continuing this BTW. hope it gets out of beta soon..

  • so I just tested the server version. Here are my finds so far which blew my mind for a min. Almost made a video to make sure I wasnt loosing my mind


    First a crash error.
    [INFO] Giving Tester 64 of Isotopic Separator
    [WARNING] Failed to handle packet: java.lang.IndexOutOfBoundsException: Index: 41, Size: 40
    java.lang.IndexOutOfBoundsException: Index: 41, Size: 40
    at java.util.ArrayList.RangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at ic2.common.ContainerIC2.a(ContainerIC2.java:113)
    at mm.a(NetServerHandler.java:836)
    at ry.a(SourceFile:28)
    at qq.b(NetworkManager.java:353)
    at mm.a(NetServerHandler.java:75)
    at fk.a(SourceFile:107)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:575)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:450)
    at dn.run(SourceFile:492)
    Isotopic still doesnt have a skin, it has a block but no GUI


    The Fusion reactor. lol This lil guy is nuts.
    SSP works great. powers up, generates power. all good.
    SMP (been waiting for this) There is a block but no GUI. You can left click on it and it gives you an ingame message of:
    Heat: 0, Fuel: 0, ignited:False, Fuel Type: 0, production: 0, added to grid: false, storage: 0, breeding: 0
    The Neutral-beam heating system worked like a wrench, however when I removed the wrench from my hotbar, it no longer worked like a wrench.
    Right clicking on the Reactor with the water fuel cells, acted like it at it up in a slot, however left clicking it put it back in the inv. weird.


    So I deleted everything in my Inv. and only had the wire. (which works great btw). it moved around in my inv when clicking on the fusion reactor.


    the rockets seemed to work fine, didnt mess with them too much. The laser range finder thing works fine. gives X/Y coords.
    rockets still have no skin. but are launch able.
    Let me know when a revised version SMP comes out. I'll test the reactor again.


    btw, this was tested on a private server that I host on my computer to test Id conflicts and errors before I upload them to my actual server. See if you or someone else can replicate the issues I had. If not I'll give it a fresh server.jar


    Thanks, keep up the good work


    Archer

  • the majority of the blocks doesn't show any textures in both world and menù do you will release a bug fix soon?is a little bit hard the set up a working missile defence system if you can't see the blocks.