[GregTech-6][1.7.10][Website][Patreon] Info, Support and Suggestions

  • I have a fail load in FTB after last GT update. FTB says more informations are in ForgeModeLoader-client-0.log. But I did not found it. I found FTBLauncher Log.txt only. iI´ve tried to remove a GalacticGreg mod, but that didn´t fix that problem.


    PS: thx Gorilla


    Can conform this with yesterdays released GregTech update, but not in FTB:


    Seems like some new Mod loading orders were introduced :)
    Full log in Attachement.

  • I thought so :(. Thats bad, I using multiparts.

    Today's amusing trivia is that this is the forum 200 000th post

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • i am using project red it is so fun mod to do
    so i am not gonna remove this
    but it's having problem with gregtech
    are you gonna fix this later?


    Likely cycle is in : [FMLMod:gregapi_post{GT6-MC1710}, Dummy Container (After) @804009130, FMLMod:ForgeMicroblock{1.2.0.345}, Dummy Container (AfterAll) @626942150]
    [15:04:16] [Client thread/ERROR]: A dependency cycle was detected in the input mod set so an ordering cannot be determined
    [15:04:16] [Client thread/ERROR]: The first mod in the cycle is Dummy Container (After) @804009130
    [15:04:16] [Client thread/ERROR]: The mod cycle involves
    [15:04:16] [Client thread/ERROR]: FMLMod:gregapi_post{GT6-MC1710} : before: [], after: [gregapi, IC2, IC2NuclearControl, ForgeMicroblock, ComputerCraft, OpenComputers, Forestry, ImmersiveEngineering, UndergroundBiomes, PFAAGeologica, Thaumcraft, Railcraft, appliedenergistics2, ThermalFoundation, ThermalExpansion, chisel, TwilightForest, harvestcraft, AppleCore, enviromine, magicalcrops, BuildCraft|Transport, BuildCraft|Silicon, BuildCraft|Factory, BuildCraft|Energy, BuildCraft|Core, BuildCraft|Builders, Magneticraft, DragonAPI, ElectriCraft, ReactorCraft, RotaryCraft, GalacticraftCore, GalacticraftMars, GalacticraftPlanets, atum, ThermalExpansion|Transport, ThermalExpansion|Energy, ThermalExpansion|Factory, RedPowerCore, RedPowerBase, RedPowerMachine, RedPowerCompat, RedPowerWiring, RedPowerLogic, RedPowerLighting, RedPowerWorld, RedPowerControl]

    The post was edited 1 time, last by doswls1 ().

  • For anyone also having the load cycles problem, I forked FMP and removed the "after:*" mod loading dependency.
    I'm not sure if this will break existing microblock configurations, but this is for anyone who can't wait or needs FMP because of other mods.
    Build in Attachement, No warranties at all!

    Edit: It will prevent you from adding microblocks via the config file if those mods are loaded after FMP!
    nope, still works


    EDIT2: My Pull request got merged, Official FMP version (1.2.0.347+) now works too: http://files.minecraftforge.net/ForgeMultipart/

  • Kind of a minor exploit! Shovel heads have 0.888 units of material in them, while raw universal spades have a whole 1.000 units in them. If you craft a raw universal spade head from, say, a damascus steel shovel head found in a mineshaft, you get a free extra nugget of material out of it.

  • I have gregtech_1.7.10-6.01.06 at hard difficulty and I see hammer recipe in NEI (6 ingots and stick), but can't craft it by recipe. How to do first hammer?


    UPD: I can craft stone hammer, but can't craft copper/tin/lead, it's normal?

    The post was edited 3 times, last by Denai ().

  • do you actually have the ingots or what are you asking for?

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • I have the same problem Dekker had. :(


    It says:
    Forge Mod Loader has found a problem with your minecraft installation
    A mod sorting cycle was detected and loading cannot continue
    ...and more
    It mentions about the Buildcraft silicon, buildcraft factory, bc energy, bc core...


    It happened right after I updated my GT6 version to the newest version.
    I did check other mods' updates, and I am playing my customized mod pack in Curse(FTB).
    It works perfectly fine if I remove gregtech and play.
    I can't understand Gorilla's reply because of language, so.... ?(


    Edit: ultrasn0w's ForgeMultipart file made me happy again :)
    Thank you those who try to help me (I'm sorry that I didn't really see any other replys except Gorllia's)

    The post was edited 4 times, last by aerun ().