[AddOn v1.43/v1.64] Advanced Machines V3.2 Beta 2

  • That mechanism is already here :O?


    Put a few levers on your machines, turn them on, Done!

    Sorry, forgot to mention, that I have a version 2.1, not 3.0 (didn't update server+client for a while). Was that included in the mod somewhere between 2.1 and 3.0 or I'm failing with my design? I have a Rotary Macerator connected to a LW supply and a redstone torch right next to it. RPM still drops to 0, if there is nothing to pulverize. Am I missing something simple? Also, I can't put a lever on top, because there is connected a BC pipe. Thanks.


    UPD: Yes, with a lever on top works fine. What are my options? Is there another way to put in items from a BC pipe?


    UPD 2: Ok, figured it out by myself. Lever on a side works too, but a machine doesn't react to a torch or a redstone wire. Is this intended behavior? :)

  • Sorry, forgot to mention, that I have a version 2.1, not 3.0 (didn't update server+client for a while). Was that included in the mod somewhere between 2.1 and 3.0 or I'm failing with my design? I have a Rotary Macerator connected to a LW supply and a redstone torch right next to it. RPM still drops to 0, if there is nothing to pulverize. Am I missing something simple? Also, I can't put a lever on top, because there is connected a BC pipe. Thanks.


    UPD: Yes, with a lever on top works fine. What are my options? Is there another way to put in items from a BC pipe?


    UPD 2: Ok, figured it out by myself. Lever on a side works too, but a machine doesn't react to a torch or a redstone wire. Is this intended behavior? :)


    They need a direct redstone connection, indirect won't work.
    Also: try medium voltage on them ;)

  • I get this error with the server:



    I've tryed adding a "z" in front of the filename but doesn't work on my Linux server, think this is becaouse ModLoaderMp doesn't load mods in alpabetic order. Any fix for this, eventually Zippinus/cpw, could you try fix this?

  • I get this error with the server:



    I've tryed adding a "z" in front of the filename but doesn't work on my Linux server, think this is becaouse ModLoaderMp doesn't load mods in alpabetic order. Any fix for this, eventually Zippinus/cpw, could you try fix this?


    Sadly, the code that loads mods is in ModLoaderMP, on the server side. I can't "fix" this particular problem. If you're on a bukkit server, I just posted a fixed ModloaderMP for bukkit over on mcportcentral however, that will add in the sorting you want...

  • Maybe you could add this peace of code into AdvancedMachines:


    Code
    1. try {
    2. mod_IC2.initialize();
    3. } catch (Exception e) {
    4. e.printStackTrace();
    5. }


    Then i think IC2 should get loaded before AdvancedMachines if it exist and not is already loaded :) What do you think?

  • Maybe you could add this peace of code into AdvancedMachines:


    Code
    1. try {
    2. mod_IC2.initialize();
    3. } catch (Exception e) {
    4. e.printStackTrace();
    5. }


    Then i think IC2 should get loaded before AdvancedMachines if it exist and not is already loaded :) What do you think?


    No, it won't work at all. The problem is that the class loading context won't even know about IC2 when AM loads in that case. ModLoader adds class loading contexts for each jar/zip/whatever as it encounters them. The problem is, to even load AM, it needs to have already loaded IC2. In your example: mod_IC2 won't even exist as a class in java at the point that code will execute.


    There's no simple way around the problem- you have to figure out a way to sort your directory ordering. I would suggest you look at my ModLoaderMP fix on the mcportcentral forums. I can't fix vanilla the same way though, you need Flan to.


  • UPD 2: Ok, figured it out by myself. Lever on a side works too, but a machine doesn't react to a torch or a redstone wire. Is this intended behavior? :)


    For the version you're talking about (2.1, for IC 1.15) yes, it doesn't react to redstone, except directly applied to the block (through button or lever).


  • There's no simple way around the problem- you have to figure out a way to sort your directory ordering. I would suggest you look at my ModLoaderMP fix on the mcportcentral forums. I can't fix vanilla the same way though, you need Flan to.

    Why is that? Flan's been ignoring any attempt at communication about the rather major bug there so it's unlikely we'll see a fix from him. Any chance at all you could do a fix for vanilla?

  • Why is that? Flan's been ignoring any attempt at communication about the rather major bug there so it's unlikely we'll see a fix from him. Any chance at all you could do a fix for vanilla?


    Theoretically, it likely wouldn't be too hard, but it's unlikely that I'd post it after my last attempt to attach files other than advanced machines.

  • Theoretically, it likely wouldn't be too hard, but it's unlikely that I'd post it after my last attempt to attach files other than advanced machines.


    could you please? You could always upload it to mediafire or someplace like that and link to it here... perhaps just PM it to me? I'm semi-desperate for a fix here as I literally can't bring my server up. Forestry persists in loading before Buildcraft so everything goes *bang*
    I've got some knowledge of java but I woulnd't know where to begin modding minecraft, let alone modding a mod.

  • I mean't minecraft_server.jar, and yup, its working.


    wasn't working when I tried it.
    Found a 100% evil and annoying to maintain option though... stick Buildcraft into the .jar and then leave any sub-mods in the mods folder.
    Not sure if this'd work for anyone having the same problems with IC2 as i'm not sure if it likes living outside it's jar in the mods folder or not.


  • wasn't working when I tried it.
    Found a 100% evil and annoying to maintain option though... stick Buildcraft into the .jar and then leave any sub-mods in the mods folder.
    Not sure if this'd work for anyone having the same problems with IC2 as i'm not sure if it likes living outside it's jar in the mods folder or not.


    It should, because MLMP should load the mods in the minecraft(_server).jar, then move to external ones. And IC2 works just fine outside it's .jar. You _could_ extract the files, throw them in a .zip, and name it something crazy, and it'd still work just fine.

  • It should, because MLMP should load the mods in the minecraft(_server).jar, then move to external ones. And IC2 works just fine outside it's .jar. You _could_ extract the files, throw them in a .zip, and name it something crazy, and it'd still work just fine.

    MLMP loads mods for the server just fine on a Windows-based server, due to loading alphabetically(goes .jar first, then external mods), but on a Linux server I think it loads via changes dates which can really screw things up (external mods then jar, as well)