[IC2 Exp][1.7.10] Advanced Machines 1.1.6

  • Congrats on finally making version 1 :P

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • Since this severely simplifies the code overhead, i might even think about adding other machines. I saw IC2 has added a bunch of new ones.

    I, personally, would LOVE advanced versions of the new machines.

  • Wow, trying to fix this made me discover just how screwed i am


    Version 1.0.1
    - fixed rather high level obfuscation issue by using IC2 stubs as workaround
    - have to stub every single overridden IC2 class and their hierarchy. this sucks so hard



    It works now but having to use Stubs for all the IC2 classes downgrades this version from "elegant solution" to "horrible hackwork"
    I'd need access to the IC2 sourcefiles to fix this problem

  • Ok Cool i will hav a look now.



    Plus if u email the IC2 dev guys i believe they are more than happen to help you. i did it once when i was trying to make an add on and they happily sent me the source code.

  • Nice it works now. Well done


    only one suggestion i have.


    i think the default max speed is a bit too slow.


    i know u can change it in the config. but the default speed is much slower than the induction furnace and someone of the other Advanced machines mods hav the machines going alot fast.


    i know it can be changed but i think it would be going to include the default speed so that is about the same as the induction furnace. Then people can change it if they want to.



    i only do a brief test as it is 1:33am at the time of this post and well it work and didnt crash. And on the up side the cables stay connected :)



    Very nicely done. good job.

  • 1. Are you using newest version which is for 1.6.4 on 1.6.2, coz that might not work. and the correct version of forge and IC2


    2. If your playing on 1.6.2 make sure you have a 1.6.2 version, if your on 1.6.4 make sure you have a 1.6.4 version


    3. Try redownloading the mod and sometimes it may not download correctly and be missing things (yes that is possible)


    4. If your using a texture pack that might be messing up the textures for some unknown reason.


    5. Some weird shit is happening.




    Thats just a few things to try

  • Hey.


    Something has bugged and im not sure why


    The recipes seem to not be working correctly.


    NEI wont show the recipe for the Rotary Macerator.
    When the recipe for the Singularity Compressor is shown, the Rotary Macerators Recipe is used with the Compressor output.
    When the recipe for the Centrifuge Extractor is shown, the Singularity Compressor Recipe is used with the Extractor Output.


    Im using the second release version of your Mod.
    IC2 Experimental 295
    Forge 9.11.1.935
    FML 6.4.31.935


    i dont believe it was happening before i updated like 20 mins ago. it just a really strange bug.


    Because when i checked your src code it look perfectly fine to me. really weird.
    could be a bug with NEI but not sure.



    The only thing i saw in the code is that the block metadata started at 1 not 0. i dont know if that makes a difference but i thought it does. (but im not the modder here).


    The Log looks fine to me. Weird Bug. sort of annoying.


    Thanks

  • Found another problem


    The upgrade slot in each of your machines are down 2 pixels too far.


    Just need to change 1 value to fix.


    then all good.




    thanks

  • To add to that, the Macerator's white "processing" progress animation is slightly askew to the right. The Compressor's progress animation looks just fine. I haven't looked at the Extractor's progress animation yet, so if I don't come back to post on it, you may want to check that.


    So far so good otherwise. I ran a few batches thru the Macerator and Compressor, and it works as good as usual. Personally, I'm happy enough to live with these small cosmetic inconsistencies while my cables stay connected on game load.

  • Hello,
    I registered here because I am getting a wierd crash when using your mod. It is related to Rotary Macerators. Here it is in spoiler:


    I am using IC2 2.0.293_Experimental version, 1.6.2 experimental version of your mod, and minecraft 1.6.2. Can you tell me if you will fix this mod, otherwise I am going to have to omit this mod ;(

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Hello,
    I registered here because I am getting a wierd crash when using your mod. It is related to Rotary Macerators. Here it is in spoiler:


    I am using IC2 2.0.293_Experimental version, 1.6.2 experimental version of your mod, and minecraft 1.6.2. Can you tell me if you will fix this mod, otherwise I am going to have to omit this mod ;(

    I actually got a crash just yesterday too concerning the Rotary Macerator. I decided not to post it yet until I could find out more details on what the conditions were that caused the crash and re-duplicate it. Right now it has me boggled, because it worked fine when used by hand, but in an attempt to use it as part of an assembly line of machinery and pipes, it decided to crash the game, while simple tests to duplicate the issue so far has failed.

  • I think I was able to figure out what my particular problem was, but I'm not certain it's the same issue as Mad3ineer judging by the subtle differences in our crash logs.


    What I think happened at first is that is I was feeding coal into a macerator by BC pipes, but I accidentally allowed a redstone dust pass into the macerator as well thru the same piping. My guess is that it got inserted in the Additive Macerator slot, and crashed the game (Crash log named crash-2013-11-20_15.46.53-server.txt).


    At first I didn't realize this could be the case. Later that same day, I was fooling around on creative mode trying to duplicate the error without luck, when I suddenly decided to stick a "milk bucket" (from MFR) into the Additive Macerator slot at random, and then the game crashed (Crash log named crash-2013-11-20_16.26.29-server.txt). I didn't realize this crash was related, but just today I looked at both error logs together, and they look just about the same as far as where the crash happened at.


    Not everything put in the Additive Macerator slot causes the crash though. So far I've accidentally placed coal in the additive slot, and all it does is stop the macerator from processing anything.



    If you don't mind me posting the crash logs as attachments, here they are. They were too big to post otherwise.

  • I have been testing things, and it appears to work fine, unless ANY item goes into the Additive slot. It immediately crashes. I tried putting redstone in additive, then iron ore into main. It crashed as soon as I put the iron in. I tried putting gold ore into main, (started macerating) then dirt into additive. It crashed as soon as dirt went in.


    Please fix this bug... I hope this info helps

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker