[IC2 Exp][1.7.10] Advanced Machines 1.1.6

  • It did.


    Version 1.0.3
    - fixed crash in additive macerator slot

    With this new version, I tried throwing all kinds of stuff in there, and no crash. I tried doing an actual additive "recipe" (coal + water bucket additive), and it functioned as normal. Looking great!

  • Yeah, it's there. I believe the reason it's not on the first page of this thread is because these recent versions are not completely tested, and thus "experimental", and prone to bugs. After the last update to it (Ver 1.0.3), however, I haven't had any problems with any of these machines whatsoever.


    A little tip before using: If you are currently using an older non-experimental version of this same mod, be sure to back up your save first. I had funny things happen with my existing rotary macerator where it's transformer and overclocker upgrades got moved to incorrect slots in the machine, which could potentially be a problem as you might imagine.

  • Thanks AtomicStryker for the quick fix!
    I used all my diamonds on energy crystals, so energy crystals for you! :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal: :Energy Crystal:

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • So, I have ratted out another bug...
    crash log


    It crashes server (couldn't remake bug in SSP) when the macerator is like this:

    Notice how the output is in bottom slot. It crashed the server when it finished macerating, which should have added another bronze dust to the top/bottom. In ssp, instead of crashing, it simply stopped the macerator, after adding the bronze dust to the top slot.


    I guess I have reported 2 bugs now... With detailed info... Does that make me your official tester? 8)

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Thanks for the quick fix!

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Some textures to match the experimental builds would be quite nice. Nothing like a good 32x texture :)

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Also, something I noticed about the rotary macerator... If you look at the last image I posted, you will see that the progress-overlay is about 4 pixels (to the right) off from it's background.

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Chock one up for the bugs... I've found yet another!
    Happened when I tried putting copper and tin ore in to make bronze dust. Not sure what caused it specifically.


    Bug


    It also said "tileentity" at the end of the report if that helps. We are going to have this mod bug-free!! Yipee!


    Btw. Does this make me the exterminator?

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • Version 1.0.5
    - fixed yet another crash in additive macerator slot


    And no, you are the bug charmer at most, causing them to crawl from their holes. I am both Creator and Exterminator of those bugs. That makes me the Bug God.

  • I think I found a new signature for myself...
    *borrows quote*

    "And no, you are the bug charmer at most, causing them to crawl from
    their holes. I am both Creator and Exterminator of those bugs. That
    makes me the Bug God." - AtomicStryker

  • hm, noticed the advanced machines got a fair bit slower from the last version we where using. Not as much of a big deal, but when you insert overclocker upgrades the devices do not speed up like they should. I assume this is a bug, and not intentional?


    Edit: looks like it does speed up, the RPM's don't increase.