[IC2 Exp][1.6.4][V1.118] Advanced Power Management V1.2.85-IC2_1.118

  • Okay... I saw this mod a while ago, but didn't see myself using it. However, I've just looked at it again and seen the adjustable transformer, and realized that that block will probably be one of the most useful blocks I've ever used. Holy hell man, that thing is AWESOME.

  • Really nice mod! Is there any ETA for 1.6.2 compatibility?


    Err... well, that depends on when there's a 1.6.2 compatible version of IC2. As far as I can tell, the first compiled version available that seems to be 1.6.2 compatible is build 400 (http://ic2api.player.to:8080/job/IC2_lf/400/), which also happens to be the latest build and was created yesterday. The stability of it is uncertain. We don't like to jump right into updates in case the IC2 API gets changed or there are bugs in IC2 itself.


    Also, like most mod devs, it'll be done when it's done. We are aware there's been a Minecraft update and have been watching MCP, FML, Forge and IC2 for updates.

  • Hi all,


    Me and a friend are using this mod on our server, and its been working fine for the past few days. The only item we have currently is a Storage Monitor. Today, we both locked up at the same time and are receiving the same crash report.



    Any idea if there's a fix available for this?


    Thanks in advance.

  • I know that Bug. Happens with almost every Mod, as soon as an ItemStack with Wildcard Damage Value gets rendered it will crash, due to not making any Range checks in the Arrays.


    But the Wildcard Damage got changed from -1 to 32767, so that other Mod which is causing the Stack, is also problematic.

  • I know that Bug. Happens with almost every Mod, as soon as an ItemStack with Wildcard Damage Value gets rendered it will crash, due to not making any Range checks in the Arrays.


    But the Wildcard Damage got changed from -1 to 32767, so that other Mod which is causing the Stack, is also problematic.


    I haven't seen that error before.


    I need the entire ForgeModLoader-client-0.log file (put it on pastebin, attach here, whatever works) in order to troubleshoot the issue.



    Thanks for replying. Heres the attachment.



    Edit: Greg, can i just say what an awesome mod you have created. GregTech adds so much more fun into modded minecraft for me. Since the early days of playing just with IC2 + buildcraft i craved for something more "Industrial" and your mod certainly added that aspect for me. Also, please dont kill me when you see what im using to launch my mod pack.

  • Also, please dont kill me when you see what im using to launch my mod pack.

    Does it start with T? Because if it does, I used that too before I found Multi MC ^^

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • Quote

    Does it start with T? Because if it does, I used that too before I found Multi MC


    Lol yes it does. Ill have to look into Multi MC, i keep hearing about it but ive never used it.

  • Hello, my name is Brian.
    I am making a mod-pack on technic launcher for myself and some friends. We would like permission to publish a pack with your mod in it. The mod-packs name will be Razors's Abomination. Currently, I have the modpack list that i would like to publish when I have permission from all developers here:


    http://www.technicpack.net/mod…azorss-abomination.164740


    Please let me know your thoughts, and give me something to quote in my page if you approve.


    Thanks,


    -Brian

    The post was edited 2 times, last by Razorskills: Better Message ().

  • Thanks for replying. Heres the attachment.



    Edit: Greg, can i just say what an awesome mod you have created. GregTech adds so much more fun into modded minecraft for me. Since the early days of playing just with IC2 + buildcraft i craved for something more "Industrial" and your mod certainly added that aspect for me. Also, please dont kill me when you see what im using to launch my mod pack.


    Tallinu and I have gone over our code line by line and can't see how this is our issue. The error is likely being caused upstream of our mod by something else. I don't really know what else to tell you on this issue. I would check with Galacticraft first as the issue starts right after it fails a packet.



    Please see https://github.com/pantheis/Ad…rManagement/wiki/Modpacks for information about modpacks.

  • I have a Question, what happens at Line 187 of com.kaijin.AdvPowerMan.BlockAdvPwrMan. I guess you access an Array, right? That is actually the Error. You must check the boundaries of the Array, before accessing it!


    Items can have all kinds of damage values, like -1 for Wildcard in 1.4.7 and earlier, or 32767 for Wildcard in 1.5 and later. If such an ItemStack somehow exists, like for example in a GUI, or if such Stack is spawned in the World it will cause that exact Error, when the Game tries to render it. If the Array Index is out of Bounds you should default to the Item, which has the damage value of 0.

  • I have a Question, what happens at Line 187 of com.kaijin.AdvPowerMan.BlockAdvPwrMan. I guess you access an Array, right? That is actually the Error. You must check the boundaries of the Array, before accessing it!


    Items can have all kinds of damage values, like -1 for Wildcard in 1.4.7 and earlier, or 32767 for Wildcard in 1.5 and later. If such an ItemStack somehow exists, like for example in a GUI, or if such Stack is spawned in the World it will cause that exact Error, when the Game tries to render it. If the Array Index is out of Bounds you should default to the Item, which has the damage value of 0.


    The code at line 187
    https://github.com/pantheis/Ad…/BlockAdvPwrMan.java#L187


    This is not handling items at all. This is handling picking which texture to use on the side of our block in the world. It is picking that texture out of an array and it isn't possible for our code to be returning anything out of array size. One index into the array is a 0 or 1 value, and can't be anything else, and the other index into the array is a value between 0 and 12 (https://github.com/pantheis/Ad…EStorageMonitor.java#L307 and https://github.com/pantheis/Ad…EStorageMonitor.java#L263)


    And that fits within the array defined here
    https://github.com/pantheis/Ad…n/BlockAdvPwrMan.java#L95


    We've gone over this code multiple times trying to figure out how an array index out of bounds error could possibly exist in this section and it just can't. Nobody else has reported this issue, we can't duplicate it and the code can't provide for an out of bounds index, and since this isn't handling rendering of in-game items in the world or in a player inventory, it can't be what you're talking about at all.


    I appreciate you trying to help with this issue, but I think you're off the mark on this one.

  • Found it. Even though it is really not an Error of yours, I know where the negative Value comes from.


    It seems that some other Mod sends out a Packet, which somehow gets into your receiveDescriptionData Function, and then causes Problems with it's random Data.

  • Found it. Even though it is really not an Error of yours, I know where the negative Value comes from.


    It seems that some other Mod sends out a Packet, which somehow gets into your receiveDescriptionData Function, and then causes Problems with it's random Data.


    The question then becomes, how could another mod's packets be getting sent on our mod's packet channel, "kaijinAdvPwrMan"? And for the block coordinates where one of our mod's blocks happens to be placed?

  • If that's what is causing the problem, it means Forge isn't handing off packets correctly and this is actually a Forge bug, or a bug caused by some other mod misbehaving horribly.


    We register the packet channel name 'kaijinAdvPwrMan'. It is very unlikely this is a channel name conflict.


    If possible it might be interesting to see the ForgeModLoader-Server-#.log file showing where the clients are being disconnected. That might shed more light on the issue.

  • The question then becomes, how could another mod's packets be getting sent on our mod's packet channel, "kaijinAdvPwrMan"? And for the block coordinates where one of our mod's blocks happens to be placed?

    I can only explain the Coords thing, as the Coords can happen due to TileEntities not invalidating properly (happened sometimes with Universal Electricity Mods), but that it gets into your Channel is very unlikely. I forgot about the Channel ID's. I apologize for bothering you, as I made a mistake, while trying to fix a Problem.

  • I can only explain the Coords thing, as the Coords can happen due to TileEntities not invalidating properly (happened sometimes with Universal Electricity Mods), but that it gets into your Channel is very unlikely. I forgot about the Channel ID's. I apologize for bothering you, as I made a mistake, while trying to fix a Problem.


    You're not bothering me at least. I appreciate you trying to help fix an issue that somebody was having. I still am curious as to HOW it's happening though, even though it seems it isn't in our code.