[MC 1.4.6] Open Beta v1.112

  • I don't quite get this: 112.170 is the beta version? What is 1.112.187-lf Wliu posted? Is it better? What is the difference? Where can I find the download?

  • read posts in this thread, link posted multiple times.


    187 192 and soo on are dev builds, you shoud install them only if you know what are you doing.

    Unsafe.putObject(42,Unsafe.staticFieldOffset(42.getDeclaredFields()[42]),43);

  • read posts in this thread, link posted multiple times.


    187 192 and soo on are dev builds, you shoud install them only if you know what are you doing.


    Ok, thanks for the explanation!

  • for everyone "too smart" 146 and 147 are compatable versions, 147 called 147 for no reason, it does not change anything expect dispencer class.

    Unsafe.putObject(42,Unsafe.staticFieldOffset(42.getDeclaredFields()[42]),43);

  • The only problems I'm having, is my log getting spammed with EnergyNet warnings. It would be nice to get that fixed.


    Update to the latest version, you are like the fifth person to say that in this thread alone.

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l


  • Excuse me. It does.

    Ok, then, why do I get this error report?
    Minecraft: 1.4.7 official
    IC2: industrialcraft-2_1.112.170-lf.jar
    Forge: 6.6.0.497


    Specific error

  • Ok, thanks, I'll try to download the latest LWJGL and see if that works.



    Edit: Nope, still didn't work, and I downloaded the LWJGL jars from the official site,too.

  • Hm, okay, I wasn't sure, that's why I said "looks like". Maybe something else is misdownloaded or poorly installed? The error you're getting is Java complaining that one of the files it's trying to load up and use has been tampered with in some way -- might even be as simple as forgetting to delete META-INF from the minecraft.jar, to be honest -- I don't remember what error message you get when that happens.


    Either way, there are several of us who have IC2 1.112 (both official beta and dev builds) running on Minecraft 1.4.7, so there's nothing broken there. Report back if you get it working, and good luck!

  • Hm, okay, I wasn't sure, that's why I said "looks like". Maybe something else is misdownloaded or poorly installed? The error you're getting is Java complaining that one of the files it's trying to load up and use has been tampered with in some way -- might even be as simple as forgetting to delete META-INF from the minecraft.jar, to be honest -- I don't remember what error message you get when that happens.


    Either way, there are several of us who have IC2 1.112 (both official beta and dev builds) running on Minecraft 1.4.7, so there's nothing broken there. Report back if you get it working, and good luck!

    Oh, a little extra info: I'm running it on MultiMC.


    Edit: Daaaamn, finally got it to work, had to put it in the mods folder to make it work. Jeez, must hate being stuffed into the jar.

  • IndustrialCraft2 works with Minecraft 1.4.7??Please help me!! When I instal the mod my minecrfat have a crash.... ;( MinecraftCreeper

  • Update to the latest version, you are like the fifth person to say that in this thread alone.

    Well, I'm running IC2 v1.112.-170-lf. Is there a newer version or dev version I don't know about? This one seems to be a month old already.

    And I'm talking about EnergyNet warnings, which I didn't notice anyone else talking about. Forgive me for having a life, and not sitting in forums 24/7 to know how often a problem is mentioned. :P

  • Oh, a little extra info: I'm running it on MultiMC.


    Edit: Daaaamn, finally got it to work, had to put it in the mods folder to make it work. Jeez, must hate being stuffed into the jar.


    Why are you stuffing a mods folder mod into the jar? Why? This is just wrong. Mods folder mods in mods, coremods in coremods, only jar mods in the jar.

  • Why are you stuffing a mods folder mod into the jar? Why? This is just wrong. Mods folder mods in mods, coremods in coremods, only jar mods in the jar.

    To amplify this, the only jar mods you're likely to be using are Forge and Optifine (and they go in the jar in that order). Everything else should be left to the Forge Mod Loader to load out of coremods and mods.


  • The way you made this message is so confusing that I can barely read it. But yes, there is a new version LIKE I LINKED YOU TO. And there's a nice little page button at the bottom-left of the page SO YOU CAN READ OLD POSTS.

    IndustrialCraft2 works with Minecraft 1.4.7??Please help me!! When I instal the mod my minecrfat have a crash.... ;( MinecraftCreeper


    It might help if you post a crash report...*hint hint*