[AddOn v1.90] Charging Bench v1.90-1

  • I haven't had any time to really play around with this add-on, but it seems cool. My Mk. 2 bench seems to charge a mining laser slower than my MFE, but that might be because its power line is split three ways. But I recently had a random thought: A Lapotron Crystal can store 1,000,000 EU, and a MK 3 bench can charge & discharge 12 Lapotron crystals, meaning that a single MK 3 bench can store 20% more power than an MFSU :P. This is a bit funny & perverse, but probably not OP -- compared to an MFSU, to get 10 million EU storage 4 more diamonds have to be crafted into Lapotrons and an extra advanced circuit is used.

  • When ever I try to install charging bench 1.64-1 i get this error.
    I have tried changing the ids and the gui id nothing seems to work.


    Link to the error log since its 3061 characters over the limit..
    http://pastebin.com/HCWrM7bk


    Looks like you might be having the same problem as Surma a little ways back in the thread - Charging Bench is loading before IC2. In Windows, you probably just need to make sure that the Charging Bench zip file comes after IC2's jar file alphabetically. If you're in Linux, I've done a little digging, and I think mods will load from some file systems in the order they were originally written to the disk rather than alphabetically. In those cases, deleting and creating a new copy of Charging Bench will probably bump its load order to the end.

  • Looks like you might be having the same problem as Surma a little ways back in the thread - Charging Bench is loading before IC2. In Windows, you probably just need to make sure that the Charging Bench zip file comes after IC2's jar file alphabetically. If you're in Linux, I've done a little digging, and I think mods will load from some file systems in the order they were originally written to the disk rather than alphabetically. In those cases, deleting and creating a new copy of Charging Bench will probably bump its load order to the end.

    Hmm still didn't seem to fix the issue. I am on linux and I have tried re-downloading the mod and re zipping it my self sadly no fix. :(

  • ...
    Hmm still didn't seem to fix the issue. I am on linux and I have tried re-downloading the mod and re zipping it my self sadly no fix. :(


    Damn. Might depend on the file system too, I think reiserfs uses some kind of balanced tree, and returns things in a completely arbitrary order. As a last ditch effort, I think you can solve the issue by merging Charging Bench into the IC2 jar. (*fingers crossed*) Not the ideal solution, but it should work.

  • Damn. Might depend on the file system too, I think reiserfs uses some kind of balanced tree, and returns things in a completely arbitrary order. As a last ditch effort, I think you can solve the issue by merging Charging Bench into the IC2 jar. (*fingers crossed*) Not the ideal solution, but it should work.

    Well that seemed to work no error on start up and items didn't crash server when made, thanks for the help +1 Internets for you :D

  • Well that seemed to work no error on start up and items didn't crash server when made, thanks for the help +1 Internets for you :D


    Whew, glad to hear it. I'll probably be trying to remove the direct references to non-API classes next time I go to make upgrades to the code (beyond updating to a new version) so this kind of thing doesn't happen, it's a real pain to fix on some systems.

  • Awesome mod but it sucks that it doesn't accept power directly from an MFS Unit =/


    Also I had mine sitting on top of a MV to LV transformer and it just exploded :o


    EDIT: oh no it was a HV to MV transformer lol. My bad. Guess they do take energy from cables lol.

  • Were you using a Mk3 bench? That should've happily accepted HV from an MFSU.

    Yeah it works fine now, I was just being a spaz and thinking it was the mod lol. Epic mod dude, I can't believe this isn't in the game yet! :D

  • Crashes on IC² 1.70


    Because the crash happens directly after loading Advanced Machines I first thought its that one.
    But after deleting AdvMach the error persisted and I took a closer look, I highlighted the line stating its Charging Bench.



  • We need a new version of Changing Bench for IC2 1.70b, only mod that need to update the server to IC2 1.7.

  • I had the same issue and the same error. Looks like the other IC2 add-ons I was using (BC-IC Crossover and Advanced Machines - with Pwnedgod's fix) are working fine with 1.70