[Addon 1.112] BuildCraft-IndustrialCraft Crossover Mod v2.0[SSP/SMP]

  • Can you support BC 3.x - When teleport pipes/logistics pipes update to 3.1.2, i dumped my world, and started over.. problem is, I would love to use this mod too, but i can't :(

    20kb for a signature? who has pictures that small??

  • they are for me... so i dunno what is going on... maybe you just missed them.

    Doubt it.


    Maybe it is some sort of ID conflict... Can someone give me the line from the config file for the engines? Maybe if I just paste it in, it'll pick 'em up.

  • Happens when I install this addon, Reverts to normal upon removal, there are no errors however, which is what's throwing me off a bit


    screenshot attached


    Hmmm, creative isn't really supported... but I dunno why it would do that. Looks like something else might be trying to use that block ID. Try changed the block ID for the generator and see if that does anything. If not I might look it sometime for the next version, but it is a low priority.


    Edit: I've looked at it, I think I know what is wrong, if I am right it isn't a difficult fix and will be fixed in the next release.

  • Read the change log, the IB version doesn't use a block ID for the engines, thus it cannot be a conflict.

    Hmmm... That's disappointing. I think I might've just mucked up the download for it then.

  • Hmmm... That's disappointing. I think I might've just mucked up the download for it then.


    If you have BC engines you should have mine. Do you have BC engines?


    Edit: Could possible be another mod conflicting with this. Try removing all other mods but this, NEI, IC2, and BC then see try it out on a test work and see if you have any issues then, if so then we can try to narrow down the conflict.

  • Okay, I double checked the engines and I figure it must be a conflicting mod. A few things:


    1) The Combustion Engine's name was replaced with the name of the large engine, but the GUI says the combustion engine
    2) Due to this change, said engine (large engine) can not be crafted.


    I tested this late last night, will edit with any additional information.


    Could my changing the ID for BC's engines be the culprit?

  • You know what you should add for sure? A way to refuel the IC jetpack using buildcraft fuel. I am thinking 1 tank of fuel to fill the jetpack, or two tanks if that is too overpowered. Maybe an item that you click on the tanks with, which empties them and fills the jetpack? I just hate the lossy way of fueling a jetpack in IC, where you must sacrifice tons of tin. And the electric jetpack doesn't cut it above like height 80. So this would be greatly appreciated.


  • Something is interfering with the way the engines are loaded. Either something is overwriting the BC files, are they are not being properly overwritten by the ones I provided. Again check other mods. This has absolutely nothing to do with block IDs. Follow the instructions I posted earlier and see what that does.

  • You know what you should add for sure? A way to refuel the IC jetpack using buildcraft fuel. I am thinking 1 tank of fuel to fill the jetpack, or two tanks if that is too overpowered. Maybe an item that you click on the tanks with, which empties them and fills the jetpack? I just hate the lossy way of fueling a jetpack in IC, where you must sacrifice tons of tin. And the electric jetpack doesn't cut it above like height 80. So this would be greatly appreciated.


    I'll think about it.

  • Has anyone had any errors loading Crossover for a server? Every time I try to start my server with it it fails to find some class or another.


    Everything is up to date, and I re-downloaded twice in case I had corrupt copies.


    Attached is an example of the kind of error logs I am getting.


    Any suggestions?


  • Don't rename the zip file, BC needs to load first, you made it so that didn't happen.

  • Something is interfering with the way the engines are loaded. Either something is overwriting the BC files, are they are not being properly overwritten by the ones I provided. Again check other mods. This has absolutely nothing to do with block IDs. Follow the instructions I posted earlier and see what that does.

    Okay, I installed JUST IC2, BC and their prereqs, then I dumped Crossover into the mods folder. Same thing: combustion engine GUI, Industrial Engine name.


    Oh, I renamed the zip so it would load after IC and BC. If that helps.


    Edit: The other mods I installed are: NEI, Treecapitator, Optifine, and ScrollControls. Though I doubt it's them interfering with this addon.

  • I too am having the same issue with the Large electric engine.
    I have no issue crafting the Small electric engine nor the Industrial Electric Engine though
    I’m running BC 3.1.2 and IC 1.64


    EDIT: I also get a Saving chunks error when i tried to power a filler with a small electric engine.

  • Okay, I installed JUST IC2, BC and their prereqs, then I dumped Crossover into the mods folder. Same thing: combustion engine GUI, Industrial Engine name.


    Oh, I renamed the zip so it would load after IC and BC. If that helps.


    Edit: The other mods I installed are: NEI, Treecapitator, Optifine, and ScrollControls. Though I doubt it's them interfering with this addon.


    No, no, no. Don't rename the mod at all. It must load first for clients, last for servers. Modloader and ModloaderMP do things in the opposite way.


    And post your modloader.txt

  • It happened when they all had the original names too though .. that was just my latest attempt at loading that I uploaded


    Make sure you used the correct name for the zip "zBCIC2crossover server v1.18.zip" note the z.


    If that doesn't work, then make all the names the original. (Backup the save) Then try running the server with just IC2 and BC. if that works then add my mod and see what it does.


    An explanation, the class it is looking for is in the buildcraft core zip. It just has to load that first. Also what OS are you using?