[IC2 Exp][1.7.10] Advanced Machines 1.1.6

  • Your crash happens because the Tile Entity was saved with a different NBT dataset than the one you are attempting to load it with
    More to the point, your save file is prior to the Short overflow bugfix, and the one you tried to load was after. Yes, they are incompatible. Sorry.
    I'm pushing a fix to that particular issue.



    I welcome immibis offering an actual rewrite of this mod. The (just recently fixed) ghost TileEntity bug, and basically every single other bug i have fixed, were pretty much all stuff i missed when fixing Zippinuis source up. It should have had a clean re-code, given the code state. But i didn't want to put in the considerable effort. Just making it work was hard enough back then.

  • There is a graphic bug,which doesn't crash the game.But it looks quite weird.
    That is,the progess bar doesn't display porperly.

    Detail:
    MC1.5.2,Advanced machine4.9,IC2_lf329,Optifine_1.5.2_D3,forge710,gregtech,mfr and a lot of other mods.
    As you see,machine is doing nothing,but the progess bar tells me the machine is progessing...something.It's really weird and confusing.



    EDIT:All right,I figure out the problem.(don't ask me how!)the problem is in these lines of codes.your machine's progress bar scale incorrectly.The reason is simple,progress bar only scale when the Gui is opened,in order to save CPU power.when closed,it will save the current place of the progress bar and stop update it.When the jobs are done,the progess value goes back to 0.When you open the Gui,MC reload the progress bar's place from the saved one in the RAM,without judging wthether it is correct(that's because your code!) .That's my explanation,maybe incorrect.
    I borrowed some lines of code from UnixRano(don't tell him!)which is showed below.


  • I have a slighty problem with adv machines im trying to connect them to buildcraft pipe system, but when i use wooden transport pipe to extract items from rotary macerator, all items are extracted not only product (to what ever side i connect pipe) what is wrong with it ?

  • Got that error when i connect pipe to rotary macerator now ...

  • Hey, I can't put items into your machines using hoppers or applied energistics. I tried putting a vanilla hopper on top of the machine and it wouldn't deposit items into the machine.

  • Forgive me for asking but I have not seen this answered yet, will your Advanced Machines be updated so the bottom side is the output?


    I am currently running a locally modified version with that change implemented (thanks for providing the source code), but I don't want to be using a forked version and have to worry about updates.

  • Forgive me for asking but I have not seen this answered yet, will your Advanced Machines be updated so the bottom side is the output?


    I am currently running a locally modified version with that change implemented (thanks for providing the source code), but I don't want to be using a forked version and have to worry about updates.

    Use UUM Advanced Machines , from immibis.

  • Hello Stryker. I gotta say I love what you did with your version of advanced machines, but I encountered an issue with one of the machines while establishing a network with Applied Energistics mod. The problem involves the rotary macerator.


    I don't know if you're aware of what Applied Energistics does, but I'll keep the explanation simple. When you place its interface block on top of, say, one of your machines, that machine is now part of the network and will contribute towards virtually automated crafting. In the interface, you can place encoded patterns inside which allows the interface to program whatever its attached to. For this scenario, if you put a pattern thats essentially designed to turn cobblestone into sand into the interface attached to macerator, you can request cobblestone to be macerated into sand whenever needed so long as cobblestone is in the network via storage.


    Long story short: Your rotary macerator has a hard time working with AE's interface block, as in not at all. The interface works with the furnace and compressor, but the other machine is a no-go. The only alternative solution I can do is use basic macerator, but I have to apply a number of overclockers and energy storage upgrades to be comparably close to rotary macerator, which eats more EU as a result.


    Just wanted to pass that along.


    EDIT:
    Wanted to confirm, but rotary macerator and singularity compressor both don't work with AE's interface blocks.


    EDIT 2:
    A better fix is connecting a buildcraft hopper to macerator/compressor then attach interface to chute. Still a little inconvenient. :P

  • The Buildcraft Hopper is worse in every single aspect, compared to the vanilla Hopper. It has one slot less, It can only move Items downwards, It doesnt respond to redstone Signals, Its not Comparator compatible, It doesnt work on vanilla ISidedInventory and it looks ugly with these Diagonal Parts of the Model (Y U NO MORE LIKE CUBE).

  • Just wanted to let you know, it seems advanced machines aren't currently compatible with the new Ejector Upgrade. Items aren't ejecting.


    The Buildcraft Hopper is worse in every single aspect, compared to the vanilla Hopper. It has one slot less, It can only move Items downwards, It doesnt respond to redstone Signals, Its not Comparator compatible, It doesnt work on vanilla ISidedInventory and it looks ugly with these Diagonal Parts of the Model (Y U NO MORE LIKE CUBE).


    Well, the Buildcraft Chute (recently renamed) is a lot faster than a Vanilla hopper, and is currently more compatible with other mods through sheer inertia. But I do agree; I've turned off Chutes in my server.