[1.3.2] Open Beta v1.107

  • Did solar get broken? I updated to 1.107.35 and they will not craft.

    Are you using GregTechs-Addon Mod? He changed the recipe for the solars but you can change it within the config file.

    Otherwise, no the recipe has not changed, i can craft solars without any problems with 1.107.35.lf

    Edit: Is IC² using the ore dictionary properly? Because i noticed that the wood from extrabiomesxl, which is registered via ore dictionary, cannot be used for IC² recipes.

  • How is the EBXL wood registered? I have contact with Scott but he's AFK right now.

    dang new keyboard, keep hitting ctrl-P ctrl-S and all kinds of stuff

    I'm just beta tester for scott, not involved into programming. So he can answer that to you ;)

  • Quantum leggings sprint automatically turns on when you sprint. CTRL key does nothing. It's probably a feature, but it would be nice to have config on that thing.

  • Don't know if this is just a bug in the gravisuit mod, or 1.107, so figured I would report it.

    World Gen: Flat World, Hard mode, Survival Mode.

    Items Spawned in that was used at time of crash: One Nuke, One Lever, Bucket of Milk, Quantum Leggings, GraviHelmet, and GraviChestPlate

    Situation: I placed and used a lever to set off a nuke on the map, cheking out the gravisuit stuff. Nuke detonated just fine, got poisoned just fine. Pulled in a bucket of milk via NEI, flew above the nuke using gravisuit to fly. I drank the milk, animationed started, and Minecraft crashed. I do use MultiMC.


    Able to replicate: Yes for a total of three times, with the same exact crash log.

  • I noticed that I can't macerate non-IC2 ore Dictionary ores anymore. I tried with what seems like 5 types of tin, and only one worked in a IC2 Macerater. I didn't test if I could use Forge Ore Dictionary Metals for IC2 recipes which use them, but I will try again. (I do at least know that I can use UE's Atomic Science Refined Uranium to make IC2 Uranium Cells, both normal and Depleted, which is nice, as it means I can use IC2 Uranium Ore in my UE Atomic Science Nuclear Reactor that I'm working on in a Mystcraft Void Age)

    Apprentice Redstoner, Professional Slacker

    • Official Post

    We use 107.35 on the server and I can macerate the RedPower ores I mine just fine.

    I did fix the inability to make DCP from ore dictionary copper though.

    Does Redpower load before or after IC²? I dont know if its using PreInit (like you) to initialize Items, what i doubt, as its a very bad Idea to register Ores in PreInit. And if i force Forestry to load before IC², then i cant macerate its Ores! Fix your damn wrong and massively outdated Oredictionaryusage. The Oreregisterevent is not getting called with all preregistered Ores anymore, when registering the Oredicthandler aka IC2.class.

    And dont say that SirSengir shouldnt register his Ores in PreInit. You do that failure yourself too.

  • I just registered to say thanks for the update! I've been using it since release and the only bug I can find is the rubber boots. The rubber boots stopped taking damage and now I am invincable to mobs.

    Many thanks for the hard work put into this mod.


  • Some warning appear in the log of magic launcher ( [IC2] Submodule not loaded: java.lang.ClassNotFoundException: )

    forge and industrialcraft-2_1.107.35-lf

    log by magic launcher

    Full log pastebin