[GregTech-5][1.7.10-FORGE-1355+][Unofficial but approved Port][Stable] Even GT5 Experimental is slowly getting stable.

  • You can at least put cactus directly onto crop sticks, so if you manage to find a desert and get some natural cactus the eating plant isn't too much of an issue to get. If you can't find cactus then you are certainly right about it being more of a pain to breed for.


    The later versions do also have a command to allow giving you a cropcard of any crop with any stats you want, but that was never backported to 1.7 from the looks of things

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • NEI says that there is no such seedbag as cactus, sorry for make a confuse, maybe I've mistaken it with some other IC2 build.


    On other hand if you're not going to invest in selection later in game then there's no point in this water gain method, building a pipe for even 300 blocks is way easier than that. Another interesting (but also unpromising) way is to solid down water to snow for dry transportation and liquifying it on other end. Anyway filling up GT large fluid cells is still easier and more efficient.

  • In the version of IC2 I’m playing - the 1.7.10 version, since that’s what GT5U requires - you can’t place natural cactus on crop sticks. I tried.


    I’ve got plenty of natural cactus.


    —-


    I hadn’t seriously considered shipping fluid cells instead of using the liquid tanker. The tank car from Railcraft is typical capacity for a tank, 32 buckets for one tank. A single stack of fluid cells is 64 buckets, and a chest carries 27 stacks. It should be easy to supply enough drilling fluid via train, I’d think a couple of stacks should be enough. I’ve got a stack of steel cells (16 x 16 = 256 buckets), but I don’t know that I need them for this.


    By default Railcraft prohibits carrying fluid containers in chest carts, since the capacity is almost always much higher than the tanker carts. I’m not sure if it detects IC2 fluid cells or not, since I haven’t tried. I believe it’s something you can turn off.


    I think I’ll look into this. There are some headaches involved, mainly there’s no way to distinguish between chest carts carrying ore and chest carts carrying fluid cells, but I think it’s manageable and it’s far less work than laying out a pipe that runs about 6 chunks away (96 blocks) to the nearest plains biome.

  • I found tungsten. Or rather, I found the vague vicinity of tungsten.


    I misplaced my seismic prospector - I found out the next day I’d stuffed it in my ore bin by accident - so I built an Advanced seismic prospector, which is EV tech rather than LV. At first it looked like a pretty amazing upgrade, since it surveys as 12 x 12 chunk area, which is 25 potential ore veins at once if you do it right. 25x the prospecting speed, for only 8x the industrial TNT. You still have to cover almost as much ground, but it’s still a lot faster.


    Except that it turns out, the report gives you only that the mineral is somewhere in the 12x12 chunk area. The oilfield report gives you a simple map, but the ore report doesn’t. Ores are categorized by “near” (< 32 tiles) “medium” (33-64 tiles) and “far” (64-95 tiles). No direction, and even the “near” report is vague, since it summarizes a 4x4 chunk area, and the most-common ore can actually be spillover from a nearby chunk if the center chunk has no vein of its own.


    Thus, because one report showed tungsten in the “far” ores, I know it’s one of 16 locations in a ring around the test site, but not which one. I’ll have to test each of those locations with the basic prospector.


    The Advanced prospector is still a great tool if you’re looking for something specific, want to cover a lot of ground, and get a hint as to where you should look. In my first trip, I surveyed 170-ish vein locations, more locations than all of my trips with the basic prospector to combined. What the advanced prospector doesn’t do is give you a precise location, you need the basic one or mine shafts for that.

  • On a completely unrelated note, my oil distillery stalled, and I’m really not clear on what to do about it. The distillation tower always has this possibility, because it has multiple outputs. I’ve set my crude oil distillation to stop if any of 4 output hatches gets full.


    What’s specifically happening is that I ran out of toluene, because I’m using it for Industrial TNT for my survey trips. My refining setup makes toluene from heavy fuel and naphtha. If the light fuel or refinery gas tanks get full, the distillation tower stops, and I don’t get any more toluene.


    Initially it was the refinery gas. That gets converted to LPG, so I added a 128v gas turbine feeding into the battery that normally gets only power from the steam turbines. Initially I was only burning LPG if the steam power couldn’t meet demand over an extended period. Now I’m burning it all the time, and the LPG tank is still nearly 100% full.


    Now it’s the light fuel, which gets converted to cetane diesel. Diesel powers the remote sites, acts as an alternate power source for the blast furnaces, and powers the main grid if steam power can’t keep the primary 2kV battery buffer above 50%.


    I could add additional light fuel or diesel storage, and maybe additional toluene storage so that I have larger reserves. More storage usually doesn’t solve rate matching problems, but it’s possible I won’t use much toluene for a while. After all, I only used so much because I was looking for tungsten, and I kinda-sorta found that.


    I could add logic to convert light fuel to toluene, but only if toluene is very low and light fuel is full. I think that’s a possible conversion, there are so many petroleum conversions I lose track. There’s already logic to convert excess toluene to light fuel, since the normal flow is Oil -> heavy fuel, light fuel, naphtha, refinery gas, heavy fuel + naptha -> toluene, toluene -> light fuel, light fuel -> cetane diesel.

  • Soon there will be no such problem as excess LPG for you, tungsten sintering and alloying are those full-time HV/EV processes I mentioned before and you're going to need it much from now on


  • I've been having some issues with oil distilling too, I've rebuilt the whole setup a couple of times and just ended up burning almost all of the products and "voiding" the energy making cobblestone because the storage would just keep getting full and blocking everything. With so many different outputs it's impossible to keep things balanced.


    Also, looking at the recipe for the fusion reactor controller, I regret switching my 2 reactors to thorium

    since it requires *some* plutonium, unless I've missed something.

  • It's 45 plutonium in average, not so much at all. At the moment you consider building fusion reactor this is nothing compared to other requirements (without spoiling a recipe, for example: 16 stacks of chrome, 512 superconductor wires and most of all the very controller), there are long way ahead, you can just make required amount of plutonium in replicator or reactor many times.

    On the other hand is 12 stacks of lutetium that you will need eventually.


    Also I didn't agitate to switch to thorium completely, it's up to you in the end. I just promoted nuclear technology and described the benefits of using it.

  • Turns out there’s no simple light fuel -> toluene conversion. Water cracked light fuel produces heavy fuel and naphtha, and steam cracked light fuel produces heavy fuel and toluene, but there’s no direct single-block distillery recipe for light fuel -> toluene.


    For the moment, I’m going to let it slide, since I surveyed the precise location of the tungsten, and I’m not in dire need of iTNT immediately. The problem may resolve itself when I set up a heavy fuel cracking setup, or high octane gasoline synthesis. Light fuel cracking is very far down my list, particularly since it produces products I can’t use right now.


    I did a little re-wiring of my power grid, so there’s now a 2kV trunk feeding several HV branches, rather than the 2kV battery feeding almost directly into a single HV transformer which feeds the rest of the base. I was having power distribution issues. Immediately after wiring it my consumption went from 2000 EU/t (the limit of the 4 amp HV line) to 3000.


    Distilled water destruction under continuous load continues to be a problem. I may add a 3rd distillery producing water for that system, though the amount of power I’m using for that is starting to feel excessive. It’s eating most of the power increase I got for switching to large turbines.

  • It doesn't seem to have been mentioned before, but are you sure you didn't build your boiler across chunk borders? Wiki says that it can lead to steam/water loss.


    Another option is to build a small two-layer distillation tower for fast and efficient water distillation.


    After all, if dist.water/steam system doesn't work as closed one, you can go back to using regular water since it's a boiler and not an LHE.

  • Yes, I’m sure that I didn’t build my boilers across chunk boundaries. I use NEI’s F9 option to verify that before building any multiblock machine. That doesn’t fit the observed behavior anyway - if the steam was vanishing, the turbines wouldn’t run, and I wouldn’t get power.


    It’s fairly clearly a bug in boiler startup, because it behaves properly once the boilers are running. It’s consistent with the idea that the boiler eats fuel and water at 100% while heating up, but only produces a fraction of its rated steam output while heating. Overall efficiency is about 30% during heating according to the wiki.


    For a titanium boiler that means 17,000 L of water per boiler gets eaten without producing steam, each time the boiler starts. That’s roughly the loss I’ve observed, though I haven’t measured it properly in Creative yet.


    Switching back to regular water is unworkable. I built the large turbines originally primarily because boiler water consumption was a serious problem. That it increased efficiency and improved power output was secondary. Two titanium boilers eat 426 L/sec of water, and my water collection was not keeping up over the long run.


    I’ve since throttled the 2nd boiler, so they’re collectively producing 55,000 L/sec of steam instead of 64,000, or only 1000 L/sec more than the turbine consumption. This means that the net consumption of the boilers is 7 L/sec distilled water. A single 128v distillery produces 12 L/sec of distilled water, so the distilleries are easily keeping up now.


    I calculate it’s costing me about 2 million EU to replace the lost water per boiler startup. If the boilers run once while filling the 20 million EU buffer, that’s a 10% loss. Under continuous load it drops to less than 1% as the boilers run for a long time between starts.


    I haven’t looked at the cost of distilling water in a distillation tower vs. the single-block distillers. I think of distillation towers as being large and expensive, it didn’t cross my mind that a water version is only 2 blocks high. Still very expensive compared to a couple of 128v distilleries, but maybe worth doing anyway.

  • Just tested it. Well, it's actually 3 blocks high because it's minimal height for tower to form, while tecnically height determined by recipe and it must be 2 for d.water.

  • Hah, there’s a post mentioning this issue in the Support thread, and Greg acknowledges that the large boiler eats water while heating up while producing no steam. Of course, he’s almost certainly talking about GT6, not GT5U, but I wouldn’t be surprised if it’s the same overlooked issue.


    I still need to test it to verify the numbers.

  • actually my boiler doesn't eat steam while heating up, it does while cooling down. Different cause, same effect of voiding Steam to preheat the thing.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • I finally put the effort in to do a test. It helped that I already had a pre-built titanium boiler / large turbine setup in Creative.


    Running 128 charcoal through the boiler consumed 29,600 L of water. The large turbine returned 26,900 L of water. So, only 2,500 L of water destroyed during startup, far less than the 17,000 L I estimated, or the amounts I thought were being consumed each cycle in actual usage.


    A single-block distillery produces 6 L/sec distilled water at a cost of 32 EU/L. A 128v distillery produces 12L/sec for 64 EU/L. 5,000 L water destroyed per cycle by 2 boilers = 160k EU to replace at 32V, or 320k EU at 128v.


    The distillation tower produces 625 L/sec of distilled water at a cost of 3.8 EU/L at 128v. It’s 100x as fast as the LV block, which is understandable given that the material cost is around 30x as much and uses more valuable materials, and 8.3x as energy efficient.


    Interestingly enough, the distillation tower recipe destroys water, since it’s 576 L water in and 520 distilled water out, and the single-block recipe is 5L for 5L. I don’t really care, since it’s the destruction of water inside the distilled water loop that concerns me, not the original source water.


    I don’t think I’ll put in the investment. 320k EU/cycle is about a 1.5% loss, and doesn’t warrant the cost and effort of a distillation tower.

  • Gregtech sometimes has me doing some weird things. Though in fairness it’s also interaction with other mods.


    I set up a second ore drill over the tungsten vein. My first drill is still running. Both are quite distant from my base, about 300 and 600 blocks away respectively. I use a Railcraft train to bring ore back from the first drill.


    I could just divert the train to the tungsten, since the older site is fairly low priority stuff now. Instead, I decided I’d rather set up a second train, and that means Railcraft signals. A lot of them, actually.


    Railcraft signals require various dyes. I’m auto-farming red, blue, green, and black dyes right now, but now I need yellow, and Railcraft won’t take sulfur as a substitute (which many recipes that consume yellow dye will).


    Rather than go out foraging for lots of dandelions, I decided I’d tech up some dandelion IC2 crops with decent growth and yield. So I’m doing a lot of gardening right now. “I’m breeding dandelions because I want tungsten” doesn’t sound like a logical connection, but in fact it is.


    Of course there are more direct routes to the same goal, but I gravitate toward what Dwarf Fortress players call “dwarfy solutions.”

  • Finally got my signaling system up and running on my ore railroad. I’m pretty sure I got everything correct, but I haven’t built a second train yet, so I’m not 100% certain it’s safe yet.


    My experience is that it’s easy to overlook minor things. In running a single train, I discovered I hadn’t set a couple of locking tracks to “train mode,” so they immediately locked the train in place as soon as the locomotive entered the new block.


    The basic signal block logic is very simple, but the real issue is the switching point where the Tungsten train goes one way and the Lithium train goes another. That’s the point where a collision is possible if the signals aren’t right. I’m pretty sure a deadlock can’t happen, at least.


    The problem is that compared to Factorio, Railcraft’s signal support is rudimentary. Railcraft’s “signal blocks” aren’t full fledged train signals, they’re just detectors. The actual control is done by locking tracks, and anything involving track switches requires that you wire the logic yourself.


    I’m using AND gates from Project Red. Each locking track looks at 2-3 track segments, and only lets the train pass if all of them are clear. The entrance from the base can leave 2 ways (Tungsten or Lithium), and crosses track returning from Tungsten. All those need to be clear before the train can enter the intersection. A train returning from Tungsten needs to check that the Lithium train isn’t in the intersection, either coming or going.


    I also discovered that Railcraft’s electric locomotives are unsuitable for distances of 600+ blocks. The electric rails transfer power very, very slowly, and the train ran out of power well before getting to the Tungsten site.


    I went electric initially because a steam locomotive eats significant fuel and water even if stopped unless you shut it down. If you shut it down, it takes a long time to reach operating temperature when you re-start it. “Idle” mode reduces consumption, but not nearly enough, given how long the train will spend waiting for the drill to fill the train.


    Adding charcoal fueling and water loading to my train station proved to be easy, and the steam locomotive had no difficulty reaching the Tungsten site and returning without needing additional water. A one-way trip eats about 1200 L of its 6000 L tank, and 2-3 charcoal. I just adding some control tracks to shut if off while it’s waiting at the Tungsten depot, and restart it when it has a load of ore.


    From now on, any future mines or oil sites will get serviced by steam locomotives. Which seems like regression, but the steam locomotives are just more reliable for long distances.

  • I built my first multi-fluid pipe to deal with a congested pipe area.


    I’ve built multi-fluid pipes before, but only because the situation seemed to require it. The exhaust of the electric blast furnace, for example, can produce a variety of oxides, though usually it’s sulfur dioxide or carbon dioxide, and I’ve got a multi-pipe with fluid filters sorting that out. My spray paint factory also has a multi-pipe setup, but no fluid filters because the pipe leads to paint tanks, and those effectively filter the paint because the paint in the pipe can’t enter a tank with a different paint color.


    Anyway, I put a tungsten electrolysis machine in to my ore processing line, and it needed a hydrogen line, but the area below it was completely blocked off by other pipes. So I created a combined sulfuric acid / hydrogen line, and split the hydrogen line off after it went down to level B3.


    I initially set it up with 4 fluid filters, one each for where the hydrogen and sulfuric acid entered, and one each where they exited. My reasoning being that I didn’t want back-wash from the multi-pipe to contaminate the source pipes.


    Then I discovered that fluid filters are also one-way valves, prohibiting any flow from the pipe with the filter to the multi-pipe. The input pipes couldn’t have filters on them. I realized since the flow was always intended to be one-way anyway, I could just put pipe shutters on them, configured to only allow fluid to pass into the multi-pipe.


    For color coding, I painted the pipes red (for hydrogen) and put a checkerboard of bronze plates on them, coding them to be also orange for sulfuric acid. At connection points I couldn’t paint the pipes or they wouldn’t connect, so I used red alloy covers there for the red.


    The pipes were 9x plastic pipes, since that’s slightly cheaper at 9 polyethylene than 4x pipes, which are 12 polyethylene but allow higher throughput. I view the plastics as essentially free, since I make from ethanol I’m making as a side product of my tree farm. The covers I used for color coding were more expensive, adding 2 bronze to the cost of each pipe, but I’m swimming in extra copper and tin from my ore drills so I don’t care.

  • On a more Railcraft related note, I’ve got 2 ore trains running on a single line now. I discovered a few errors and oddities along the way, as I thought I might.


    The signaling works fine. I’ve had 2 trains at the station several times now, where one train is waiting for the other to finish unloading. I haven’t witnessed both approaching the switch point yet, though, and that’s the only part that isn’t dead simple, as I mentioned before.


    The charcoal loader for the steam locomotive was initially in “wait until full” mode, but that caused the locomotive to wait forever. I don’t know why. I changed it to “stop when no more items get moved,” and that worked.


    Similarly, I forgot to set the fuel and lubricant unloaders at the tungsten depot to “stop when fluid stops moving.” Instead both were in “wait until empty,” which held the train. Since the locomotive was shut down, it just mean it was waiting at the depot despite having a full load of ore.


    The electric locomotive is doing something weird. While unloading at the station, it flips direction. This happens because it’s idle, rather than pulling, and the cart behind it bumps into it when it finishes loading fuel. This has the effect of reversing the locomotive. Forunatly, when the ore finishes unloading that bumps the locomotive again, and it’s facing in the right direction when it gets pushed past the track re-starting the train.


    I don’t see any way to prevent this, it’s just a bug in the way Railcraft behaves. It’s also unpredictable, because the steam locomotive goes through the same process and yet doesn’t flip around when it gets bumped.


    The worst case scenario, should it stop flipping back, is that the train gets stuck in the station. The locking tracks for the loaders are all set to one way, so it can’t actually start backing up. Backing up would be really, really bad because the signaling system can’t handle trains going the wrong way on one-way track.

  • It appears I spoke too soon. I noticed I hadn’t seen any ore deliveries for a while, so I thought I’d go check on the trains. I found that they’d collided and destroyed the intersection between the tracks in an explosion.


    I have no idea what happened. I guess I’m going to restore some backups, find a point before the explosion. Maybe conduct some tests. I’m not clear on whether it’s a mistake on my part, or just Railcraft being buggy (which it often is).


    I’m not entirely sure how to test the intersection, beyond maybe placing a cart at various places on the tracks and seeing if the locking tracks are activating the way I planned. There’s always the possibility it was a timing issue I didn’t foresee.


    I may give up entirely on signaling and running multiple trains on one track. The costs of a failure are too high, particularly if either of the trains are carrying rare material. If trains colliding resulted in them getting stuck rather than exploding, it’d be OK, but losing the track, cargo, and both locomotives really isn’t an acceptable risk.