[IC2 Exp][1.7.10] Advanced Machines 1.1.6

  • You messed up big time.
    on the category String. You can't use custom ones cuz they're not yet supported.
    You can only use specific categories.


  • That's funny - the custom categories get autocreated just fine, but Forge cannot parse them.

    Say whatever you want, it's shitty implementation. Yeah ill fix it.


    Besides, that's not even the problem. Forge already fucks out on

    config = new Configuration(new File(Minecraft.getMinecraftDir().getPath(), "/config/IC2AdvancedMachine.cfg"));

    Which was not changed by me whatsoever

  • On the "Null Pointer Exception" thing, I can confirm that it exists in more than one place. (Though I'm sure you guys have more than your fair share of bugs going on right now.)

    AM 3.8c for Minecraft 1.2.3 on Bukkit. Here is the output from the server console when someone tries to interact with their inventory or the rotary macerator while the rotary macerator's GUI is open. I figured that since you guys bundle the source, the Bukkit port, and the client port, I should post this here:

    At first I was using CB++ via Donovan on MC Port Central, but it also happens (At least, the second half of that error message) with the most updated build of MCPC's modded server jarfile. I don't know if it's an error in AM itself or not.

    It doesn't seem to be causing any other issues, aside from disconnecting people from the server when they try to use the macerator, or their inventory while the macerator GUI is open. I have not been able to verify if it happens with the other machines.

  • Stumbles upon this on the Suggestion forums: Red Alloy Dust

    Any chance that you could add this into Addictive Macerating?

    Would anyone like to try a Slowpoke Tail?! Only 1 Million Yen!


    this isn't about arrogance or ego, I have a block that I put a lot of freaking work into

    Every Mod Author, in existence. And yet, you STILL say otherwise.

  • Could you please fix the 3.8c bukkit port please? That's all me and my friends need for our server right now and all we get is an error when trying to use.

  • I guess the errors I get when someone opens the interface of an advanced machine is normal. I am on bukkit 1.2.3 and using 3.8c. I am glad I never really use machines directly and I do everything through boxes and a pipe system. Although I have to admit that even when I get the error it rarely kicks me out of the server.


    10:51:03 πμ [SEVERE] ALERT: SERIOUS BUKKIT PORTING ERROR. net.minecraft.server.ic2.advancedmachines.ContainerRotaryMacerator is a container that does not provide a valid player and inventory to bukkit.10:51:03 πμ The mod porter needs to provide a player through getPlayer() and an IInventory through getInventory().10:51:03 πμ You may encounter issues. File a bug with this message at mcportcentral.co.za, please.10:51:03 πμ java.lang.Throwable10:51:03 πμ at net.minecraft.server.Container.transferTo(Container.java:40)10:51:03 πμ at net.minecraft.server.NetServerHandler.handleContainerClose(NetServerHandler.java:1144)10:51:03 πμ at net.minecraft.server.Packet101CloseWindow.handle(SourceFile:16)10:51:03 πμ at net.minecraft.server.NetworkManager.b(NetworkManager.java:234)10:51:03 πμ at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:118)10:51:03 πμ at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)10:51:03 πμ at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:557)10:51:03 πμ at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:455)10:51:03 πμ at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)

    This is the error I get from the macerator.

  • I seem to be getting server crashes when somebody attempts to use additive macerating. I am at work at the moment and so unable to pull the logs, but I'll edit this and post them up when I get home. I just wanted to get this up in case anyone else had experienced it.

    Never mind, I updated from Forge to and it seems to have resolved the crashing issue.

  • Damn. You are fast.

    Hmm, I wonder if I can persuade the operators of the server I play on to update from 1.0.0 now that all of the mods and their addons are released on the current MC...

    GENERATION (Pineapple + i): The first pineapple you see, copy it into your sig on any forum and add sqrt(-1) to the generation. Pineapple experiment.

  • just tried to download this mod but got this message and no download file



  • Can someone please port 4.0 to Bukkit? I've been trying for 5 hours, and the weird error messages are beyond my comprehension.
    All of the other downloads have a bukkit port, 4.0 doesn't.

    Alternatively, can someone enlighten me, how to make a bukkit port with the src?

    Ty in advance.

  • I tried the rotary macerator on 1.95b and it contiinously runs. I tried this with just IC2 1.95b and this mod installed with base mods required plus chicken bones NEI to test.

    I forgot to mention I'm using MultiMC