[1.4.2] Open Beta v1.108

  • Are you sure a IC² 1.108 for MC 1.4.2 will work in MC 1.4.4 ?

  • Are you sure a IC² 1.108 for MC 1.4.2 will work in MC 1.4.4 ?

    I think Sodaguzzler did it just for the sake of saving the IC2 team some work in isolating where one of (potentially) many problems lie in the new code base in 1.4.4. Though I find it a little odd that it would throw a ClassNotFoundException pertaining to a class file that is used by IC2 internally, but that's good old nooby me talking as I am only beginning to learn Java through modding and Forge.

  • Don't use MCPatcher, it has issues with Forge.


    Forge has built-in support for HD texture packs, without MCPatcher or Optifine

    i dont want to break the rules here though.... the 1.4.2 version of this dosent work with 1.4.4 please update ASAP *not requesting if i was it would say "PLEASE UPDATE NOW!" so hope so it will be done soon :)

  • I hope the time between 1.4.5 and 1.5 (if there won't be any other version) will be like 1.2.5 <-> 1.3. Good times.

  • Okay just got a server tick loop crash when setting up some fiber cables to a MV transformer and then after reloading the game hooked the cables up to a Mass Fabricator.


    Forge log:


    http://pastebin.com/3WyWMrzd


    Minecraft crash log:


  • Okay just got a server tick loop crash when setting up some fiber cables to a MV transformer and then after reloading the game hooked the cables up to a Mass Fabricator.

    You hit the sound bug, I get it from time to time as well, your game crashes for no explainable reason due to some error with IC2 sounds.

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l


  • may as well wait a bit longer... why? 1.4.5

    If I'm not incorrect, I think for the most part the 1.44 to 1.45 jump just requires a re-compile against the new package.. so not that much to get rollin if you have a working 1.44 version of something.. though I may be completely off course on that.

  • just forcedisable sounds via hotplug, it's not fun already, every page someone report problems related to sounds or other mods (or plain stupidity)

    Unsafe.putObject(42,Unsafe.staticFieldOffset(42.getDeclaredFields()[42]),43);

  • The 1.4.4 version will have sounds forcedisabled.


    For the love of god, why? The problem is already fixed, you just need to implement the fixes. I already have a working version of the latest 1.4.2 beta with sounds thanks to the fixes that matjam provided.

  • For the love of god, why? The problem is already fixed, you just need to implement the fixes. I already have a working version of the latest 1.4.2 beta with sounds thanks to the fixes that matjam provided.


    How do you fix it? I would like to play with sound! lol. Or could you maybe set up a download somewhere with the fix? that would be sweet.

    The post was edited 1 time, last by Vagabor ().