[MC 1.4.6] Open Beta v1.112

  • Been trying to get the build, but it seems dl.dropbox.com is down. Haven't been able to get a non-corrupt download yet. :thumbdown:


    Hope DB gets their stuff together... Really looking forward to an industrial build!


    Edit: I finally got a good download. Bloody hell. Took around nine attempts.

  • Any chance we can stop this enet spam from checking? It's so bad in my nether world now when I leave it the server stalls due to the spam lol...

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • Hi Ive been trying to connect an MFE to a rotary macerator via glass fibre but it keeps blowing up when I add power via solar panels. Where am I going wrong? (Also happens with induction furnaces). The only time it does not blow is if i go via a transformer. I thought it was supposed to be able to connect with out one?


    thanks Antony

  • Hi Ive been trying to connect an MFE to a rotary macerator via glass fibre but it keeps blowing up when I add power via solar panels. Where am I going wrong? (Also happens with induction furnaces). The only time it does not blow is if i go via a transformer. I thought it was supposed to be able to connect with out one?


    thanks Antony

    Rotary Macerators don't exist in vanilla IC².
    Anyways, the rotMacerator you are using belongs to the Advanced Machines 4.6 addon (not the Advanced Machines Original 1.6 for IC² 1.111 & MC 1.4.4/1.4.5). The machines in there have a maximum voltage tolerance of 32 EU-p, that means they will blow up from a direct connection of Multi-Functional Electricity Unit (MFE) which outputs 128 EU-p.

  • Rotary Macerators don't exist in vanilla IC².
    Anyways, the rotMacerator you are using belongs to the Advanced Machines 4.6 addon (not the Advanced Machines Original 1.6 for IC² 1.111 & MC 1.4.4/1.4.5). The machines in there have a maximum voltage tolerance of 32 EU-p, that means they will blow up from a direct connection of Multi-Functional Electricity Unit (MFE) which outputs 128 EU-p.

    Thanks. Looks like Im using the wrong addon then :( But at least I know why its blowing up.

  • Since the 1.4.6 beta I have performance issues with IC2 running mod textures. Every few seconds fps drops to Zero. Without the textures (NP oder Spax) everything runs smooth.
    No Problems in 1.4.5


    Any Ideas?


    Thx all.

  • Is there a version somewhere that fixes the machines' API calls or disables API error messages?


    Because spamming the console with "[WARNING] [IC2] API ERROR: ic2.core.block.machine.tileentity.TileEntityMacerator@7c96ade5 didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true." or similar is getting pretty ridiculous. I am getting dozens of messages per second.

  • Is there are version somewhere that fixes the machines' API calls or disables API error messages?


    Because spamming the console with "[WARNING] [IC2] API ERROR: ic2.core.block.machine.tileentity.TileEntityMacerator@7c96ade5 didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true." or similar is getting pretty ridiculous. I am getting dozens of messages per second.


    Not yet, I agree with Kane Hart, there should definitely be a config option to turn it off

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

  • Came home to a 250 megabyte forge text file of these errors... this is a need to get fixed thing, unless gregtech can run without ic2?


    2012-12-27 19:59:46 [WARNING] [IC2] API ERROR: ic2.advancedmachines.common.TileEntitySingularityCompressor@786901af didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true.
    2012-12-27 19:59:46 [WARNING] [IC2] API ERROR: ic2.advancedmachines.common.TileEntityCentrifugeExtractor@349153af didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true.

  • Came home to a 250 megabyte forge text file of these errors... this is a need to get fixed thing, unless gregtech can run without ic2?


    2012-12-27 19:59:46 [WARNING] [IC2] API ERROR: ic2.advancedmachines.common.TileEntitySingularityCompressor@786901af didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true.
    2012-12-27 19:59:46 [WARNING] [IC2] API ERROR: ic2.advancedmachines.common.TileEntityCentrifugeExtractor@349153af didn't implement demandsEnergy() properly, no energy from injectEnergy accepted although demandsEnergy() returned true.

    Well this particular error is caused by AtomicStryker's Advanced Machines, not IC2 :P.
    But yeah they need to add a config.

  • Lol, it's impossible that this message is coming from my Addon, as I accept all the Energy, which the E-net is trying to inject. If then the Energystorages are getting more than full, then its IC²s fault. :P