IC2 Experimental crash

  • Hello everyone,

    I've a big error when i start the game with all valids builds of IC2 Experimental : with and without gregtech, and with and without all other mods...


    I've tried to delete my config folder, but the game still crashed.
    Please help me x) I want to test this ! :)
    (I'm on mac)


    • Official Post

    I think I know the Problem, the experimental IC² needs a certain Library to be installed. I dont know from where to get said Library as I got it via the Build on Git. I'll ask Player when I see him, if that dependancy is really necessary.

  • Is there any combination of NEI/CCC that wouldn't cause an instant crash with IC2-experimental? I'd love to check out all the new nifty machines but not being able to see what they make kind of makes it hard :)

    Yes, I know it's a problem on NEI side. I'm just hoping some older version could work.

  • Ye, if someone knows - tell please recipes... and what is mor important - for power unit and small power unit. Can't start to play and test without chainsaw))

    Second law of thermodynamics!

  • centrifuge former and washer recipes wont appear in NEI ever if you manage to run ic2 with nei, nuke stats also wont appear, some coding required for this.

    Save this post forever, RawCode said something that wasn't rude!

    Age: 16. Favourite school subject: Physics/Chemistry.

    The IC2 forums could really use a lot more of [REDACTED], [DATA EXPUNGED] and ████████.

    I'm in a so called "after-school". It's freaking fantastic and nowhere near as boring as normal school!

  • I've tried the experimental build #44 and I did not need an extra library.
    It loaded up without an initial crash.

    Thanx so much for your continued work, this build appears to be working so far, the texture issues have been fixed apparently.

    However it happens to me repeatedly that the client crashes in certain places, something about connected textures:

    • java.lang.ArrayIndexOutOfBoundsException: -1

    • at ic2.core.block.BlockMultiID.getTextureSubIndex(BlockMultiID.java:110)

    • at ic2.core.block.BlockMultiID.func_71895_b(BlockMultiID.java:161)

    • at ConnectedTextures.isNeighbour(ConnectedTextures.java:705)

    • at ConnectedTextures.getConnectedTextureVertical(ConnectedTextures.java:792)

    • at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:307)

    • at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:194)

    • at ConnectedTextures.getConnectedTextureSingle(ConnectedTextures.java:97)

    • at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:55)

    • at net.minecraft.client.renderer.RenderBlocks.func_78598_k(RenderBlocks.java:3023)

    Here the full crash: http://pastebin.com/5XeKSjGX

    Maybe you can make sense of it.
    Disabling connected textures seems to fix it.

  • I was just about to remind everyone about the bug report thing, but now that I think about it, should we use that for the experimental builds? Under version there the latest is the 1.118.XXX ones, nothing about experimental.

    Is there a better place to be putting experimental bug reports?

  • Version 67 crashes if the reactors are set to steam output.

    Crash report follows:

    Haven't tried the newer versions yet, and it doesn't crash if the reactoers are set to EU output.

  • In version 47 of the experimental build painting cables works,
    in version 96 it does not.

    I have not invested the work to find out in which version the painting breaks yet, though.

    Just thought it good to be known so it can be fixed.

    Update: I tracked it down and it no longer works in build 87 and later.
    There greg checked a change in described as "Fixed Painter to use onItemUseFirst instead of onItemUse".

    Can you fix this?

  • Greg checked in a fix for the painter now which is available in experimental build 111. Thanx!

    I did notice that the texture of the painting marker is not perfect though (create a circle wire and painted one yellow and the yellow marking was seen again in the middle.)

  • Hi, I am not sure if this post is posted in the right place, but I will post it anyway...

    There is a bug with the cables. If I interconnect 2 MFSUs with just the Low Current Cable, one full - one empty. The current flow is right, since the other MFSU is filling up. Current between them should be 512EU/p... It should be sufficient to blow that link between two MFSUs, made of Low Current Cable, a.k.a Tin Cable...

    In fact, I've never seen any cables explode in any of experimental versions of IC2, since 2.0.108, i think... Right now I am checking 2.0.118, but - the same...

    Also - no electrocution of the player in the contact with the uninsulated cables of any kind...

    Together with the other stuff including not being able to get readings with the EU-Reader, this mod is near to unplayable ;( ... I hope they will get to fixing that EU coding - ASAP

    IC2 2.0.118 experimental
    Minecraft 1.6.2
    no other mods...

  • Do you need a specific version of Forge for this? Thermal centrifuge and Recycler have not worked since version with Forge .845. Also, what do you do with liquid UUmater? :rolleyes: