[GregTech-5][1.7.10-FORGE-1355+][Unofficial but approved Port][Stable] Even GT5 Experimental is slowly getting stable.

  • Marry me ^^

    That escalated quickly.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • btw. if u need just water - u should use drain cover on fluid pipe closely to water source

    Unfamiliar with this method. Would help to see how that's set up...


    My new question for the day, is how do transport pipes work now? And do Buildcraft Cobblestone pipes still work?


    Got a full blown bronze age working and trying to automate it from machine to machine to chest and then autocrafter ect. also, trying to find out how to differentiate where input / output ect is on machines now... going through the wiki isn't exactly helpful in this regard.


    What i'm trying to do -


    Steam Macerator - manually place product inside (ore) - Auto transport (pipes) crushed Ore to Steam Furnace - Auto Transport (pipes) the nuggets to autocraft table to make ingots - auto transport ingots to a chest (will do 2 chests once i find more diamonds so i can build a sorting pipe) and then have ingots go to Alloy Smelter and from there to a final chest.


    Steam connection (fluid pipes) are connected to the back of each machine in a line. Each machine is 1 space apart. Small boilers on each side of the assembly. Vent for each machine is facing to the right side.

  • If you want to transport items from something that isn´t an electric machine, you´ll need to set up an item pipe between the macerator and the furnace and then place a conveyor module cover where the pipe is connected to the macerator, than right-click it with the screwdriver and set it to import. Electric machine can output items and fluids, you don´t need pump or conveyor covers for them. I´d recommend that you automate the steam machines using hoppers.

  • How tool hardening is going to be like? Because I have been working on a big project where the Gregtech tools can be crafted with some parts to make the tools better. Thanks!


    EDIT:
    A small suggestion: tool could affect movement's speed of a player depending on material tools made from.

    Up (I hope it isn't permitted)

    My native language isn't English so I'm sorry in advance.

  • Fixing:
    - Fluid regulators not accepting fluids.
    - Maintenance covers not reporting turbine dying.
    - Required player opening inventory for turbine swap
    - Machine casing not conducting Redstone and controller block in the center (forced wireless bullshit)
    - Insanely low durability in Large Plasma generators.

    Before new features?


  • I agree, but that will depend on Blood Asp, who hasn't posted a message here or a commit on GitHub since about the end of April.


    Edit: he has been active more recently on the FTB forum, though.

  • Last activity
    Yesterday, 8:20pm


    He is still on the Forums, so he isnt dead or anything :P

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • Last activity
    Yesterday, 8:20pm


    He is still on the Forums, so he isnt dead or anything :P


    Is that IC2 forum activity? I couldn't find an indication of last activity other than last post in his profile.


    Anyway, good to know. Too bad we can't say the same for certain (afaik) about Binnie567 (the author of the addon for Forestry called Binnie's Mods).

  • only Friends can see that on his profile. maybe also admins but I am not sure

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • If you want to transport items from something that isn´t an electric machine, you´ll need to set up an item pipe between the macerator and the furnace and then place a conveyor module cover where the pipe is connected to the macerator, than right-click it with the screwdriver and set it to import. Electric machine can output items and fluids, you don´t need pump or conveyor covers for them. I´d recommend that you automate the steam machines using hoppers.

    Thank you, will research that one for sure. All greek to me for now, but sure i can figure it out pretty quick.

  • Ok... what did i do wrong? Followed the instructions... 4 tiers, bottom tier fully filled, 2nd tier has the blast furnance in a ring formation... 3rd and 4th tier in a ring formation... not working... and grrrrrrrrrrr!!!


    nvm, appears to be working... just very... very... very... slowly, and didn't do a "cover change" when the last piece connected like i've seen on tutorials. *shrugs* oh well, at least it's doing what it's supposed to

  • Ok... what did i do wrong? Followed the instructions... 4 tiers, bottom tier fully filled, 2nd tier has the blast furnance in a ring formation... 3rd and 4th tier in a ring formation... not working... and grrrrrrrrrrr!!!


    The structure looks okay as far as I can tell from those images. Did you put an iron ingot in the top slot? Since you still have a full stack of coal in the bottom slot, probably you didn't.

  • Ok... what did i do wrong? Followed the instructions... 4 tiers, bottom tier fully filled, 2nd tier has the blast furnance in a ring formation... 3rd and 4th tier in a ring formation... not working... and grrrrrrrrrrr!!!

    I dont see iron ingot in inventary. U try smelt ore or crashed ore? Just try iron ingot and i think u have lucky

  • yeah, tutorials i watched showed the image of the multiblock change when assembled properly. appears to be working when i put iron in it... going full bore, iron ore - macerator - crushed to smelter - nuggets to ore. put ore in and it fired it up... just... wow that's gonna take a while... well, gives me time to harvest my rubber farm


    can't make a conveyor though. not that far progressed to start automation. by the time i get there, i'll have electrical anyways, so useless

  • and recipes have changed a lot since the tutorial videos i have of GT5. This is insane. Thought i had enough materials to get started on electrical age... we'll see, but not entirely sure now.

  • and recipes have changed a lot since the tutorial videos i have of GT5. This is insane. Thought i had enough materials to get started on electrical age... we'll see, but not entirely sure now.

    If it would help, there are my videos about progress on GT 5.09
    https://www.youtube.com/watch?…p3srNzkR3PdkIr9t7&index=2
    I speak Russian, but using English language in MineCraft options, so i hope u could understand something :)

    Ideal Industrial Assembly (IIA) - my pretty hard industrial modpack based on GT5.09

    Идеальная Индустриальная Сборка (ИИС) - довольно сложный сугубо индустриальный модпак, базирующийся на GT5.09

    http://sapientmail.wixsite.com/minecraft

  • actually, it does help, like Bear99 or... sorry... been drinking and names not 100% remembered, but something like that... good to see a play through for style ect.


    now, another problem i see in both videos, yours and his, vs mine... i have "timber" from axe = true in config, but when i hit a tree with axe... i still have to go block by block... wondering if another mod is controlling that, if so, i can't find it Searched config front to back and can't find anything in there to conflict with it. So it must be an actual programming confliction between some mod or another.


    oh, and i do have vanilla ores turned off in GT config... but still getting some (not a lot, but some) from other mods
    Diamonds and gold i've gotten were primarily from mobs from other mods (which GT controls ores, not mobs... and thankfully, since i LOVE MoCreatures... but that's not the one to give me those). So, it's rare, by mob standard AND drop rate... so, not QUITE as rare as actually mining it, and i don't have to actually have a pick strong enough to. So, that's how i've been getting my ore, saved diamonds from said mobs to make a diamond pickaxe to mine all the ore i need and using stone / flint pick axes for everything else that doesn't need it and have a decent stockpile saved up so far from the mine / caves i've found... left a lot just because with specific veins of ore, inventory fills up faster than i can handle. So, grab all i can, then move to next when in a mine / cave / dungeon.


    that and my night / day cycle is a LOT faster than these guys...

  • now, another problem i see in both videos, yours and his, vs mine... i have "timber" from axe = true in config, but when i hit a tree with axe... i still have to go block by block... wondering if another mod is controlling that, if so, i can't find it Searched config front to back and can't find anything in there to conflict with it. So it must be an actual programming confliction between some mod or another.


    The timber axe option in the GregTech config only applies to the GregTech metatool axes. If you're using vanilla-style axes, or axes from some other mod, it won't apply.


    Edit: Blood Asp, I can somewhat understand you being busy, but I didn't think you'd be so busy that you'd be unable for nearly a month to even post a message to explain what was keeping you busy. However, now you have, so we can try to be patient.

  • It seems some are missing me and the updates.


    I'm currently in the last weeks of writing my final thesis and quite busy.


    I will be done next month, but not sure how soon my activity here will improve again.


    Best of luck for your thesis!


    But it wouldnt be me if I hadnt another question..
    I'm trying to add an assembler recipe for tin cable. But I can't get it to work.
    the command is:


    mods.gregtech.Assembler.addRecipe(<gregtech:gt.metaitem.01:1246>, <gregtech:gt.metaitem.01:1240>, null, <liquid:molten.rubber> * 144, 100, 8);


    If I load the script I get the eror:


    Error executing Custom.zs:
    [Lnet.minecraft.item.ItemStack; cannot be cast to net.minecraft.item.ItemStack]


    If i change the second input from "null" to "<minecraft:stone>" the script loads but the recipe doesent show up in NEI and doesent work in any assembler.


    Would anyone like to help me? Thanks in advance.


    While Im at it: Why are the first two digits after gt.metaitem alsways "01"