[1.4.2] Open Beta v1.108

  • So I started playing this today..no real "bugs" yet, no ctd's or anything like that, however I am getting a weird Graphical Bug I believe, unless the look was changed and I'm behind. I'll link a screenshot of the bug, but safe to say any cables I place are these huge full block versions of themselves, making them extremely bulky and well..ugly. Anyways, Screenshot below.

  • Wonderful thanks RichardG, one other thing I forgot to put in my above post..um, everytime I exit my world or game and re-enter, a new Beta Information book is put in my inventory, and while it's not a huge deal it's kind of annoying when I'm experimenting and exiting and re-entering and suddenly have a full inventory of books.

  • Well, after removing all my mods aside from Optifine, IC, and Forge it still did it, so I'm assuming it might be something I did accidently in my Jar that's not showing up in my Forge list, oh well. I'll try reinstalling it all later just to be sure.

  • I also get the book every single time I enter the world....was running build 52...ill post later about 57 I just downloaded it.
    Oh and I have these mods + flat bed rock layer wich is a jar mod messing with aac and zy classes
    ---- Minecraft Crash Report ----
    // Shall we play a game?

    Time: 10/28/12 3:57 AM
    Description: Exception in server tick loop

    at java.util.HashMap$HashIterator.nextEntry(Unknown Source)
    at java.util.HashMap$KeyIterator.next(Unknown Source)
    at hz.a(EntityTracker.java:202)
    at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:653)
    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:585)
    at bcb.q(IntegratedServer.java:110)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:492)
    at fp.run(SourceFile:818)

    Relevant Details:
    - Minecraft Version: 1.4.2
    - Operating System: Windows 7 (x86) version 6.1
    - Java Version: 1.7.0_07, Oracle Corporation
    - Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    - Memory: 167319984 bytes (159 MB) / 519110656 bytes (495 MB) up to 1037959168 bytes (989 MB)
    - JVM Flags: 2 total; -Xms512m -Xmx1024m
    - AABB Pool Size: 8981 (502936 bytes; 0 MB) allocated, 3287 (184072 bytes; 0 MB) used
    - FML: MCP v7.19 FML v4.2.6.422 Minecraft Forge Optifine OptiFine_1.4.2_HD_U_A7 16 mods loaded, 16 mods active
    mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    mod_CodeChickenCore [CodeChicken Core] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    mod_NotEnoughItems [Not Enough Items] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    mod_ReiMinimap [mod_ReiMinimap] ([1.4.2]ReiMinimap_v3.2_05.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    ComputerCraft [ComputerCraft] (ComputerCraft1.46.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    CCTurtle [ComputerCraft Turtles] (ComputerCraft1.46.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    EnderStorage [EnderStorage] (EnderStorage 1.2.1.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    IC2 [IndustrialCraft 2] (industrialcraft-2_1.108.52-lf.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    mod_InvTweaks [Inventory Tweaks] (InvTweaks-1.44-1.4.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    IronChest [Iron Chest] (ironchest-universal- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    Millenaire [Millénaire] (millenaire3.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    Mystcraft [Mystcraft] (mystcraft-uni-1.4.2- Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    Railcraft [Railcraft] (Railcraft_6.7.0.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    TreeCapitator [TreeCapitator] (Treecapitator.FML.1.4.2.r01.Universal.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available
    - Is Modded: Definitely; 'forge,fml'
    - Profiler Position: N/A (disabled)
    - Vec3 Pool Size: 1117 (62552 bytes; 0 MB) allocated, 955 (53480 bytes; 0 MB) used
    - Player Count: 1 / 8; [ih['MaryuZ'/78, l='1.4.2 at last', x=-748.98, y=63.00, z=-41.11]]
    - World 1.4.2 at last Entities: 0 total; []
    - World 1.4.2 at last Players: 0 total; []
    - World 1.4.2 at last Chunk Stats: ServerChunkCache: 0 Drop: 0
    - Type: Integrated Server

    mcmz4e aka MaryuZ aka 2.muCh.Pride

  • Cables are still big sized, they only shrunk just a wee bit.
    Is this intended. ?
    Are cables going to be to their previous size or is this the new thing thats happening.?

  • Even with a fresh install on build 57 I get the book every time.

    Hey Richard? Is it possible to create a config flag for giving the book? This could help as once the book in given, the code would change the flag to false or something and save that. Might crush this little problem that this guy is having.

  • Whelp, one less reason to not update yet.

    Though I'm curious; since we have potatoes and one can grow them via crops(a much needed feature for me), does that mean we also have vodka? As in take potatoes, and some water, in a booze barrel?
    I would enjoy something to warm me inside in my glacier base. Which I obviously haven't built yet, due to not actually playing 1.4.2 yet, and needing to get the mods I need for this base before doing so, but I digress.
    And no, fire is not a good idea in a glacier base. Too big of a chance for stuff melting and making a mess.

    Apprentice Redstoner, Professional Slacker

  • Not sure if it is a bug or just my setup.

    The quantum leggings make you run all the time, pressing ctrl does nothing. Can anyone duplicate this to make sure it isn't just me?

    Also, while the helmet and boots (quantum) are drained of energy, the leggings currently do not drain.

    Am using 1.108.57 of IC2
    a few other mods, most likely not significant for this bug.

    Hell, prove me wrong, Happy to be so 99% of the time, then I can learn stuff :)

  • change your config and it will be ctrl look in the config for the leggins

  • Is there a way to automatically downlaod the last build of ic2? Directly in your mods folder? That would be nice, so everyone could test the same version and resolve some confusions...
    Also, testing the new build :D

    Minecraft.... so annoying and so funny! <3 :Nuke TNT:

  • Ok, after a quick review of the new build, I found:
    - Now cables are OK.
    - Wrong hitboxes on iron fences.
    - The luminator block and the graphic shown in the item doesn't correspond.
    - Unnamed black block (?)
    - Still no sounds for ITNT and NUKES
    - Unnamed thing in the NEI like a door but when you put in the ground it's like a flower pot.
    - Also, some items like iron fences and the luminator doesn't appear on the minecraft's cretive menu, you must use NEI.

    I hope I helped a lot :D

    Minecraft.... so annoying and so funny! <3 :Nuke TNT:

    Edited 2 times, last by TheArni: My english isn't correct after all... D: ().

  • 50k EU to remove wither effect?!?!
    That's a lot.

    Fusion Power Engineering Industries® Making Fusion™ Automation Chamber© is DONE!!!!!!!! HAYO!!!

    Hint: Click the Automation Chamber text to see how it looks :D

  • Well:

    2) Hazmat suit break any types of defence by providing complete invulnerability to tesla coils.
    3) Tesla coils 2 times weaker then HV cable with 2048EU current...
    4) Still not disabled sounds by default eh?
    5) Luminators still suffer from TE ghosts bug (not noticed soo long time since they completely useless, if you have some time, add armored glowstone better...
    6) Electric hoe can't break any block but will consume energy in process
    7) NV googles does not work, they will provide 10 blindness but never provide infravision, clockrate on googles too fast, it shoud provide effect every 2-5 seconds, not every tick.

    not checked code yet (not ever set MCP, ecpected source with 140) but i perfectly sure, that wither will break personal blocks and do other awfull things to IC2 machines.

  • Is it intended that only the armour, chainsaw, reinforced armour, terra wart and the canned food aren't in the IC2 part of the creative inventory?
    It's quite confusing, and definitively lacks a consequent concept.

    (I'm running 108.57 with forge 341)