[1.4.5] Open Beta v1.109

  • It works, but you can also update to 397, if you want. Like, three posts above yours someone mentions Forge > 397 made some API changes that break this version of the beta (1.109.113, for future reference).

    I did see that, but I have other mods... and I dont want to risk updating forge and breaking them too... thanks.

  • Hi, I'm just starting with IC2 and I have some issue with IDs. Conflict is probably between buildcraft and ic2. I changed conflicted IDs manually and it works good in single player.[...]

    Strange... I've been running IC2 and Buildcraft together for a good long time now and have never had a block or item ID conflict between them. As far as I can tell, IC2 takes 216-250 and Buildcraft takes 150-172. Likewise IC2's item IDs are in the 29xxx range (unshifted), and Buildcraft hangs out around 3800-ish (unshifted). Not a conflict to speak of between them.


    As for your error, IC2 says earlier in the log

    Quote

    [WARNING] [IC2] Error while trying to access configuration! java.lang.RuntimeException: unknown character :

    , which presumably means you have a : in there where it shouldn't be. Really, the only ones in the whole file should be on the "Generated on" line and the valuableOres setting.

  • Thanks narc, I changed that. Server started without error when I deleted :. But then I wanted to test if all will work properly. I made 2 wooden gear, no error. But then I wanted to check redstone engine. Recipe was good, everything ok, but when I took engine from craftbox, client crashed.
    I must say, that before I changed IDs, recipe for one engine had Nuke or Industrial TNT instead of gears. And with the sticks I made some strange red wire instead of wooden gear.


    Error in server console:


    Error in client:



    I haven't changed anything by myself. I'll add to this post screenshot for making wooden gears without changed IDs.
    EDIT: Here is ss with clear BC and ID2, without changing anything: http://i49.tinypic.com/2v9ufpj.png

    The post was edited 1 time, last by Ethelnalen: Adding SS ().

  • Looks like your server and client are really just not agreeing with each other. I don't know what you did there, but I'd advise deleting the configs and letting them all regenerate.


    ...and making sure they're identical between client and server.


    Although, either way, this is not an issue with IC2.

  • Maybe I'll try to install forge and everything again and then we will see if it will help.


    EDIT: For the god's sake... I should start with reinstalling everything at first place. Sorry for this, reinstalling helped and everything is OK. I'm so stupid... The easiest ways to fix something are sometimes the hardest to find. xD

  • ok, i'm using Buildcraft and the beta of IndustrialCraft2 for 1.4.5 and when i try to build items for BC i get IC items even if there is no relation. e.g trying to make a wood gear gives me a red stick with no name and if i try to use that red stick as a wood gear to complete the recipe for a stone gear i get a nuke, if i use the nuke and put iron around it as i wood if it were a stone gear to make an iron gear then i get industrial TNT. All the IC recipes work normally, but ALL the BC ones give me something random from IC as above. thoughts? suggestions?

  • ok, i'm using Buildcraft and the beta of IndustrialCraft2 for 1.4.5 and when i try to build items for BC i get IC items even if there is no relation. e.g trying to make a wood gear gives me a red stick with no name and if i try to use that red stick as a wood gear to complete the recipe for a stone gear i get a nuke, if i use the nuke and put iron around it as i wood if it were a stone gear to make an iron gear then i get industrial TNT. All the IC recipes work normally, but ALL the BC ones give me something random from IC as above. thoughts? suggestions?

    Your Item Ids are most likely conflicting?

  • ok, i'm using Buildcraft and the beta of IndustrialCraft2 for 1.4.5 and when i try to build items for BC i get IC items even if there is no relation. e.g trying to make a wood gear gives me a red stick with no name and if i try to use that red stick as a wood gear to complete the recipe for a stone gear i get a nuke, if i use the nuke and put iron around it as i wood if it were a stone gear to make an iron gear then i get industrial TNT. All the IC recipes work normally, but ALL the BC ones give me something random from IC as above. thoughts? suggestions?

    You have the same problem like me. Just reinstall all mods using mineforge .397. That should help

  • Buildcraft latest release has conflicts as such:



    Latest release is 3.2.0:


    http://www.mod-buildcraft.com/…-2-0-for-minecraft-1-4-5/

  • I am getting this (server-side) error and kicked off the server when breaking Twilight Forest root strands with Chainsaw


  • thanks for the information, but how do i fix it? i've tried IDResolver and switching to an earlier version of forge (.397 and all the ones around it) and it eather won't load any mods and just crashes or tells me that the hooks are "disabled or not working so no errors will be resolved". i've tried wiping the entire folder clean and starting fresh several times loading the mods in different orders but i get the same results. i'm running 64bit windows 7 if that changes anything.

  • Hello, I have this crash when I load the world, in the mail menu all ok. Im using a 403 Forge build.
    This error appearing when ic2 installed.
    This is a crash-report: http://pastebin.com/b6HBAGGP
    And full: http://pastebin.com/urJp1fz2
    P.S. Sorry for my bad English:( :love:

    Install this fix from mistaqur, this should work (this bug is caused by an update from NEI)

    The person who finds any spelling errors can keep them by himself. Sorry for the bad knowledge at all, look at my age and my country. Sorry for any inconvinience.


    Greets!

  • New CodeChickenCore and NEI released. ChickenBones fixed the bugs! No need for the fix from mistaqur with the newest release of ChickenBones mods.