[GregTech-5][1.7.10-FORGE-1355+][Unofficial but approved Port][Stable] Even GT5 Experimental is slowly getting stable.

  • I just discovered that smelting crushed iron ore produces an iron ingot, instead of 10 iron nuggets, as it did with GT 5.07.07. I guess it's not really a big deal, but was that a deliberate change? For the "ite" ores (e.g. chalcopyrite, limonite), NEI shows me that those crushed ores also smelt to ingots, while before they would only give 3 nuggets each (unless I hammered them to impure dusts first).

  • Can anyone tell me how to build and use the distillation tower? What fluid goes in it?
    I tried following the blueprints in the machine its self, but can't seem to get it to accept any fluids into it - I guess it would help If I knew "what" goes in and what should come out.

  • Can anyone tell me how to build and use the distillation tower? What fluid goes in it?
    I tried following the blueprints in the machine its self, but can't seem to get it to accept any fluids into it - I guess it would help If I knew "what" goes in and what should come out.


    I found this documentation on the distillation tower (presumably from an older version of GregTech):
    http://ftbwiki.org/Distillation_Tower_%28GregTech%29
    I don't know how much Blood Asp has changed it from that, though.

  • Hey Blood Asp,


    With version 5.08.01 i'm getting a bunch of weird recipe changes, such as


    Alloy Smelter: 2x Caesium Ingots + Mold (Casing) -> 3 Gold Item Casings (IC2).
    Smelting: Vanilla Hopper -> 9 Draconium Ingots (From Draconic Evolution mod, also HEE Endium Block turns into 9 Awakened Draconium Ingots)
    Almost all Polarizer recipes only giving Magnetic Iron rods


    I'm still trying to see what else seems changed, but these are some weird examples. None of this behavior is seen in normal GT 5.07.07 and Forge < 1355 with all other mods exactly the same. Any ideas off the top of your head what might be causing this?

  • I checked fusion reactor recipes. One uses lutetium, and I didn't find how to get it.

    It comes from depleted thorium fuel rods.

    There seems to be a quite big problem with the ore processing loader. In the end likely only a wrong char somewhere, but who knows how difficult it is to find it.

  • It comes from depleted thorium fuel rods.

    There seems to be a quite big problem with the ore processing loader. In the end likely only a wrong char somewhere, but who knows how difficult it is to find it.

    There are also problems with hoppers and the bronze machines and it looks like the 5.08 reenabled the IC2 recipes of electronic circuits and advanced circuits.

  • There are also problems with hoppers and the bronze machines and it looks like the 5.08 reenabled the IC2 recipes of electronic circuits and advanced circuits.


    What problems exactly?


    Also found the reason why the oreprocessing is broken and why ore textures are wrong.


    But at last i now get bugreports. That no one noticed this until now...

  • The Hopper thing is a Problem of the Hopper in general. Checking Recipes every single Tick is not a good thing, but the Hopper causes it to happen.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)


  • What problems exactly?


    Also found the reason why the oreprocessing is broken and why ore textures are wrong.


    But at last i now get bugreports. That no one noticed this until now...

    The hopper inputs in ALL slots of the machine, not just into the input slot. And it outputs items from the input slot, not just from the output slot. That means it takes out the ores from the macerator instead of the crushed ores, making automation almost impossible.

  • First of all I want to thank you for brining the fusion back :D
    So I tried building one in creative and did it mosly like in the old version. Fusion coils surrounded by casings mark 2, a mark 3 controller where the normal controller would be, I put 2 input hatches inplace for the fluids (they changed textures so im sure they got recogniced) and I also put some energy hatches (the ones for inputting). And i also put in a output hatch for the plasma to come out.
    Do I need a mainance hatch? if yes where does it belong(could find a place where it changed textures like the other ones). With my setup i also was unabled to to use the rubber hammer(after insterting power(maybe I need more (24k/t) I inserted tritium and deuterium but it didnt want to start.
    Is there/will there be a energy bar for how much it already got inserted before it will start (the starting power/kick off) will be visible, basically how much is stored inside the fusion.
    Maybe a picture where things belong if you open the fusion interface or an image that would popup if you used a special item(maybe even a craftable book/map kind of thing where you could see something similar to the old fusion interface.
    And of course every Hatch is in UV.
    Before supplying the power with solar panals via MAX transformers I tried to use Plasma generators but they didnt seem to accept Helium plasma from bedrockium/normal drums using pipes/conduits o somehting silimar and universal Fluid cells did also not insert any Helium plasma/nitrogen plasma into the generators (tried tier 1-3)


    Even though i got a few questions here its really amazing that you brought the fusion back :) Thank you very much I really appreciate your work

  • The hopper inputs in ALL slots of the machine, not just into the input slot. And it outputs items from the input slot, not just from the output slot. That means it takes out the ores from the macerator instead of the crushed ores, making automation almost impossible.

    I allready tought it was such a big problem. As allways likely just a small decompiler mistake.


    About the OreProcessing not working correctly:
    Every Swich/Case using Enums got broken


    Code
    1. switch (aPrefix)
    2. {
    3. case crushed:
    4. case crushedPurified:
    5. case crushedCentrifuged:


    turned into


    Code
    1. switch (aPrefix.ordinal())
    2. {
    3. case 1:
    4. case 2:
    5. case 3:


    And that is just wrong...


    Even though i got a few questions here its really amazing that you brought the fusion back :) Thank you very much I really appreciate your work

    So i better should answer your questions. ;)


    I plan to add the right GUI, but that has low priority. You can check the internal buffer with the scanner.
    Each Energy Hatch adds 10mioEU to the internal buffer and can provide 2048EU/t, doubleing with each tier.

  • Ahh ok thats fine, I guess its that I just used 2-4 energy hatches.. now that I think of it ^^ you sure can take your time, I got a lot of digging/quarrying to do before i can even built all that stuff ;) Just wanted to check it out and test it alittle.
    And what is with the plasma generators? are they not working or did I something wrong? couldnt get the plasma in at all (neither of them)
    And again thank you very much for your efford

  • Ahh ok thats fine, I guess its that I just used 2-4 energy hatches.. now that I think of it ^^ you sure can take your time, I got a lot of digging/quarrying to do before i can even built all that stuff ;) Just wanted to check it out and test it alittle.
    And what is with the plasma generators? are they not working or did I something wrong? couldnt get the plasma in at all (neither of them)
    And again thank you very much for your efford


    Testing it in my dev enviroment i could fill in plasma just fine.
    Are you maybe using a forge version prior to 1355 (like 1263) in an old work? That again mixes up the fluid ids...

  • Ohh yeah that could be we are at 1352 atm (we are testing our update atm with 1381 will be out in about 10-20 mins, will edit if it works (I gues it wil then, didnt have those cells and so on in mind when thinking about the fluid update of forge hehe :) thanks for clearifying that