[Addon 1.112] BuildCraft-IndustrialCraft Crossover Mod v2.0[SSP/SMP]

  • found and mushed. Dare I ask why you were trying to power a wooden transport pipe?


    Not quite sure what you mean... What am I supposed to power? I need to pump out items from IC2 machines and other stuff.


    ps To reproduce the bug you can try a lever to activate the engine. Just switch it on/off quickly.


    pps There is another bug - it seems, that engines limit an IC2-energy packet size.


    To reproduce: put induction furnance and 10-12 small engines to 1 common wire (I took fiberglass). Engines must be not activated. Power source may be any (MFS-T2-T1 in my case). Then run a furnance and measure power on it. There are 12 engines on screenshots, and only 8 eu/t to furnance (must be 16), and only 8 taked from MFS, so the engines don't consume any eu.


    img 1, power to furnance


    img 2, state of the furnance, it shows the furnance don't have enough energy


    img3, power taked from MFS, measurement is performed on fiberglass under crosshair



    modloader.txt the same

  • OK, so you have engines powering other engines, which themselves have nothing to work on.


    Either your screenshots don't convey your actual setup, or you definitely don't understand how engines work. What is it you're trying to do there?

  • I'm trying to say that no matter of what engines powering. They actually off (no redstone signal). The only 1 consumer is induction furnance. Why it receives only 8 eU/t (must be 16)?


    When there are no engines powered from the same power line (or only 1 or 2), the furnance getting full power (16 eu/t).

  • I'm trying to say that no matter of what engines powering. They actually off (no redstone signal). The only 1 consumer is induction furnance. Why it receives only 8 eU/t (must be 16)?


    When there are no engines powered from the same power line (or only 1 or 2), the furnance getting full power (16 eu/t).


    It seems he's right, even though the engines are inactive and they're not consuming EU (after the capasitors are full). They're still somehow flagged as 'needing EU' thus the EU supply is split up and the induction furnace only gets a small share of the EU.

  • Whenever i open the petrochemical generator gui in smp , bukkit.
    i crash , minecraft freezes and goes into blackscreen, whenever i open the gui from the petrochemical generator.
    the error i fetched usen a batch file start:


    Version info:1.18 both server as client


    (Note : i typed the error , i had it on another screen, there might be a typo)
    any help would be appreciated
    also , ignore some of the lines behind behind eachother , i dunno what it is , but i cant force them in new lines

  • Apologies if I've missed this being requested earlier, went through all 26 pages and didn't find it though.


    Would it be possible to add a small* (possibly optional?) EU requirement to redstone engines, inline with the ratio of BCE:EU that other engines use? Trying to have a "nothing free, nothing with no real world equivalent**" game, and redstone engines are - while limited - free energy.


    * Steam/Small electrics produce what, 1 BCE/tick? Maybe have redstones use 1 EU/cycle?
    ** Within the obvious limits of minecraft - not many creepers and dragons in England. None outside Parliament anyway...


    Fantastic mod by the way, BC engines have been firmly relegated to ingredient only status now!

  • Not quite sure what you mean... What am I supposed to power? I need to pump out items from IC2 machines and other stuff.


    I mean you were using a wooden transport pipe, you need to use a wooden conductive pipe to transport energy.


    ill look into it for the next version.

  • don't wish to change spacetoad's code in that manner. However, he has stated he plans to redo the redstone engines at some point. The equivalent EU usage for a redstone engine would be 0.125 EU/t.

  • Question:
    Any other way besides the zip name to force the add-on to load after IC? Nothing I do seems to get to load last.


  • Actually, it's not so much as this addon loading before or after IC, it should be loaded before Buildcraft (At least that was the case a version ago)

  • Receiving the Same error of Crossover loading before IC2, but my version of Crossover the name of the zip is "zBCIC2crossover server v1.24.zip"
    Any other reason why IC2 isn't loading before crossover? (IC2 Jar name is "industrialcraft-2-server_1.70b.jar")

  • Question:
    Any other way besides the zip name to force the add-on to load after IC? Nothing I do seems to get to load last.


    Receiving the Same error of Crossover loading before IC2, but my version of Crossover the name of the zip is "zBCIC2crossover server v1.24.zip"
    Any other reason why IC2 isn't loading before crossover? (IC2 Jar name is "industrialcraft-2-server_1.70b.jar")


    Both of you: What OS are you running? ModLoader/ModLoaderMP should sort themselves but at least in the case of Linux MLMP stopped doing such again.
    There's an "interesting" workaround involving dd and creating a small fat32 filesystem if you've got root permissions (as one needs to mount said filesystem)

  • I Just thought I would pop in to make a suggestion (I don't know if it has been asked before). would it be possible to add support for the use of bio-fuel (refined bio-mass) from the forestry mod in petrochemical generators? (I realize that would mean that they are no longer true petrochemical generators).


    It would help me out a lot.