[1.4.2] Open Beta v1.108

  • java.lang.IllegalArgumentException: Slot 241 is already occupied by ic2.common.BlockRubSapling@9d4f7b when adding codechicken.enderstorage.BlockEnderChest@1cd5320
    </init></init></init>

    Two blocks with the same blockID. Change either of those in the IC/enderstorage configuration file to fix it.

  • I think there is an issue with steam outputing reactor, in multiplayer, it will not output steam until you build railcraft firebox and boiler. Dont know if its ic2 or railcraft issue. It does not happen in singleplayer, only on dedicated server.

  • I have bugg, which was in forum, but it's not solved - don't play any sound of IC2. For example, if put in nucelar reactor uranium then any sounds doesn't play.
    And second bugg - it's drop armor. When I want to wear any armor and close inventory then armor is droped! There no that problem in creative mode.


    P.S Sorry for my English.

  • Water Mill :Water Mill: and Wind mill :Wind Mill: don't work. Although, I place it according to the instructions. Why doesn't it work?

  • Updated to 1.108.71, adding EXPERIMENTAL Railcraft steam outputting reactors. I also separated the energy part from the core reactor, so there MAY be bugs with the regular reactor.


    To enable them, you gotta set enableSteamReactor to true in the config, then reactors will output steam, balanced vs. the turbine output.


    Exactly how much steam do these output, and how can that steam be conveyed to a steam turbine? A gold waterproof pipe can only carry at max 40 units... and there are only 18 possible output faces on a 6 chamber reactor. I think 18. Each steam turbine needs 160 steam units to run at 100%, so that's 4 pipes. 18 output faces at 4 per steam turbine means at most 4 steam turbines.

  • Teleporter doesn't work. When build it server crash. There is log:


    ---- Minecraft Crash Report ----
    // Oops.


    Time: 13.11.12 20:04
    Description: Exception in server tick loop


    java.lang.ClassCastException: net.minecraft.server.EntityItem cannot be cast to net.minecraft.server.EntityHuman
    at ic2.common.TileEntityTeleporter.teleport(TileEntityTeleporter.java:159)
    at ic2.common.TileEntityTeleporter.g(TileEntityTeleporter.java:115)
    at net.minecraft.server.World.tickEntities(World.java:1313)
    at net.minecraft.server.WorldServer.tickEntities(WorldServer.java:454)
    at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:548)
    at net.minecraft.server.DedicatedServer.r(DedicatedServer.java:219)
    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:475)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:401)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:818)

  • Anyone know why windmill don´t work?
    I placed windmill at the correct altitude and that simply seems to don´t recognize the wind...

  • Fresh copy of Minecraft 1.4.4, fresh copy of Forge 6.3.0.372, fresh copy of the IC2 dev build on the front page.

    I didn't even have to read the error log, reread the title of this thread, specifically the part in [].

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

  • Hmmm I noticed something and it might or might not be related to IC2 but the IC2 copper and TIn appears to not be deposited into the miner backpacks from Forestry.

    Check the configs of Forestry, probably the wrong id's there.

  • Nope... not the wrong id's most of the time I don't need to add id's to the config for backbacks... actually I've never tired successfully, every attempt to add ID's to the backpack configs ends up with my game not wanting to run.